Web Development



Can't Access www.Google.com

By pjcannon ·
WinXP Pro SP2 Desktop. All updates applied. Computer crashed when applying DST updates to Outlook 2003. Since then can't access www.google.com except by ip address. This computer can access any other website by url. Identical computer in the same LAN can access google by url. Tracert from affected computer times out during the 6th hop. Tracert from other computer completes in 8 hops. I can put an entry in the hosts file and get to the website by url then but none of the links from a search then work. No Viruses or spyware on the pc. I have flushed dns, reset the tcp/ip stack, reinstalled the nic drivers, installed a different nic, done a repair install of XP. Problem repeats. Any ideas other than a complete reinstall.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

May be a quick fix but google now works

by lee_eardley In reply to Here is something

Open c:\windows\system32\drivers\etc and check out the host file..

You will find that there is a list of all google web sites.
Rename the host file to host.old and then restart
This has worked so far and have no other side effects after for 1 week now.

Collapse -

weird. you tried safe mode w networking, yes?

by sgt_shultz In reply to Can't Access www.Google.c ...

no proxy, no firewall...huh. weird.
if dns is configured the same on a box that works and this one that doesn't - i am out of ideas. post when you figure it out and let us know?

Collapse -

Safe Mode

by pjcannon In reply to weird. you tried safe mod ...

Tried safe mode with networking and got the same results

Collapse -

I am pretty much with

by w2ktechman In reply to Safe Mode

Sgt Schultze on this, it really does not make sense unless the URL is being blocked on that particular system. For that to happen, it needs to be blocked via policy, firewall SW, Internet Settings, etc.. Since these were all looked over, this really does not make sense. I would move to your router, but other systems work fine so the problem is not there. And since all other sites work fine, I doubt that it is a DNS issue.
Tell us, is Google.com your home page (or was it when the failed patch was installed)? If so, maybe that was grabbed and put with a setting somewhere (unlikely, but grasping at straws) in IE settings.

Scour the registry for google.com and post back all aspects of it along with path's. It has to be somewhere.

Collapse -

Grasping at straws

by pjcannon In reply to I am pretty much with

Grasping at straws is pretty much where I am. Google is not the home page. The problem occurred after a crash with automatic updates. I can't find anything blocking google anywhere. The only thing I find is when doing a tracert www.google.com it times out either on the 5th or 6th hop in Atlanta. No other website is affected. I searched the registry for google and deleted all references to it. It has become one of those issues that would be less time consuming to wipe & reinstall but that is rather boring and not paticularly satisfying. and I have a stubborn streak and really just want to figure out the cause now so I will invest a bit more time and effort.

Collapse -

Another Grasp

by w2ktechman In reply to Grasping at straws

however I do not see why, try deleting the 'all users' and 'default users' profiles and reboot.
they should be re-created upon bootup. Save them somewhere else first in case of a problem.

Does anyone know if this will trigger a reactivation of XP???

Collapse -

Delete Profiles

by pjcannon In reply to Another Grasp

I will try this and post what happens. It will be the weekend before I can do this, there is an extensive amount of software on this computer. I suspect that even if it works I will do the wipe & reload anyway.


Collapse -

Sounds like time for a re-load

by jdclyde In reply to Can't Access www.Google.c ...

Have you looked in Task Manager at the memory consumption?

If your using more than 120/140 right at bootup, you probably have a root kit running on your system.

Back up your data, wipe and reload.

Collapse -

same problem

by thesexiestguy In reply to Can't Access www.Google.c ...

i m also having the same problem.
i m using wired lan.
can't access www.google.com.
n gmail as well as googletalk.
all three services are not available.
ping ok.
other sites ok.
i can use proxies like www.polysolve.com to use google n gmail.
if i use proxy like that i can use them.
i can't use google on other networks also such as my school lan.
reset everything.
scanned my computer also.
before this happens,i have a virus attack.
but now everything is cleared.
may b i need to format my harddisk again.
don't wanan do so until necessary.
but google was my homepage before all these happens.
suggest lab in google toolbar can suggest though.
but whenever i tried to access google.com,my firefox shows that unable to connect.
i have installed other browsers like opera,avante apart from the onboard ie.
i think may b it is a virus or the old virus has cause something wrong.
any idea?
plz help.

Collapse -


by thesexiestguy In reply to Can't Access www.Google.c ...

man,now after i posted here,
i did further search.
i hope that u have not formatted ur system.
i traceroute www.google.com using visualroute program.
n i found that visualroute said that,the trace return is so fast.
n guess what,
it also said that www.google.com=localhost.
n then i search for this issue.
n found that it is in my host file.
i found that file as windows\system32\drivers\etc.
n shazaam,when i opened it with notepad,
it shows that is www.google.com.
that damn virus has changed it.
n then i changed it back to localhost.
n now i can use www.google.com,gmail.com and googletalk as well.
i hope u have the same problem with me.
n u can solve it b4 formatting ur harddisk.
since my localhost is www.google.com,
whenever i use that url,it comes back to my localhost,n since i m not running google on my laptop,i can't get anywhere n end up as unable to connect.
thank god that now it is solved.
here is the link to the answer,
n one other thing is,the lines in my host file are changed by CiD or something.
here is also another explanation.
and one last thing is,
i have downloaded and run this tool from symentac.i don't know whether it can help,but since i suppose this is done by some malicious software,i think i better scan with this tool.i m not sure abt the results,coz it is still scanning when i m writing this.
hope this can help u.

Related Discussions

Related Forums