Catalyst 4500 Series Switch Cisco

By kenneth.w.jones ·
I have a 4506 Catalyst Switch that I can no longer telnet to. It comes back with the statement:

"Could not open connection to the host, on port 23: Connet failed"

The line vty has a password, login, and transport input telnet configured.

It worked previously, not sure what has happened. Any suggestions?

Tks in advance for any help.


This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Its simple...

by Fregeus In reply to Catalyst 4500 Series Swit ...

..but I have to ask, can you still ping the switch?

If not, then you need physical access to the switch, a laptop and a console cable.

If you can ping the device, can you telnet to other switches from your location (other switches or servers)? If yes, then you need physical access to the switch, something has changed in its configuration and you need to investigate.

If not, then there is probably something wrong with your set up or your telnet application.


Collapse -

Telnet to Switch

by kenneth.w.jones In reply to Its simple...

I can ping the switch from another switch but when I try to telnet from the same switch I get "%connection refused by remote host"

I have several switches inside a Pixs firewall that I manage and I can connect to everyone but this one.

There has to be something in the configuration that is preventing the connection - I just don/t know what....

Tks for reply

Collapse -


by John.Schupp In reply to Telnet to Switch

You will need to access the console of the switch with a laptop and a console cable. Then you can check the log to see if there are any errors in the switch, and you can double check the configuration to see if any changes have been made recently.

Collapse -

Check your vty config

by Fregeus In reply to Telnet to Switch

You'll have to go to the switch and log on to the console. Check the vty config. Make sure you have sessions configured. Check the sessions too to be sure you don't have some hanging. I am assuming that its not a firewall configuration, but it all else fails, I would double check that too.


Collapse -

Catalyst 4500 Series Switch Cisco

by kenneth.w.jones In reply to Check your vty config

Tks for the replies.

I had verified the vty line configurations and all looked correct.

Powered off switch and restarted. Whatever change that was applied was not saved to the startup-config. (Good or bad - good in this case). When switch came back up - telnet was available again.

Still not sure what the problem was - but now have a backup file of running-config in case this happens again. Also will configure user logon accounts and track what changes are made by who.

Tks again for all replies.


Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums