Domain Group Policy problem - no shutdown options in workstations

By jens ·
We recently added another group policy object to a domain with 3 sites so that logon scripts are handled depending on in which site the user logs on due to hotdesking personnel.

The problem that seemed to develop from that is that, although the "Shutdown" button is available in all workstations and the servers can still be shutdown/restarted, the actual Shutdown diaglog window on the XP workstations only contains a "Log off" option whereas you would normally get "Log off, Restart, Shutdown, Stand by".

I have attached a picture link below to illustrate the problem. The users should have the right to shutdown/restart. I have been over the group policy back to front and I cannot find an option. Does anyone have an idea?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

These might work, they might not......

Not Displaying Logon, Logoff, Startup and Shutdown Status Messages

To turn these off:
1.Start Regedit
2.Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system
3.If it is not already there, create a DWORD value named DisableStatusMessages
4.Give it a value of 1
To turn on, give it a value of zero "0".

Bringing Up the Shutdown Dialog Box.

Create a new txt file somewhere on your system, open it and put in this one line:
(new ActiveXObject("Shell.Application")).ShutdownWindows();
1.Save and Close the file. Change the extension to js and you've got it.
2.You can make a shortcut to that file to make it easy to shut down your sys.

Poweroff at Shutdown.

If your computer does not turn off the power when doing a shutdown,
you may need to edit the registry. If you have all the correct BIOS and Power settings you might still need to do this.
1.Start Regedit
2.Go to HKEY_CURRENT_USER\Control Panel\Desktop
3.Edit the key PowerOffActive and give it a value of 1
4.You can do the same in HKEY_USERS\.DEFAULT\Control Panel\Desktop

Creating a Shutdown/Reboot Icon.

WindowsXP has a program called SHUTDOWN.EXE which allows you to easily create icons to shutdown or restart your computer.
To create a shutdown shortcut on the desktop:
1.Right click on an open area of the desktop
2.Select New / Shortcut
3.Enter in "shutdown -s -t 00" - no quotes
4.Press the Next button
5.For the name, enter in anything you like. I just use shutdown. Click on the Finish button.
For a reboot, enter "shutdown -r -t 00"
Shutdown [{-l|-s|-r|-a}] [-f] [-m [\\ComputerName]] [-t xx] [-c "message"] [-d[p]:xx:yy]
-l - Logs off the current user, this is also the defualt. -m ComputerName takes precedence.
-s - Shuts down the local computer.
-r - Reboots after shutdown.
-a - Aborts shutdown. Ignores other parameters, except -l and ComputerName. You can only use -a during the time-out period.
-f - Forces running applications to close.
-m [\\ComputerName] - Specifies the computer that you want to shut down.
-t xx - Sets the timer for system shutdown in xx seconds. The default is 20 seconds.
-c "message" - Specifies a message to be displayed in the Message area of the System Shutdown window. You can use a maximum of 127 characters. You must enclose the message in quotation marks.

Please post back if you have anymore problems or questions.

Collapse -

Enable user shutdown.

by BBPellet In reply to Domain Group Policy probl ...

Enable the user shutdown.

Right Click start button
Select Properties
Select Customize
Select Log Off Box.

You should now have shutdown also.

Collapse -

GPO path

by IC-IT In reply to Domain Group Policy probl ...

User Configuration/Admin Templates/Start Menu and Taskbar/Remove and prevent access to the Shut Down Command.

Collapse -

Thank you for replies. - Update.

by jens In reply to Domain Group Policy probl ...

Thank you for all the replies. I have tried the suggested registry changes without success. I have run gpresult just to find that for some odd reason the default domain policy is applied twice to the workstations as well as the domain controller policy. I have now made sufficient changes to only have the default domain policy applied once. I will know tomorrow morning when they boot up the PCs.

It is not practical to make changes locally on each workstation (I have thought about creating an icon myself to allow shutdown), because you are looking at 30 workstations and they want it to work the way it has always worked - typical.

Collapse -

Argh wrong post to reply to Edited NT

by IC-IT In reply to Thank you for replies. - ...

No Text, ok a little need more coffee. ;-)

Collapse -

No problem.. Just give us an update if it is working or not. :)

Please post back if you have anymore problems or questions.

Collapse -

Will do as soon as I know

by jens In reply to No problem.. Just give us ...

You know what it's like. If something's wrong it needs to be done yesterday, but if you (as IT guy) want information or feedback, who cares. Just glad we don't burn people at the stake anymore, otherwise a lot of IT support people would be dead by now!

Collapse -

Reponse To Answer

by erikforeman In reply to Thank you for replies. - ...

did you ever get this solved? I am having this issue on my netowrk. I made several changes to the Group policy on the network yesterday now several, but not all users are complaining about not having the shutdown option.

Back to Networks Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums