Question

Locked

explorer.exe won't load

By d1g1t ·
Hello World:

I am a first time caller, long time listner, running 32-bit Windows XP SP3 on an AMD Sempron 3400+. (Don't laugh) Explorer won't load. The symptoms are thus:

I recently un-installed an old UBISoft game called Splinter Cell Chaos Theory and then restarted my computer. On the way down I heard the familiar sound that windows always makes however, on the way up, there was no sound. I rebooted the computer a couple of times and sure enough, the Creative X-Fi card would only produce sound as Windows was signing off. I re-installed the sound drivers from cd and rebooted but when I clicked on various music apps they all said something to the effect that there was a certain file/object that could not be located.

I rebooted again after reinstalling drivers and I actually heard that opening startup windows sound but was not prepared for what came next.

I have no icons, system tray, start menu or quick launch bar. Just nothing but wall paper and no icons.

I hit ctrl-shift-esc to bring up task mangler and explorer is not on the list. While I had taskman running though, I noticed only about 32 out of 48 tasks running. I brought down the taskman menu to run the command line type of stuff like explorer.exe and cmd and sfc /scannow but it's not having any of it. Taskman just blinks out of site. I can bring it back no problem but it won't let me enter commands through it.

I also can use the winkey-u command and it works. And of course the sound works.

So, I rebooted to safe mode with command prompt and tried to run sfc /scannow and it says RPC server unavailble. I thought maybe a digital certificate might be preventing explorer from loading (based on a quick google search and a trip to microsoft) so I ran mmc and added the certificate snapin and checked out the trusted root cert called NO LIABILITY ACCEPTED and its there. It shows that it's been expired since 2004 but I checked a few other computers and they all look the same except of course they work.

So, after running chkdsk /r and seeing that yes, a few files did get moved around (but I couldn't tell which ones) I rebooted and the situation was unchanged.

So, I did an XP repair type of install (twice now), all to no avail. The memory and mobo check out. Video card is fine. Even with limited options, I was still able to run Eusing Free Registery Cleaner and the there doesn't really seem to be any problems with the registery. It looked pretty clean. I reinstalled explorer.exe in both places \Windows\system32 and \Windows\system32\dllcache\ and file sizes match at 1,000,960 bytes which is what they were before.

For some reason, I don't seem to have any restore points. The only thing I can think of is that something software related is keeping explorer from loading.

The only other symptom I can think of is that the system tray was acting up once in awhile by not showing all the icons that should be running however, all the icons were showing prior to my reboot while messing with the Creative Labs install disk. I still have sound though, no problem their. A clean install is not an option.

Please help.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Well - that's a first ....

by OldER Mycroft In reply to ...hmmmm

I've never had a regsvr instance fail before.

I've had it not make much difference - but never had it fail.

Regsvr32.exe usage
RegSvr32.exe has the following command-line options:
Regsvr32 [/n] [/i[:cmdline]] dllname

/u - Unregister server
/i - Call DllInstall passing it an optional [cmdline]; when used with /u calls dll uninstall
/n - do not call DllRegisterServer; this option must be used with /i
/s ? Silent; display no message boxes (added with Windows XP and Windows Vista)
When you use Regsvr32.exe, it attempts to load the component and call its DLLSelfRegister function. If this attempt is successful, Regsvr32.exe displays a dialog box that indicates success. If the attempt is unsuccessful, Regsvr32.exe returns an error message. This may include a Win32 error code. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
193625 (http://support.microsoft.com/kb/193625/) WinInet error codes (12001 through 12156)

Clearly if you invoke the command without '/i' it is effectively doing nothing, that's probably why it looks like it's working.

Check out the M$ link where this excerpt lives:
http://support.microsoft.com/kb/q249873/

As for me - I'm away to find my Thinking Tam O'Shanter
(if you need to ask - don't!)

I'll get back to you ....

Collapse -

Check to see

by Jacky Howe In reply to explorer.exe won't load

if it is being loaded from the Registry.

See if you can check this in Safe Mode.

At a command prompt type in regedit and press Enter
Locate the registry key HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\shell
Make sure that its value is set to explorer.exe.

If you cant access the Registry copy and paste this to Notepad and save it as addexp.reg
At a command prompt type in regedit /S addexp.reg and press Enter

**********************
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"Shell"="Explorer.exe"
**********************

< another thought >
At the command prompt type in sfc /scannow

Have your XP CD handy.

Collapse -

nope! ... still doesn't work

by d1g1t In reply to Check to see

As per my rather lengthy introduction to the problem, I have no access to things like notepad. Just the command line. I have already mentioned (as per above) that sfc /scannow returns the error message of RPC server unavailable.

What I did do, was type "regedit" and manually navigate through the registry to the location indicated in your last reply. I changed the value from Explorer to "Shell"="Explorer" and now I don't even get any wall paper, not to mention the rest of it.

I suppose I could use Edit.exe instead of notepad and still create a file like the one you have suggested. I think I'll reboot and try the shell= command without the quotes and see what i get.

I'll be right back...

Collapse -

I have returned

by d1g1t In reply to nope! ... still doesn't w ...

...and no. It doesn't work with or without the quotes. It's time I got some shut eye. Tomorrow I will have to make far more drastic errors, ah, I meant MEASURES.

I WILL have to *take* far more drastic *measures*.

Absolutely!

Collapse -

See if this is of any help

by Jacky Howe In reply to I have returned

explorer.exe is in c:\windows

After the Windows Logo displays or after you log on to Windows, a Windows XP-based computer may only display the wallpaper, a black screen, or a blue screen

http://support.microsoft.com/kb/318027

If there is no success with that try this.

Restart the PC in Safe Mode and turn off System Restore and run Sophos and then run Spybot.

From another PC download and install these two programs and copy the the installed folders to a USB Stick.

Restart the PC in Safe Mode and run Sophos and then run Spybot.

Download Spybot - Search & Destroy 1.5.2 and install it. Update it. http://www.safer-networking.org/en/download/index.html


Download Sophos and the latest IDE Files. Install it and extract the IDE files to the C:\SAV32CLI folder.
http://www.sophos.com/support/knowledgebase/article/13251.html

Copy and paste the below two lines into Notepad and save the file to the USB Stick as sophos.bat, it will scan and remove. When the Scan has finished check the log file to see what it hasn't removed. You will normally find the answer to this via Google.

===============================
CD SAV32CLI
SAV32CLI -REMOVE -P=C:\REMOVLOG.TXT
===============================
The Sophos SAV32CLI folder can be safely deleted after it is copied to USB.

Related Discussions

Related Forums