Firefox Address Bar/Navigation Bar not working

Ok. So I have been using Linux w/ Firefox for quite some time now, and I've always had problems with Firefox. At first, it worked perfectly, but then...

At first, sometimes when I booted up the system, it wouldn't load firefox, it would show the little "Firefox is loading" thing down in the GNOME program bar, but then it wouldn't load. It would just stop.

Next, after I got it working, the Address Bar wouldn't work, it would allow me to type sites in and hit enter to go to the sites, but it wouldn't show the URL if I went to another address, say I typed "" and hit enter, it would go to Google. Next, I clicked "Sign in to Google", and it went to the sign in page, the URL would still say "". Not even "", just "".

Another problem is that the back, forward, stop, and refresh buttons won't work. They just appear grayed out no matter what. The home button works, but it only takes me to a blank page.

Can anyone give me some advice on what to do?

P.S. Yes, I do have Firefox 3, and I'm running Ubuntu.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have you tried re-installing FF3 ? <NT>

by OldER Mycroft In reply to Firefox Address Bar/Navig ...
Collapse -

Re: Have you tried re-installing FF3? <NT>

Not yet, I was just wondering if anybody has had the same experiance.

Collapse -

Anyone's 'same experience' won't help you much unless ...

by OldER Mycroft In reply to Re: Have you tried re-ins ...

You try to help yourself.

Someone else's experience might have been to re-install FF3, and you won't know until you try it.

Collapse -

Re: Anyone's 'same experience' won't help you much unless ...

Yes, I was planning on reinstalling it... I do not have physical access to the computer right now, I left it over at a friends house (good thing the HD is encrypted...)

Collapse -

What did you do to "get it working"? the first time?

by jdclyde In reply to Firefox Address Bar/Navig ...

after it wouldn't load, what did you do to "fix" that problem?

Could this be a permissions issue? Check the directories it is loaded to make sure your user can execute in them, as well as have read access to the program.

Best bet, download the current version, uninstall FF and then reinstall it from the new package.

Collapse -

Re: What did you go to "get it working"? the first time?

Basically, I tried running it in Super-User mode, I tried xkilling the gnome environment (worked sometimes), etc etc.

Collapse -

Same problem on Vista and Firefox 3.5.3

by mentormatt8 In reply to Firefox Address Bar/Navig ... describes the problem, which can be described exactly like you do, on Vista as well. The solution is proposed as well. At least the one that worked for me today. The standard diagnostic procedure for Firefox is mentioned but was unnecessary today.

Back to Browser Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums