Question

Locked

gain back write registry privileges to be able to change port setting

By Cebbu ·
I googled about this topic and found few non-workable work around on error "you must have write privileges in the registry for this device in order to modify the device's advanced setting" when changing advance setting under port in device manager in XP Pro.

I have followed some blog like booting on safe mode on administrator account, changing registry {0000, 0001 , etc} to disable deny on all to no avail.

a precise and workable tweaks for this will eventually help me and others

This conversation is currently closed to new comments.

42 total posts (Page 3 of 5)   Prev   01 | 02 | 03 | 04 | 05   Next
Thread display: Collapse - | Expand +

All Answers

Collapse -

As earlier noted, the lock-out may reside in firmware, etc..

by deepsand In reply to I'll begin here

Have you checked to see if you have the latest available drivers installed?

Additionally, have you checked your BIOS settings to see if the characteristics that you wish to observe and/or change are accessible there?

Collapse -

I have taken that step

by Cebbu In reply to As earlier noted, the loc ...

I have an updated drivers. I have tried my BIOS and it is not accessible in there.

I think this is a registry denial issue because the last time, i can still add anything on the registry. I am thinking that this was a result of update offered by XP pro which i can preset and gain back my authority. It is what i am trying to find, the registry value to change, delete or add.

Under administrator in safe mode i can not also add anything in the registry.

Collapse -

Have you tried

by ComputerCookie In reply to I have taken that step

Have you tried creating another administrator account and see if you have access.

Collapse -

Just tried

by Cebbu In reply to Have you tried

I have tried this, same result, unaccessible.

Collapse -

Are we to understand, then, that the problem is not limited ...

by deepsand In reply to I have taken that step

to accessing the Advanced Settings for the ports, but that you are completely blocked from editing the Registry Hive?

Collapse -

an exact statement

by Cebbu In reply to Are we to understand, the ...

Yes, It is not limited to an account and the advance setting. The registry hive is also block

Collapse -

So the next logical question

by Tig2 In reply to an exact statement

Is this a pc that is managed by a support person or is it your own personal device? The reason I ask is that if it is managed by your IT department, they built the lock in when they imaged the pc. They don't want any one in there. I imagine that if you can present a business case for having access, they may grant it. Unfortunately, they may not.

If this is a personal device, you have some level of corruption happening. Wipe and reload the system after doing a full backup. It is very possible to have corruption in the registry without that corruption causing the pc in general to stop functioning.

Thank you for apologizing for your earlier attitude. The people you were rude to are my friends and peers. They try very hard to help people and they deserve your respect.

Collapse -

The device

by Cebbu In reply to So the next logical quest ...

It's my personal device.

Collapse -

As it is your personal device

by Tig2 In reply to So the next logical quest ...

I think that a full reload is in order. You state below that you use registry maintenance tools fairly routinely. The down side of any such tool is that they are capable of being too aggressive. Not reason enough to not use them in my opinion, but they can force a system reload.

It's a PITA but worth doing so that you can access your registry again. Also, if corruption is present, it can degrade to the point where you are forced to do a wipe and reload.

Good luck!

Collapse -

No-Reformat, Nondestructive Rebuild possible

by deepsand In reply to an exact statement
Back to Networks Forum
42 total posts (Page 3 of 5)   Prev   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums