Question

Locked

gain back write registry privileges to be able to change port setting

By Cebbu ·
I googled about this topic and found few non-workable work around on error "you must have write privileges in the registry for this device in order to modify the device's advanced setting" when changing advance setting under port in device manager in XP Pro.

I have followed some blog like booting on safe mode on administrator account, changing registry {0000, 0001 , etc} to disable deny on all to no avail.

a precise and workable tweaks for this will eventually help me and others

This conversation is currently closed to new comments.

42 total posts (Page 4 of 5)   Prev   02 | 03 | 04 | 05   Next
Thread display: Collapse - | Expand +

All Answers

Collapse -

Does not always work.

by normhaga In reply to No-Reformat, Nondestructi ...

Especially if your ntuser.dat is corrupted.

But mostly it does.

Collapse -

Re. "mostly" works.

by deepsand In reply to No-Reformat, Nondestructi ...

Is there a known work-around for the problem casues by a corrupted ntuser.dat file?

Can you identify other specific causes for the referenced re-build method failing?

Collapse -

When in safe mode

by Tig2 In reply to I have taken that step

That is "as designed". Safe mode should not allow you to modify the registry.

There is a tool called CCleaner that will manage your registry for you by identifying and removing obsolete entries. It is a free tool and very good. The only thing that I would caution is that you should make a backup when prompted to do so and retain it until after a successful reboot. You also need to run the tool recursively until it can't find anything else.

http://www.ccleaner.com

I have addressed your foundational issue below.

Collapse -

Other step

by Cebbu In reply to When in safe mode

Your opinion is appreciated.

I have check my registry with other software also like regclean and registry mechanic. I'll give your suggestion a try.

Collapse -

Once again I am confused.

by deepsand In reply to Other step

In response to my earlier question, you confirmed that you can gain no access at all to the Registry.

Yet, you here say that you have been able to access it via certain applications, such as Registry Cleaners.

These 2 statements are clearly at odds with one another.

Collapse -

Setting Registry Permissions

by scottk81 In reply to gain back write registry ...

I can't believe all the crap responses i just read here. This, not surprisingly, is a permissions problem. so, Run Regedt32.exe, find
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum
now right click Enum , and goto permissions..make sure either Everyone or your
account are set to Full

Collapse -

"Crap responses?"

by deepsand In reply to Setting Registry Permissi ...

As a newbie here, you might wish to temper your judgements of others for while until you learn the ropes here and get to know some of the regulars.

Beginning by denigrating everyone else is guaranteed to bring no good your way.

Collapse -

Looking at his profile says it all

by jdclyde In reply to "Crap responses?"

" 0 Helpful Answers Given"

Collapse -

Not to mention the rest of his Profile.

by deepsand In reply to Looking at his profile sa ...

Interests : None

Current Technology Implementation : None

My Contacts: 0

Links : None

Discussions Posted To : None

Send private message : Not Allowed

Collapse -

Registry change to ENUM worked!

by presleye69 In reply to Not to mention the rest o ...

Thanks much to the last response that suggested changing the permissions to ENUM in the registry to full for EVERYONE.

That worked well and now allows me to change the COM port number on my USB to SERIAL adapter. Now I can connect to my Point Of Sale terminals to complete my programming using my newer laptop and can retire my old broken-down laptop with the built-in serial port.

I was having the same problem as the original requester and had to wade through 40 responses to get one that worked. Much appreciated.

Back to Networks Forum
42 total posts (Page 4 of 5)   Prev   02 | 03 | 04 | 05   Next

Related Discussions

Related Forums