How to enable the E:, F:, and G: drive?

By ivanog1230-persona ·
I used to see the E: F: & G: under Devices with Removable Storage whenever I double click on the My Computer icon in my desktop...and now they're gone. The only thing that's in there are 1. Files Stored in this Computer 2. Hard Disk Drives(with local C:) 3. Devices with Removable Storage(with DVD-RW Drive ) and 4. Scanner & Cameras(with Epson Stylus Photo RX425). Also whenever I right click on My Computer>Manage>Disk Management there's no E: or F: or G: drive being detected(even if I insert the memory card of my Nokia 6600 celfon into the SD/MMC slot in front panel of my pc). Also when I right click My Computer>Manage> then click on Removable Storage I get a stop/warning sign saying "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it". How can I enable those E: , F:, and G: drive? Is my Memory Card drive buggered? Also when I put the XD card of our Olympus Digital Camera into the XD/SM card slot of our Epson Stylus Photo RX425...there is no way for me to access the XD card. I intend to copy pics from my pc to the XD card in our 3-in-1 printer but i cant since my pc isn't detecting the XD card. Do you know of a way for me to enable the E: and the F: and the G: drive(removable storage devices)?

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Sounds like you already have an idea.

by 1bn0 In reply to How to enable the E:, F:, ...

Your card reader may be defective or the connecting cables may have come loose.

Collapse -

Why can't my pc not detect the XD card in the printer?

by ivanog1230-persona In reply to Sounds like you already h ...

Im already inclined to believe that my memory card reader could be defective...and how I wish it's just a case of loose connection. But why is my pc also not detecting the XD card inserted into the fully functioning XD/SM slot of our printer(Epson Stylus Photo RX425)? The light in the printer card slot goes on whenevr I insert the XD card into the XD/SM slot so I assume it's not defective...but still it cannot be detected or I cant access it in my pc.

Collapse -

I have the same Problem

by steffcollege In reply to How to enable the E:, F:, ...

If anyone can please help me
e-mail: Thanks!

Collapse -

We do not send emails as answers....

by ThumbsUp2 In reply to I have the same Problem

.... but, I'm sure you'll now be flooded with spam email since you've posted your email address for the bot crawlers to find.

We do not send answers via email. Everything we know is posted here for others to read. You'll just have to come back here and read to see if anyone has a solution to the problem.

Collapse -

Which problem do you have

by ComputerCookie In reply to I have the same Problem

the unrecognised hard drive/s, memory cards reader or ?

Collapse -

try this maybe?

by bdr2 In reply to How to enable the E:, F:, ...

HI, Sorry for the bump. Just in case anyone still has this problem. i had the same issue but it was a common problem with my Medion pc. The fix was to turn off and disconnect all power to your pc. Then hold the power button on your pc in for 10-15 seconds. Then plug the power back in and boot up. Im not sure if it will work with other brands and models of pc's but its worth a try. cheers

Collapse -


by ntaraga In reply to How to enable the E:, F:, ...

my removable(g) has a problem it accept to be opened but if i store data on it to another computer i'm not able to view these data my removable(g) shows that it is empty

Back to Hardware Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums