Desktop

Question

Locked

How to restore Microsoft Windows Network in XP Home?

By jim.poltrone ·
I want to network my laptop and desktop computers together so I can share files and printers. I have a crossover cable connecting the two. The desktop computer runs XP Home w/SP3; the laptop runs XP Pro w/SP3. I used the Network Setup Wizard on both systems to establish a workgroup connection, called MSHOME. I can ping each of the machines, regardless of which machine I'm on.

The problem is, when I go to the desktop, I can't see its own shared folders or printers, and "View Workgroup Computers" is empty. I traced this to a missing "Microsoft Windows Network" icon under "Entire Network". I've tried several things to restore this, including removing SP3, reinstalling Windows, and reinstalling SP3. But that didn't work.

I'm stumped. I'd rather not have to resort to thumb drives to move files across the machines.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

XP Home

by Jacky Howe In reply to humm you can ping but not ...

is a pain in the butt. It doesn't have default Admin Shares and a lot of other things that XP Pro has. I keep forgetting about its misgivings and treat it like XP Pro but you can't. There are the same problems coming up with Vista Basic. If the bean counters at Microsoft would let the developers concentrate on one universal OS that would work properly out of the box we would all be laughing. All of these different Versions are a joke.

Collapse -

crap... your right....

by CG IT In reply to XP Home

Windows 2000 Professional, Windows XP Professional, and Windows Vista Business are usually what I deal with. Some small offices have a mix of XP Pro and Home, but never had a problem creating workgroups, sharing folders and printers. Have had intermittent connection problems and that's from the wireless clients who drop their wireless connection for no reason but wired, they are pretty reliable.

I dunno, I find that problems with computers and workgroups [AD domains as well] isn't some "not seen before" problem.

Watch, he'll come back, tell us he reinstalled XP and volia! network works.

Collapse -

Re: Crap

by Jacky Howe In reply to Yes I can still ping

Those OS's are probably the most stable. I like XP Pro with the new service pack. As I mentioned to someone the other day that I can trust XP Pro but I haven't came to the same conclusion with Vista yet. Vista Business and Ultimate seem to be the most stable at the moment but I sit at it waiting for something to go wrong. Maybe it's because of the Beta days when there was one thing after another going wrong.

Collapse -

It's not really for Home but worth checking

by Jacky Howe In reply to How to restore Microsoft ...

How to troubleshoot missing network connections icons in Windows Server 2003 and in Windows XP
<br>
http://support.microsoft.com/kb/825826
<br><br>
<i>Keep us informed as to your progress if you require further assistance.</i>
<br><br>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
</i>

Collapse -

Check these settings

by Jacky Howe In reply to How to restore Microsoft ...

make sure the Telephony, Remote Access Connection Manager, and Remote Access Auto Connection Manager services are running.
<br><br>
Verify that the Objectname string value is set to LocalSystem in the following registry subkey: <br>
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan<br>
<br>
Note This procedure includes steps to back up the registry keys before you modify them. <br>
Click Start, and then click Run. <br>
In the Open box, type regedit, and then click OK. <br>
Locate and then click the following key in the registry:<br>
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan <br>
On the File menu, click Export. <br>
In the File Name box, type exported rasman key, and then click Save. <br>
In the RasMan key, locate and then click the ObjectName string value. <br><br>

If this value is not set to LocalSystem, follow these steps: <br>
a. On the Edit menu, click Modify. <br>
b. In the Value data box, type LocalSystem, and then click OK. <br>

Quit registry editor, and then restart your computer.

Collapse -

Checked

by jim.poltrone In reply to Check these settings

Services are running, although Remote Access Connection Manager and Remote Access Auto connection are started up manually. (I still use dial-up to connect to my internet service provider.)

I also checked the RasMan settings in the registry, and ObjectName was already set to LocalSystem.

Despite this fix, I still can't create a network place or view other machines in my workgroup. I wonder if there's some other service that needs to be added and running.

Collapse -

Back to the registry

by Jacky Howe In reply to Checked

To resolve this issue, use Registry Editor (Regedit.exe) to locate the following key in the registry: <br>
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\<br>
Change the value of the EnableProxy value in the preceding registry key to 0 or 1, quit Registry Editor, and then restart your computer.
<br>
< Edit >
You will have to do this on both PC's.

</br>

Collapse -

Tried it. No luck.

by jim.poltrone In reply to Back to the registry

Saw that the value of this setting was 2. Changed it to 0, rebooted, and did my usual tests (ping, add new network place, view workgroup computers). No difference. Went back to the registry and saw that the value of this setting was changed back to 2. (No, I did not change the setting on the other computer. Is that what's causing this value to revert?) Changed it to 1 and repeated what I did before. The same result. Although now when I try to repair my connection, I can't clear the ARP cache.

Collapse -

If Clearing the ARP Cache Fails

by Jacky Howe In reply to Tried it. No luck.

After the installation of Service Pack 2 or 3, this service is set from Manual to Disabled by default on Windows XP Pro.

To disable Routing and Remote Services:

Click the <Start> button
Click the <Control Panel> button
Switch to "Classic View" if you are in "Category View"
Click <Administrative Tools>
Click <Computer Management>
Double-click <Services and Applications>
Double-click <Services>
Scroll down to <Routing and Remote Services>
Double-click <Routing and Remote Services>
Examine the "Startup Type"
The options are "Automatic", "Manual", and "Disabled"
Set the "Startup Type" to "Disabled"
Examine the "Service status"
Make sure that the service status is Stopped. If it is not Stopped, click the <Stop> button
Click the <OK> button
Now, try clearing the ARP cache again and it should complete with no error messages


From the desktop computer (while logged in to my ISP):

Have you tried any of these fixes without being logged into your ISP.

Collapse -

Reinstall or even reformat your PC

by dondon1205 In reply to If Clearing the ARP Cache ...

I have an experienced like this. Have a connection but only limited to 10mbps..I just reinstall the windows and it works smoothly..

Related Discussions

Related Forums