General discussion

Locked

ide controller problems

By wordmaster1 ·
In an older machine, AMD K2-300, 256 mb RAM, I upgraded from 95 to 98SE. Machine ran great for a month or so with no problems. Then I installed a DVD recorder. Installed Nero, burned CD's fine. So far, everything working great, no problems playing DVD's. Installed DVD software and suddenly there are yellow exclamation points beside primary and secondary ide controllers, I am in compatibility mode, and the CD and DVD drives no longer show. CD and DVD drives both show in safe mode.

I have tried the noide solution, it just comes back on the next boot. I have tried uninstalling all the software that had been installed... no difference.

Hard drive is partitioned into three drives using Partition Magic and is on primary ide. DVD burner is master on secondary ide and CD is slave on secondary.

All help appreciated.

This conversation is currently closed to new comments.

18 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by saihib In reply to ide controller problems

What DVD software did you install?

Collapse -

by Blackcurrant In reply to ide controller problems

Hi

Do you have DMA support enabled? If so, try disabling it. I had a similar problem through with a standard CD-ROM drive. I enabled DMA on the hard drive and my CD drives (it was a 4 drive multichanger), disappeared.

I had disable DMA to get them back.

Good luck

Collapse -

by wordmaster1 In reply to

Poster rated this answer.

Collapse -

by maxwell edison In reply to ide controller problems

The initial release of Windows 98 didn't have great DVD support. The issues were addressed with subsequent service packs, so that might help.

Plan A:
I'd uninstall the DVD software, uninstall the DVD recorder, and get the computer back to having no conflicts/problems with the IDE ports. I'd then go to www.support.microsoft.com and scan for all available upgrades and service packs for Windows 98. (The service packs will have to be installed separately.) I'd then try to install the recorder and the software again. If it works, great. If it doesn't work, I'd go to plan B.

Plan B: On an older machine like that, you might have a BIOS problem with the IDE channels and DVD technology. So do the same thing. Uninstall the recorder and the software, and then you might want to flash the BIOS to the latest and greatest version. There may be a BIOS update available from your motherboard manufacturer than plays nicer with DVD technology. Go to your motherboard manufacturer's Web site and do a BIOS search for your model. Or an Internet search might produce some third-party upgrades. If that doesn't work, or if you feel unsure about flashing your BIOS, go to plan C.

Plan C:
You might what to consider installing a separate IDE controller card. Promise Technologies makes some good cards for a reasonable amount of money. I haven't bought one lately, but you could probably find one for less than $50. Run the hard drives and the CD ROM off the motherboard's IDE controllers, and the DVD off the separate controller card. If that doesn't work, go to plan D

Plan Well, if A,B and C don't work, let us know and someone will surely come up with a plan D.

Collapse -

by wordmaster1 In reply to

Poster rated this answer.

Collapse -

by sgt_shultz In reply to ide controller problems

wonder if you had then uninstalled adaptec ez cd creator? there is a bug that will produce your porblem under certain circumstances. check it out at www.adaptec.com
if you have a registry backup you can try that...

Collapse -

by wordmaster1 In reply to

Poster rated this answer.

Collapse -

by TheChas In reply to ide controller problems

It sounds to me like the DVD player software blew away your IDE drivers.

Download and install the latest W98 drivers for the specific chip-set on your motherboard.

You may have to perform the NOIDE solution again after installing the drivers.

The default W98 IDE drivers do not properly support many chip-sets other than Intel.

Also, Windows update has more than once suggested installing the wrong chip-set driver.

Chas

Collapse -

by wordmaster1 In reply to

Once I got the proper chipset drivers installed, everything worked and all errors disappeared.

Collapse -

by willcomp In reply to ide controller problems

Since I'm not sure what DVD software you installed, will assume that it is another application that also burns DVDs. CD/DVD burning software packages are mostly mutually exclusive. Each one installs its own device drivers and one device with multiple drivers is not a desirable situation.

If that is the case, you need to completely uninstall one of the programs. Some manual driver removal may be required as well. See program developer's web site for instructions.

Easy CD Creator is the prime culprit, but others are also prone to problems.

Post back with further details, and we may be able to provide more specific guidance.

Dalton

Back to Windows Forum
18 total posts (Page 1 of 2)   01 | 02   Next

Related Forums