Desktop

General discussion

Locked

IDE CONTROLLERS

By shantie ·
After five hours on this computer I am still getting nowhere. I put a new Seagate 40gig hard drive in it approx 2 months ago, it was returned to me yesterday due to explorer.exe error messages. I tried re-installing windows 98 but after installation same message. Formatted and resinstalled windows okay, but then noticed I had no cd rom drive or burner drive. The system is a Jetway board around 3years old with an 850 Cel cpu, the hard drive is partitioned into two halves. I have tried many things in the last five hours, all drives are recognised in the Bios, and in the Post boot up screen. Boot up floppy recognises cdrom and gives it a drive letter for reinstalling. Win98 installs okay (on board Lan) asks you for network identification details and finishes install, but then there is no cd rom drives. I have tried a new cd rom drive and same thing. Tried changing cd rom drive to slave from hard drive, tried changing jumpers on hard drive from Chs to Master. Trouble is in Device Manager there are yellow question marks against all ide controllers for master and slave drives. Tried redoing Fdisk, re partitioning, Tried Sys C. Same thing. I then tried a little 3 gig hard drive, installed win98 did not ask for network identification and all drives were recognised, all ide controllers were recognised in Device Manager. I am now trying it as an unpartitioned drive with the total 40gig, why is it taking the drive as a network drive?? when it does not with the 3gig. The next step will be to put the 40gig on a different computer and see what happens. Going of my brain here please help, thank you

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by willcomp In reply to

Scratch last comment. Know from experience that XP will handle another FAT32 drive of >32GB.

Collapse -

by shantie In reply to

Again bios worked okay with this hard drive when first installed + I re partioned and formatted the hard drive + fdisked MBR so did not solve problem re no IDE controllers installed this time, but thanks for the comments.

Collapse -

by diskaus In reply to IDE CONTROLLERS

I am thinking it could be mother board driver problem but although i am not familiar with this brand of MB i would not be surprised if originally the system had a hidden partition on it and this is where the drivers are ( just like Compaq) if this is the case it is not as simple as just installing them , in fact you would need to flash the bios with the manufacturers software.

Like I said it is just a thought.
If you post back with more specific MB specs, ( model, version etc.) If you go to the folowing url and enter the details you may come up with a model number, keep in mind it is only successful if your board is listed in thier database, but it is worth a try.
http://www.motherboards.org/tools/moboidtools.html

Collapse -

by diskaus In reply to

After looking at your last comment I would say go to the website for your HDD manufacturer and download the diagnostic utility , it may or may not reveal where the problem lies , it could be a dodgy HDD, else low level format the drive an start again , I have revived 2 drives this way i the past 2 weeks.
Hpe this helps.

Collapse -

by shantie In reply to

The first part of your comment did not solve problem but the added comment about the diagnostic utility seems to have worked. I downloaded the Seagate Diagnostic utility and Disc Wizard, one of them done the trick I have now re-installed windows and "Wa La" I have ide controllers. But I have still given the lady a new hard drive and asked her to keep a log book, especially on internet (I hope) Just to find out what has caused this on both hard drives, Thanks for the Help

Collapse -

by RCOM In reply to IDE CONTROLLERS

Since the Motherboard was made after windows 98 came out, sounds like you do need to install the chipset drivers as was mentioned.

Before you attempt booting back to the desktop try the old school way to make Windows recognize that there's a CDROM in the system.

You can use CONFIG.SYS & AUTOEXEC.BAT to load IDE-CD.SYS & MSCDEX.EXE commands for the CDROM. Once you do this and start Windows it will be running in Protected Mode. After rebooting the drivers won't need to loaded from DOS and will be changed to remarks.

REM By Windows Setup A:\MSCDEX /D:NCI000 /V

To use the DOS driver again just delete the words in front of the actual command.

To disable the DOS driver from CONFIG.SYS put the character ; in front of the line for the CDROM to make it a remark.

You can use the IDE-CD.SYS file and duplicate command lines from the boot floppy. To get the command lines needed just look in CONFIG.SYS & AUTOEXEC.BAT on your boot floppy by editing them in DOS. Type the same command lines into the C: drive's CONFIG.SYS & AUTOEXEC.BAT, then change the path to match the hard drive instead of the floppy disk.

For CONFIG.SYS-
DEVICE=C:\IDE-CD.SYS /D:NCI000

AUTOEXEC.BAT-
C:\WINDOWS\COMMAND\MSCDEX.EXE /D:NCI000 /V

Then copy the IDE-CD.SYS file from A: drive to the root of the C:

Collapse -

by shantie In reply to

Did not need to do this the first time around when Win98se installed with no problems so something happened to the hard drive after it left here, therefore your comment did not help with why no Ide controllers this time only but thanks for the comments.

Collapse -

by Poettone In reply to IDE CONTROLLERS

I know alot has been said here but there is one thing to keep in mind..

When you see a yellow exclamation point on a device it mean there is conflicting device attempting to use the same interrupt, memory address etc..

Are you settings in the bios set correctly, typically auto is good, some older bios force you to choose the hard drive type.. lba, auto, chs etc..

It sounds to me like your motherboard firmware does not work with your drive firmware.. Hence the error..

Were you always using the full partition for the 98 load this time and the time it worked fine? Also were you using the same install cd for both installation attempts? Bad cd maybe, hey it happens.

Anyway I wish you luck and will monitor any follow ups..

Good luck

Collapse -

by shantie In reply to

Sorry but does not relate to the fact that Win98se installed with no problems the first time, so something has happened to the hard drive since it left here, also the fact that after a couple of months with each hard drive they were returned with same error messages

Collapse -

by shantie In reply to IDE CONTROLLERS

Thanks for all the comments. In device manager says no conflicts, and also remember that this 40gig was installed onto this computer 2 months ago with no problems??? I have'nt had a chance to do much more as have others to work on but a couple of other weird things have happened with this hard drive. You are probably going to think I am crazy but realy happening. I attach hard drive to my computer as a mass storage USB drive. and my WinXP (fat32) reads the partitions all different. It is as if there are hidden partitions, it is a 40gig and okay you do loose part of that but two partitions only come up with 18.6 approx on each partition. That leaves about 3 1/2 ?? When attached to my computer I copied the whole drivers disc onto it. But the win98 folders could not be seen, put it back on the original computer and win98 comes up but the drivers folders I copied could not be found. Definately there before I removed the drive. If I make it one partition my computer sees TWO 18.6 partitions. If I make two partitons, then on my computer it only sees one 18.6 partition??? My computer is reading different partitions to the original computer. Now to this Explorer Exe. errors this can be a virus I have been told but is it strong enough to destroy partitions or to make hidden ones????
Sorry but I am not crazy but it is making me that way. Thanks again

Related Discussions

Related Forums