Windows

General discussion

Locked

Internet access in safe mode only

By MJ_Consult ·
I can not access the internet in normal mode but I can in safe mode. This is small office net with three systems connecting to internet through Linksys BEFSR41 router to cable modem. The system in question is running Win XP SP2 and can communicate with the other systems in the p2p net and the other systems access internet normally. I have used msconfig to set up a minimum configuration (diagnostic mode) and still not able to access internet. I have reinstalled adapter, network configuration, etc. still no luck. I'm out of ideas.
Background - system had virus/trojan which corupted program files including some system files (XP SP1). I cleaned the virus and installed an XP SP2 upgrade and all worked except internet access.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by MJ_Consult In reply to Internet access in safe m ...

I've noticed something else a little strange. I use Firefox to access the internet. (I've tried IE and it doesn't work either.)If I'm disconnected from the network and attempt to connect, I get the message "www.yahoo.com is not available." When I attempt to browse while connected to the network, I get the message "the connection was refused when attempting to contact www.yahoo.com". Is there a Firefox guru out there that can tell me what triggers that different response.

Collapse -

by zack.phierce In reply to Internet access in safe m ...

did you at any point have firewall software installed IE norton internet security / zonealarm ? based on that aspect I may be of more assistance.

Collapse -

by zack.phierce In reply to

Also forgot to ask, in safe mode I assume that from command line you can "IPCONFIG/RENEW" just fine no errors, if you are in regular mode have you tried "IPCONFIG/RENEW" from command line? Any errors?

Collapse -

by MJ_Consult In reply to

Poster rated this answer. Your suggestion got me back on the right track. Norton Internet Security had become corupted somewhere along the way. It would neither run without error nor was I able to uninstall it. Checking Symantec support info I was able to download their "uninstall everything" (my words not theirs) tool. Once NIS was uninstalled my internet access came back. Thank you.

Collapse -

by rappodaking In reply to Internet access in safe m ...

Reinstall the OS from scratch

Collapse -

by MJ_Consult In reply to

Poster rated this answer.

Collapse -

by MJ_Consult In reply to Internet access in safe m ...

Zack,
I do have Norton Internet Security installed although it and Norton Antivirus are not working (using AVG for AV protection). I do not get any errors when executing IPCONFIG/RENEW in normal mode. Maybe I should try uninstalling NIS since it's not working.

Collapse -

by MJ_Consult In reply to Internet access in safe m ...

This question was closed by the author

Collapse -

Here's how I solved it

by deadtechy In reply to Internet access in safe m ...

This problem plagued me for almost a week on a customers computer. I followed every tidbit of advice I could find on the net and caused more problems than solutions. It occurred to me that years ago there was a conflict with and Antivirus program on a server I was maintaining and I had to find a removal tool for that specific AV solution. This computer had been running Norton so I ran the appropriate removal tool and Voila! Internet traffic was restored. I found not only the Norton removal tool, but also tools for McAfee and AVG. Hope this helps someone else with the same issue!

Related Discussions

Related Forums