Question

Locked

Keyboard not working AFTER BIOS...read on:

By kipjaw ·
Basically I went to a LAN party and brought my rig with me, it decided to not work after I had unplugged it all and set it back up at my friends. Everything was working find, dual head monitors, wireless mouse, LED lights inside my tower, everything but my keyboard. It?s a USB Saitek Eclipse II with drivers installed in its hardware which windows recognizes. After I boot up my comp, it will bring up the picture of my core cell extreme chip logo, then go to the little DOS text saying stuff about my hardware/Ethernet etc., where you would press <f1> or <f2> or <del> to go into your BIOS. A moment after this my monitor flashes and goes to the Windows loading screen. This is where I have the problem. The num lock key on my keyboard will stay on and will not turn off if I push it, Same with all the other keys including scroll lock and caps lock. This only happens on PS/2 keyboards by the way; the USB keyboard will only light up its background LED's and wont even turn on its num lock LED. Yes I have tried these keyboards on other computers, they work fine, I also have tried other USB keyboards too but they don't work, just like mine. The PS/2 keyboards works on other computers also.

I have tried remote access connection from my other computer hooked up through the same router but that didn't work most likely because I don't have it enabled on my computer. I have also tried many settings in my BIOS and fooled around with that for long enough, like turning off the USB ports and then enabling them, etc.

If you have any tips or ideas of anything for me to try I would appreciate it, I'm stumped =P.

Thanks.


-Kip

This conversation is currently closed to new comments.

12 total posts (Page 2 of 2)   Prev   01 | 02
Thread display: Collapse - | Expand +

All Answers

Collapse -

Solved without reinstalling OS

by vargabp In reply to Keyboard not working AFTE ...

Yeah, I know, it is probabil to late to answer but it is the first answer google gave me so i think that can help others.
I run windows Vista Ultimate and this morning, after booting into my PC i had exactly the same problem. The solution is simple as...nevermind... Just use system restore to restore...of course, your system to a early point. it didn't work on the latest restore point but i tried other restore points and it seems to work just fine.

Collapse -

maybe next time try 'scan for hardware changes'

by sgt_shultz In reply to Solved without reinstalli ...

in device manager. i have seen that work plenty of times especially keyboards especially with laptops. even if windows 'detects' it or doesn't detect it. i think it allocates resources funny and reallocates the you force scan for hardware changes. after that, it has always worked every boot.

Back to Peripheral Forum
12 total posts (Page 2 of 2)   Prev   01 | 02

Related Discussions

Related Forums