General discussion

Locked

'ls' hangs session but 'ls | more' works

By wbarker ·
This is probably a stty setting but I've tried several and I can't find it.

When I log in to a UNIX box through a network, any command that causes lots of text to scroll past on my terminal window causes telnet to hang.

In a directory with 308 items, I can do 'ls | more' and see all the contents, I can also do 'ls | wc' to see the number of items, but when I do 'ls' or 'ls -l', the session echos back a newline and then hangs. I can't break out with ctrl-C or ctrl-D, but ctrl-] brings me back to my local shell.

Other users who aren't as far away physically from the machine can telnet to it and do an 'ls'. I have tried multiple telnet clients (netterm and telnet from Windows), I have tried multiple computers from my more distant site without luck also.

This was working a week ago.

Any ideas?

This conversation is currently closed to new comments.

12 total posts (Page 2 of 2)   Prev   01 | 02
Thread display: Collapse - | Expand +

All Comments

Collapse -

by wbarker In reply to

The issue turned out to be a hardware issue. The IS team that owns the server had installed newer gigabit LAN cards and this was causing the problem. Still not sure where the setting is that can be made to change the behavior, tried all the suggestions above but in the end the server-side had to upgrade all the cards on all the machines that I was hitting along the way to the server and then it worked.

Collapse -

by wbarker In reply to 'ls' hangs session but 'l ...

This question was closed by the author

Back to Linux Forum
12 total posts (Page 2 of 2)   Prev   01 | 02

Related Discussions

Related Forums