MBR on Lenovo r60 ThinkPads?

By lfruchter ·
Hello Sages,

I've been away for a while, making strides at my cash-strapped Brooklyn public school (where we're losing laptops because we're not allowed to buy batteries for them; go figger), but here I am again, desperate for enlightenment.

I have 2 carts of Lenovo r60 ThinkPads, which just might be the worst computers ever. They came to us imaged with tons of software we don't need, apps that seem to be there only to make the laptops almost impossible to use on a network. I've been gradually getting braver and braver and removing more and more of this crap until I've gotten the image down to a fairly light, supple version that networks very well.

Here's where the real trouble begins. I use the wonderful Linux PING software to image our new HPs but the Lenovos won't play ball with PING so I have to use our antiquated Ghost 8.0 disk to image them. It actually works fine EXCEPT that the new image shows up without my custom partition set to "active" so I get the ol' "There has been a signature failure" message on startup. No problem, right? I just get a startup disk with fdisk and fix that up, right? Yes, except that I can't get a bootable CD iso that the Lenovos will accept and run! UBCD4Win fails, everything from fails.

Here's where it gets crazy: I can make a startup floppy that works and when connected through a usb floppy drive, I booted a bunch of the Lenovos, fixed them with fdisk and then changed the mbr with fdisk/mbr. But then the floppy drive stops working! I swear! After fixing 15 machines this way, now when I try to start from the usb floppy drive, I get endless "Disk I/O error" messages. Endless, not quite: it worked a week later when I randomly tried again on 3 machines. I got those done and thought the voodoo had passed, but now it's back to "I/O error" though it's the same drive, same disk.

Weirder still: Super Fdisk won't work. It doesn't seem to fix the mbr to the settings I assign. Same with Partition Magic (which I can boot off a CD I have). Only fdisk does the trick and I can't get a bootable CD of it.

Finally, I created a new Lenovo image from a machine that had the mbr adjusted, but that didn't change anything. The newly imaged machine still didn't understand which partition should have been active.

So what am I asking for?

1) Does anyone know a source for a bootable CD with fdisk that's likely to get Lenovos to play along? Any other CD that will do what I need? (Of course, the disks Lenovo provides only restore the original factory settings. They couldn't provide you with a nice OS disk like Dell and HP do...)
2) Is there any explanation for why my usb floppy drive sometimes works and sometimes doesn't? Any way to fix that?
3) Is there something I missed when making my original image which caused this mbr problem? Leaving out a drive letter or something? The Lenovos have a utility partition which I figure it's good to leave there just in case, but so do the Dells and they don't cause this trouble with Ghost.

Any hints or insights would be greatly appreciated.

Thanks so much, BK Lev

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

This may not help much

by Tigger_Two In reply to MBR on Lenovo r60 ThinkPa ...

As antiquated as this solution might sound... have you tried the native Windows Disk Management? I'm assuming WinXP here.

I have seen USB fail intermittently. I have never found a rationale for it. Sorry.

Your question is great- well worded and provided a ton of information. I am anxious to see what other answers are posted as the problem is certainly interesting.

Collapse -

Reponse To Answer

by lfruchter In reply to This may not help much

Thanks for your encouragement. Yes, it's all XP here. I'm unclear what you mean by "native Windows Disk Management." Unlike Dell and HP, I do not believe the geniuses at Lenovo provide a system disk with which to administer their crappy laptops. Instead of one little XP disk, they gave me a "Rescue and Recovery" CD and 5 data CDs to go with it. The RandR disk only lets you restore files on the hard drive or return the HD to the factory settings (which is what the other 5 disks are for). There are no useful utilities available. I can't even boot from their utility partition because all I get is "There has been a signature failure" unless I have a workable boot disk in there. I tried using my Dell and HP XP cds on the Lenovo, but that worked about as well as one would expect it to. Still pulling my hair out, Lev

Collapse -

Have you tried to update the bios at all?

Go here for more details on how to update your BIOS:
BIOS update utility - ThinkPad R60:

Collapse -

Reponse To Answer

by lfruchter In reply to Have you tried to update ...

Thanks for the suggestion, PT. Alas, I updated the BIOS (at least that much worked!) but it didn't change anything else for the better.

Collapse -

Drive Mfgr and Storage Drivers

by TheChas In reply to MBR on Lenovo r60 ThinkPa ...

I would check the brand of the hard drives used, and check for what utilities the drive manufacture provides.

As for booting from CD, I suspect that there is an issue with the actual storage driver on the Lenovo's and that you need to add and load a driver for the storage device onto bootable images.

As far as imaging software, I am a fan of Acronis and have never had any troubles with it.

I've not had the need to attempt to boot from a USB floppy drive so I don't have any answers there.


Collapse -

Lenovos Conquered

by lfruchter In reply to MBR on Lenovo r60 ThinkPa ...

Thanks all for your suggestions. Nothing worked but your interest and encouragement kept me from giving up (or worse). This forum is invaluable for me. Please keep up all your wonderful attention and efforts!

Here's my work around:

I was raised to be respectful and cautious. Because of this, I figured I should keep Lenovo's utility partition on the ThinkPads' HDs, just in case. Well, forget that. I used SuperFdisk to delete the utility partition from one of my working machines. With only my primary partition remaining, I tried to image the HD using my nice linux PING program: success this time.

In the same manner, I then deleted the utility partition from a recalcitrant laptop, one of the ones that wouldn't work with the floppy drive that held Fdisk. Once both my image and my target HD had only single partitions, I re-imaged the misbehaving laptop. As long as I told PING not to add the extra space from the deleted utility partition to the new partition AND told it not to mess with the BIOS settings, PRESTO: successfully imaged and wonderfully working laptop.

I can only wish I'd thrown respect and caution to the winds earlier.

Thanks again, Lev

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums