Software

General discussion

Locked

Net send Command

By hop228a ·
I need some help in using the net send command on a xp pro home network. I've tried sending one on computerA to computerB. ComputerA says its sent successfuly, but nothing arrived at computerB.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by ReWrite In reply to Net send Command

If you are sure that the messenger service is enabled and running (started) on both pc's then also check for the Terminal Services and make sure that it is enabled and running (started) on both pc's.

Cheers.

RW

Collapse -

by hop228a In reply to

Checked, both machine have enabled.

Collapse -

by hop228a In reply to Net send Command

Point value changed by question poster.

Collapse -

by ReWrite In reply to Net send Command

OK, let's narrow it down. On each pc, send a message to that pc. Try it by name and by ip address and by the loopback (127.0.0.1). Can each pc send/receive messages to itself? The 2273 message is telling you that either the message is not going out or it is not arriving at one of the pc's. Also,as an afterthought, do either/both pc's have a firewall enabled (don't remember asking this before)? If so, disable it.

Cheers.

RW

Collapse -

by hop228a In reply to

Okay, still getting the mentioned error when I tried by name and ip address. I get the same message when I tried the loopback ip.

"An error occurred while sending a message to computerB.

The message alias could not be found on the network.

More help is available by typing NET HELPMSG 2273."

Collapse -

by hop228a In reply to Net send Command

Point value changed by question poster.

Collapse -

by ReWrite In reply to Net send Command

OK, let's review computerB. The messenger service is enabled. You can do a "net view" and see computerA and computerB. Doing a "net send computerB test" from computerB gives you the 2273 error.

Try these steps. If you have a firewall on computerB disable it for the time being. If you have to disable it, try the "net send" command and see if it works. If so, you will need to adjust your firewall to allow the "net" commands through. If it doesn't work then check the netbios settings for the local area network. Go to Start->Control Panel->Network Connections->Local Area Connection. Right click and select Properties. Choose Internet Protocol (TCP/IP) and click the Properties button. On the General tab click the Advanced button. On the WINS tab in the Netbios area choose "Enable Netbios over TCP/IP". OK your way out of all of the dialog property boxes.

Another setting that can stop "net send" messages is TCP/IP" filtering. By default, filtering is not enabled but you can check it by going to Start->Control Panel->Network Connections->Local Area Connection. Right click and select Properties. Choose Internet Protocol (TCP/IP) and click the Properties button. On the General tab click the Advanced button. Go to the Options tab, select TCP/IP filtering and click the Properties button. If the "Enable TCP/IP filtering" checkbox is checked make sure that no filtering is done for port 135 in the TCP or UDP boxes.

When changing any of the settings mentioned wait about 30 seconds before trying the "net send" command. Sometimes there can be a lag before the command takes effect.

Post back with your results. Once you get computerB to "net send" a message to itself then try a message to computerA and vice versa.

Cheers.

RW

Collapse -

by hop228a In reply to Net send Command

This question was closed by the author

Related Discussions

Related Forums