netbios disabled - can't understand why

I am running a 2 node network. No router. Both are running windows xp pro sp2. Main machine has 2 nics. One to roadrunner modem for internet. second nick is for local network-static ip This is connected to second system via cat 5 crossover. that system nic is This network connection is for file transfers only, no internet connection sharing. I am also using zonealarm pro as firewall, windows firewall is disabled. Up until yesterday, all worked as it should work, but suddenly, neither machine could see the other or connect to the shared folders. I can ping both ways successfully. I have made sure that zonealarm is not blocking the connection. Upon the ipconfig /all command, i see that netbios is disabled for both nics, but upon checking tcp/ip advanced properties for each nic, they show netbios enabled. I have added no new software or new updates. Netbios just stopped. Any ideas on what could do this?

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

mine did it too, but I fixed it

by ThumbsUp2 In reply to netbios disabled - can't ...

Today, my system did the same thing. It could have happened yesterday, but I didn't notice it then. Up until I noticed, I had been sharing files the printer without problem. Today, the laptop couldn't see the printer connected to the desktop nor could it access the shares.

I ran the network setup wizard again and found that file and printer sharing had been turned off. Even though the shares still looked to be there and everything appeared to be turned on including file and printer sharing in the firewall... when I look at each individual computer through the wizard, the protocol was turned off on the desktop. The laptop had not changed, although it had not been turned on for a few days either.

I don't know if MS slipped us another unauthorized update that we didn't know about or what exactly did happen, but that's what I found and what worked to correct it.

Collapse -


by WOVERCASH In reply to mine did it too, but I fi ...

Thanks ThumbsUp2. Really strange situation here. After your response I ran the network wizard again, then checked setting and properties on both nics. The local only nic shows file and printer sharing installed and enabled. in advanced settings, netbios over tcp/ip is enabled. I pinged both to the other system and back to the main system with a good ping response both ways. i doublechecked my local network settings in Zonealarm, those are good too. Unfortunately, my own system doesn't appear in network neighborhood, nor can either system still connect back to each other. Ran ipconfig again, and same results- shows netbios over tcp/ip disabled for the local nic. I have never seen this before. Went back to the nic's tcp/ip settings and checked again- according to that netbios is still enabled. Maybe MS did slip another one in. I know they did one a couple of weeks back. I can't think of any other settings or services than can switch netbios on and off like that. Really wierd.

Collapse -

Try this

by ThumbsUp2 In reply to re

Try taking out the 2nd NIC card and see if you can get the local LAN working without it. Maybe it's something as simple as needing to be reset something after a power bump... After all.... stranger things have happened with bumps in the night!

Collapse -


by WOVERCASH In reply to Try this

Will try it. Thanks. Will go offline to do it. 2nd nic is my internet connection. Will get back later. Strange things about those bumps huh!
EDIT - Tried that and no luck then either. With just local network running, still exibits same problem. Going out to buy new nic tomorrow, and try that. Thanks for the suggestions anyway.

Collapse -

2nd one did it today

by ThumbsUp2 In reply to mine did it too, but I fi ...

The laptop just did it, twice, today.

When it first booted, it had no LAN. It had internet, but not LAN. I ran the wizard on it and reconnected the LAN. It was communicating while I was running WinMerge to synchronize some data folders. While I had my back turned, working on the desktop, it dropped off the network. It still had internet access. I went through wizard to set it back up and it immediately dropped back off. I ran the wizard a 3rd time and it has been connected and working ever since.

So, what do we have in common?

I do not use Zone Alarm. I use a Qwest DSL wireless router/modem for LAN (desktop via cat-5, laptop via wireless). The Qwest modem is the DHCP server, firewall and gateway. Both computers are WinXP SP2 fully patched (plus some). Both computers have Windows Firewall turned on. Both computers use Norton 2007 Antivirus. Both computers run Office 2003 Pro fully patched. The laptop doesn't have much else installed on it. I use it to take with me in the field, then come back and synchronize folders and do the majority of work on the desktop. On the other hand, the desktop has so much crap on it..... well, you know.

I just had a thought. Is it possible Norton updated something that caused it?

Collapse -


by WOVERCASH In reply to 2nd one did it today

Well, I see only one one similarity between your setup and mine- winxp pro sp2 and the latest hot fixes. Something in one of those updates are causing us some weird problems. I am still wondering about those secret updates that came unannounced and without my approval. I have windows firewall off, don't use office, and my antivirus is NOD32. Maybe norton did update something on you. I tend to still question Microsoft's updates though. Gonna go back to Microsoft and do some more poking around.

Collapse -

Zone Alarm

by net1tech In reply to netbios disabled - can't ...

) Rip netbios, reboot and reinstall
) Zone Alarm - had a lot of issues keeping my home network running with Zone Alarm. Disable Zone Alarm. Use a simple firewall like Sensive Guard without all the bells and whistles temporarily to test.

Collapse -


by WOVERCASH In reply to Zone Alarm

Thanks for the reply. I disabled ZA, ripped the netbios and rebooted, reinstalled, but still same problem. Even tried uninstalling all network props and protocols, reboot, reinstalled. Same problem then too. At least I know it has nothing to do with ZA. Still getting same conflicting responses- Windows networking props say that netbios over tcp/ip is active. In command prompt- ipconfig /all shows netbios disabled. must be some problem in the registry. All necessary services are running, and the nic pings both ways, but no connection can be made. Microsoft has no help on this either.

Collapse -

Ok you can try this

by nentech In reply to netbios disabled - can't ...

Try installing the NetBEUI Protocol
This was use by Microsoft in the old days

On the Windows XP cd in this folder


Open the file NETBEUI.TXT

This will tell you how to install it

You can also try the IPX/SPX/NetBIOS Compatible Protocol

These Protocols will be ignored by TCP/IP network devices

They can be handy if you want to stop someone from using the internet
But still want to share files with them

Just disable the TCP/IP Protocol on their computer
Bingo they can access other network PCs but not the internet


Collapse -

Thanks to everyone

by WOVERCASH In reply to Ok you can try this

Thanks for that suggestion. I had considered it, but dismissed it in my tunnel vision of desperately attempting to find the cause. Truth is I may never find the cause and short of a format and reinstall, may never fix the problem. This is a good workaround, and it did work. All I needed was file transfer ability restored. That I do have now. Thanks to everyone.

Back to Networks Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums