General discussion


Newbie Cisco Router problem

By soma561234 ·
Hey everyone. I recently bought a couple of routers to work towards some certifcations however one of the routers already has a username and password configured on it. I am unable to reach the previous owner. The router is a Cisco 4000. I know it's old school however for a beginner like me it will serve it's purpose. I have serched throughout Cisco however the information is overwhelming. I don't want to accidently erase the OS and I am really new to this technology. Whenever I boot it up it goes right the the username and password prompt. Any suggestions?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CuteElf In reply to Newbie Cisco Router probl ...

Post this in the Technical Q & A.

Other than that, have you gone to
Have you a book/manual? I know you need to hit a comb. of keys to get to safe mode boot...
can you telnet into it?

Good luck

Collapse -

That's easy...

All you need to do is boot into ROM Monitor mode. Depending on the telnet software you use will need to press a key combo to enter it.

Now I don't know the steps for the 4000 series, though I imagine they can't be much different than a 2600 series router.

I'm going to list the steps for a 2600 series which should point you in the right direction. For this purpose I am assuming you will use Windows Hyper Terminal.

Consider the router's config register is set to 0x2102 or 0x102. Essentially they're the same. Cycle the power on the router and press the break key on your keyboard within 60 seconds of the router beginning the boot process.

For hyperterminal it is Control+F6+Break or Control+Break.

At the Rommon 1> prompt type: confreg 0x2142
At the Rommon 2> prompt type: reset

When the router boots up again, it should ignore it's config file in nvram. Press CTRL-C to skip the initial config.

Enter enable to go to the priveleged exec mode.

At this point you can either type :
erase startup-config file
which will erase the startup-config in nvram


copy startup-config running-config
show run

Look for the unencrypted passwords, you can use these. Any encrypted passwords will have to be re-entered.

To re-enter any encrypted passwords try this:

conf t
for secret:
enable secret yourpassword

for normal password:
enable password yourpassword

and so on for the other passwords for vty, console and line.

The final step is to type the following:

config-register 0x2102
CTRL-Z or End
copy running-config startup-config

Now reset your router. Passwords should be gone. :) Hope this helps you out.

Collapse -

by soma561234 In reply to That's easy...

Next time I will post in technical Q @ A. Thanks for the great response. I know it will put me in the right direction. I'll give it a shot in the next couple of days. I did go to cisco however I couldn't find anything about reloading this router (it's quite outdated as I'm sure you are aware). In any event I'll try the sequence noted to boot into ROM monitor mode. Hopefully it will work.

Collapse -

by soma561234 In reply to That's easy...

It worked!! Awesome. Now I can go ahead with some labs! Thanks again.

Collapse -

Glad it worked...

by Angus McLaren-20563336362429375073194186836826 In reply to

And I'm glad I could help. :) Enjoy your routing. :)

Collapse -

Brilliant thanks

by Madsmaddad In reply to That's easy...

I had got into Rommon, but didn't know what to do.

Confreg and reset worked. thanks for posting.

Back to Desktop Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums