General discussion


Office 2007 changes file permissions when saving on network

By mathias.schenker ·
I recently upgraded to MS Office 2007 on our computers. Ever since I have had a very puzzling problem: whenever word or excel save a file (existing or new) on a network share, they change the permissions to read only.

I'm using Windows XP, Office 2007 professional on the clients, Linux with samba 3.0.30 on the server. Whatever the file permissions were before, after saving they are reset to 400 (user only, read only).

This problem is new to Office 2007, with the 2003 versions everything worked fine. Until now I have found no answers on the internet.

Does anybody recognize this problem? I'd very much appreciate any hints and tips!

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

change the

by Jaqui In reply to Office 2007 changes file ...

default options for the samba share.
kill user attributes on it.
[ owner nobody and group nogroup result ]
set samba to make the share writable and readable.

then the file perms can't be altered by anyone but root on the system running samba.

Collapse -

Office 2007 changes file permissions when saving on network SOLVED

by mathias.schenker In reply to change the

after many searches and with a little help from my friends i found this in a remote corner of the googleverse:

it seems that removing "profile acls = yes" from smb.conf does the trick.

i was puzzled on end by the changed behaviour of office 2007. now i'm just glad it's fixed. thanks for your support.

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums