OK, now it's my turn for needing help........

By ThumbsUp2 ·
Hi all,

I've got a doozy of a problem that I'm hoping someone can help me solve so I can avoid a trip to the other end of the state (8 hour drive, one way).

The computer involved is stuck in an endless reboot cycle. I don't think it's hardware related, but can't confirm that just yet. Here's what happened. Please bear with me, it's a long story.

I use a program called GoToAssist Express to remote into some of our field offices and I've never had any problems with it. The program allows me to send a "Reboot" or "Reboot to Safe Mode With Networking" signal to the computer on the other end and, after rebooting, it automatically reconnects that computer back to my remote session. I simply log back into the remote computer as if I was sitting right there. No intervention on the other end is ever required unless I need them to put a CD in the drive.

Yesterday, using GTAX, I had remotely connected to this particular computer, uninstalled some stuff they weren't supposed to be running (MSN and Google Toolbars), ran CCleaner to clean it up, rebooted it, logged in again, installed our GIS software, rebooted again, tried to configure the license manager on the GIS software and failed. This is not the problem though. I ran out of time in the day to finish the rest of what I needed to do, so I disconnected the remote session and went home.

Today, I started another remote session with this computer and tried a few things, including remotely rebooting the computer, in an attempt to get the GIS software to connect to our license server, but was again unsuccessful. Since we've had problems with this particular software before and it's always related to the order things have gotten installed in, I decided to uninstall all of it as well as uninstall Office, reboot, clean the registry (CCleaner), reboot and start the installation process all over again. Here's where the problem really begins, so bear with me. I'm almost there.

I received an error when trying to uninstall the GIS software (unable to uninstall, call the vendor? yuck!), so I was going to reboot to Safe Mode and try the uninstall from there. Using GTAX, I sent the command to "Reboot to Safe Mode with Networking". My screen showed the remote computer shutting down to begin the reboot cycle. As usual, after the remote computer begins the reboot cycle my screen simply showed that it was waiting for the remote computer to reconnect. However, the process took longer than it normally does with no response from the remote computer, so I called the field office to ask what she saw on the screen. She said it showed the typical F8 menu where you select Safe Mode or Normal boot, etc?, but it did not display all of the options which are normally present on that screen (abbreviated menu) and it had a timer counting down. Before she could read me all of the choices and select one of them, the timer expired and it rebooted again, coming up with the same screen. She said it had been doing this several times before I called her.

We let it do this one more time, then I asked her to select "Safe Mode With Networking" and press the enter key. It simply rebooted and came back to the same screen with minimum options. So, the next time it rebooted from the timer, I had her press the F8 key during boot. This time, the computer displayed the entire list of options that it normally shows and had no timer running. Good! We're making progress, right? I had her select Safe Mode With Networking one more time and press enter.
Now, normally one would see a list of OS's to boot into and if there's just one OS, that's all it displays. You simply press enter to continue with the boot. Her computer only has one OS installed, so I would have expected it to say "Windows XP Professional" and waited for her to press enter. This time, it said "GoToAssist Express" and waited. There were no other options to select. I told her to press enter and see where it goes. Well, guess what. After she pressed enter to accept the only option there was to select, it rebooted right back to the smaller screen with the timer running. We went through this process over and over again, trying different options including Reboot to Last Known Good Configuration and even Safe Mode with Command Prompt. Each time, it rebooted and came up with the abbreviated menu and timer. If we went through it using F8 to boot, the "GoToAssist Express" instead of "Windows XP Professional" was eventually displayed and each time, pressing enter simply rebooted the computer back to the abbreviated boot menu with a timer running. I also had her turn the power completely off, disconnect the power cord, disconnect the 2nd monitor, disconnect the network cable, disconnect all peripherals (printer, scanner, etc?) and try booting up that way using all of the various options. No luck.

Thinking that GTAX had gotten itself stuck in a loop and also knowing that every programmer worth a hoot builds a backdoor in to and out of their software (just in case of endless loops), I called the GTAX Tech Support and explained what was happening, hoping they could give me a key combination which would bypass the GTAX reconnection sequence. In a 3-way conference call, their Tech Support had the gal at the other end try all of the same things I had already tried and they were stumped by what was happening. Tech Support said it was impossible and called in one of the Software Engineers who took her through all of these things again. No luck.

The GTAX Tech Support left the call telling me there had to be a hardware problem with the machine because their software couldn't possibly be causing this endless reboot cycle, that it simply wasn't possible given the fact that we had physically turned off the computer and unplugged the network cable thereby terminating the remote session. Yeah, well one would THINK that was what should happen, but the problem still persists. It's stuck in a loop. The computer is trying to reconnect to a remote session which has been terminated and it's not going to do anything at all until it can do what it is supposed to do.

Oh, and did I tell you that, despite what they said, GTAX does in fact allow a session to remain in tact even when the network cable is disconnected, the lid on a laptop is closed and it's put into hibernation and unplugged (although on battery), transported into a different room, plugged back into power and network, opened the lid and logged back in? Yeah! The session doesn't terminate as long as you do it fast enough. I do it every Monday morning for the boss! :-& And yes, I had the user today turn off the computer, unplug it and wait 3 hours, then try it again. No luck.

So, before I make the trip tomorrow, does any one have any ideas how to reset the boot sequence back to normal so this silly thing doesn't try to boot back into a non-existent remote session of GTAX? Remember, I have to talk her through it over the phone AND?. this is the kicker?. she doesn't have a normal WinXP CD to boot into so we can try to use the console. The OEM CD's that come with this particular brand of computers can only be used to wipe the drive and re-image it. There are warnings all over the CD not to use them unless you intend to wipe/re-image. I had to learn the hard way, not to ignore those instructions!

This conversation is currently closed to new comments.

129 total posts (Page 1 of 13)   01 | 02 | 03 | 04 | 05   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Bear with me I am still reading, but

by The Scummy One In reply to OK, now it's my turn for ...

have you tried recovery console and a system restore or a boot.ini change?

Also, are you using the same system and does it have the same IP Address (if the SW works from IP). Maybe it is rebooting due to not finding the right address (just a stupid thought).

I will finish reading in a few minutes

Collapse -

Ok, no recovery console

by The Scummy One In reply to OK, now it's my turn for ...

However, if you have an NTFS write boot disk that she can copy and use, I am pretty sure that the boot.ini can be changed (likely the program creates a boot.old from the boot,ini file and puts in a new boot.ini for the app to run). If you can get her into the file system and have her copy a boot.ini file or put the old one back, it may save a long trip.

Collapse -

Another suggestion! For the future (not this to fix this)

by The Scummy One In reply to Ok, no recovery console : ...

add the recovery console to the systems that you support like this remotely.

Collapse -

Hindsight is always 20/20, isn't it?

by ThumbsUp2 In reply to Another suggestion! For ...

Yeah, wish I had thought of that the last time I made the rounds to all the field offices!

Collapse -


by ThumbsUp2 In reply to Ok, no recovery console : ...

The thought of the software creating a a boot.old hadn't even crossed my mind. We can only hope that's what it does. If I could just get her to a command prompt, we should be able to get it back up and running.

First thing tomorrow, I'll see if I can walk her through getting some sort of boot disk created which will allow her to get to a command prompt, even if we have to use another computer and download Linux Live to 'Get 'er Dun!

She's not going to have the slightest clue what to do, so I'll have to walk her through every step of the way. I just hope I can get it all done in an hour or I'll be driving through the last mountain pass tomorrow night and it's currently snowing up there.

Collapse -

The problem with a live cd

by The Scummy One In reply to Thanks.......

you can copy data from a drive, and fix the partition -- but it does not have NTFS write capabilities.
Also, if it is NTFS, a DOS boot disk will not work either, unless you have an NTFS Write DOS disk.

I am glad to have offered at least a little help :)

Collapse -


by ThumbsUp2 In reply to The problem with a live c ...

You're just full of sunshine! Aren't you?

Collapse -

Perhaps UBCD or Knoppix

by seanferd In reply to ... :(

I've used several different boot CDs to paly with an NTFS volume. If they have Midnight Commander or similar, and NTFS4DOS or similar, it'll work. I thought I've written to NTFS from the older Knoppix (5.1.1), but any CD that gives you the choice to boot to a * Commander file manager should work.

I'll check.

Collapse -

I'll be taking it with me.....

by ThumbsUp2 In reply to Perhaps UBCD or Knoppix

UBCD, among others, will be going with me.

I was just hoping to be able to find a way to avoid the trip this late in the week. I won't have much time in the morning to walk her through some pretty complicated tasks. You and I know what we're looking at and for, but she's hard pressed to learn how to get into OWA with the browser, if you get my drift!

Collapse -

Well, I checked Knoppix, it works just fine

by seanferd In reply to I'll be taking it with me ...

I was thinking of posting a series of screenshots to photobucket as a walkthrough.

I think your're covered with the UBCD, and if you are going anyway - oh, well. Sorry you have to make the trip. Take care.

The Knoppix I used is
I'd guess the newer versions would support writing to NTFS, but I've not used them. I should have known positively that the above version did, as I had it write a small page file to my C: drive. (Duh. Looked right at it when I looked at the boot.ini.)

It automounts all drives and shows them on the desktop, so if you copy a boot.ini to flash or floppy, it will be right there. The only thing to check is that the HDD is writable by right-clicking for properties, ensure Owner has read-write, and on the next tab, that read-only is unchecked.

Edit: Oh, and good luck. Drive carefully, lights on for safety, and all that.

Back to Networks Forum
129 total posts (Page 1 of 13)   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums