General discussion

Locked

Port won't close after use

By smundine ·
I am running Windows 98 on a PIII 650Mhz system. I have a USRobotics v90 internal modem. I have to delete the modem everytime before I shut down so that the system will reconfigure it upon startup. If I use the modem then disconnect then try to connect again I will get an error message 630. When I run diagnostics then on modem it says that it can't open port or port is already open. I show an ACPI controller using IRQ9 which is the same interrupt the system assigns to my modem when I startup. If I try to change the interrupt to IRQ3 or 4 it says it is in use by com1 and com2. If I try to use Com1 thru 4 it tells me that they are in use.

This conversation is currently closed to new comments.

24 total posts (Page 2 of 3)   Prev   01 | 02 | 03   Next
Thread display: Collapse - | Expand +

All Comments

Collapse -

Port won't close after use

by bgridley In reply to Port won't close after us ...

If you are not actually using the Com1 or Com2 ports on your PC then go into your BIOS setup and "Disable" them. This will free up the associated IRQ (Com1 = IRQ4 , Com2 = IRQ3)
This should then allow your modem when you boot to be configured to Com1 or Com2.

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by tlippert In reply to Port won't close after us ...

Go to device manager and remove all comports. Remove the modem. Shut down the system.

Remove the modem from the computer.

Turn it back on go into BIOS.

AWARD bios: make sure ports are set to com1 and disable second com.(unless you need it then com4)

AMI bios: make sure ports are set to com1 and com4. (do not disable comports on an AMI bios. You will get a mystery comport).

Turn it on bring it up into windows. Shut the system back down then reinstall the modem. Hope this helps!

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by Pyro In reply to Port won't close after us ...

i got the same prob w/ my Rockwell Modem(internal) first thing u should do is remove modem in control panel then remove any software associated with it then ren install everything and make sure nothing is conficting with..

Pyro

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by saihib In reply to Port won't close after us ...

The reason you can't reconnect is because rnaapp.exe is still running even after you disconnect. It is also the reason you are told the port is open when you run diagnostics. Hit ctrl-alt-delete and end the task and your should be able to reconnect and run diags.Error 630 means that the computer is not receiving a response from the modem. Check your accessibility options in Control Panel and make sure that "support serial key devices" is disabled.

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Collapse -

Port won't close after use

by welovells In reply to Port won't close after us ...

***HOLD IT! HOLD IT! HOLD IT!*** Be wary of all advice given so far. If it where a conflict with another device for the port, it wouldn't work right in the 1st place. 3com modems often work on IRQ9, The sucess of that is really up to the BIOS on the MB. more than likely the modem is bad, one of the recent storms in your area has fused the relay. It will not close by itself. Lastly, It is the responsiblity of the PC you are connected to, to send a close port signal to the modem on disconnect. If the modem is fine, it is probly your ISP.

Collapse -

Port won't close after use

by smundine In reply to Port won't close after us ...
Back to Desktop Forum
24 total posts (Page 2 of 3)   Prev   01 | 02 | 03   Next

Related Discussions

Related Forums