Problem w/Mapping a Drive Over a PPTP VPN Connection

By richard.f.toomey ·
My neighbor just started a small business. At his business location, he has an XP Pro desktop. The XP Pro machine is connected to one of 4 Ethernet switchports on a Netgear FVS114 VPN router. (It's the only PC on his store network.) The FVS114's "Internet" Ethernet port is in turn connected to the Ethernet port of a ZyXel DSL modem. The ZyXel's hanging off of an ADSL circuit provisioned as a 3Mbps download/512Kbps upload. Everything works great at his store: Internet access is fine, and the XP Pro desktop performs swimmingly.

I configured his XP Pro store PC as a VPN server and defined a new VPN client connection on a PC at his home. The problem: he wants to be able to map a drive over the PPTP VPN connection from his home PC (which runs WinXP Home Edition rather than Pro) to the store's XP Pro PC. Although we can start a VPN session from his home office PC with no problem, and although that session stays nailed up, our attempts to map a drive from his Home Edition PC to a shared folder on his store's XP Pro PC (after the PPTP VPN session is established) consistently fail. (We just get a "not found" error every time.) Note that I can map a drive using PPTP with no problems from my test laptop (which is running XP Pro) from MY home office. I suspect XP Home Edition may be the culprit. I would appreciate any ideas re: the possible root cause. Thanks!

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How are you identifying the server

by shardeth-15902278 In reply to Problem w/Mapping a Drive ...

are you usng the NETBIOS name (THESERVER)
the FQDN (
or the IP address?
I assume you have already confirmed that you can ping the server?

I'd recommend trying \\<ip address>\share

XP HOME definitely is short a few brain cells with respect to networking, but it SHOULD be capable of mapping a drive.

Collapse -

Problem w/Mapping a Drive Over a PPTP VPN Connection

by richard.f.toomey In reply to How are you identifying t ...

Thanks for the suggestions. I've tried both the NETBIOS name and the IP. (\\servername\share & \\<ip address>\share). Both work from my XP Pro test laptop, neither work from my neighbor's XP Home Edition PC. I've NOT tried the FQDN yet. Good suggestion. I'll give it a shot. Thanks again.

P.S. - And yes, I'm able to ping the server once I've established the PPTP connection. In fact, I configured his Netgear VPN router to port-forward Remote Desktop Connection requests to the server, and that works fine. He would just prefer avoiding the remote terminal approach, although it is a workable option. It's just driving me nuts that I can't map a drive to the share from his XP Home machine while PPTP-connected but I can from my laptop while PPTP-connected. Weird.

Collapse -


by shardeth-15902278 In reply to Problem w/Mapping a Drive ...

One other thought, does his XP Home PC have any anti-virus/spyware or Firewall software on it? It is possible something is blocking a return packet. (Which does lead to a final option for troubleshooting. Install wireshark on his XP home machine and capture the packets while attempting to map the drive. You can run on your machine to obtian a baseline of a successfull map and compare his to yours.)

Before you do that, is anythign showing up inthe event logs on either system?

Collapse -

Try set both PC to same work group and ...

by fwang In reply to Problem w/Mapping a Drive ...

If the two PC you are talking about is XP pro and XP Home, I assume there is no domain. You can set up these two PC with the same workgroup. Use same user name and password on both PC, make sure the user have access right to the shared folder. Then you should be able to connect the shared folder.

Collapse -

Problem w/Mapping a Drive Over a PPTP VPN Connection

by richard.f.toomey In reply to Try set both PC to same w ...

Thanks for your suggestions. Both PCs are in the same workgroup (no domains are defined). I did note that his XP Home machine used "MSHOME" as the workgroup and "WORKGROUP" for the workgroup on the XP Pro server, so I changed the Home Edition XP machine to "WORKGROUP", but no luck. I'll double-check the access rights, though. Thanks again.

Collapse -

Similar problem

by peluca__ In reply to Problem w/Mapping a Drive ...

I have a similar problem. Have two pc's connecting to a server through PPTP VPN. Connection is ok, able to ping the server and all but no drive mapping. The working pc is a Xp pro machine and the non-working is a Vista machine. Maybe the problem is a Vista issue? Any solution would be much appreciate.

Collapse -

for the time spent

by CG IT In reply to Similar problem

upgrade the XP Home to XP Pro since you've had success at establishing a mapped drive on your test laptop [running Pro].

you can get XP Pro SP2 from for $140.00 USD plus ship and tax.

If the owner was paying for tech support, the cost of XP Pro that is known to work is less than the total labor to troubleshoot [billable hours].

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums