Windows

Question

Locked

Problem with Maxtor EXT HDD on Win7

By Cracktower ·
I have read some of the forums on this topic so if this is a repeat please excuse me. I have a Maxtor Touch II 300 Gb EXT. HDD. For the life of me I cannot get it to work on Win7 even though it is recognized. I will break down as much info as possible that I think is relevant.
1)Installed with original disk and updated drivers from the Seagate site for Win7
(express_HD_EN_1_1_127)
2)Rebooted and the One touch menu comes up, the new hardware wizard for Win 7 came up and said it was installed and ready.
It is in the disk management screen. It recognized 279.48 gb (unallocated) and is labeled disk7 with a red arrow pointing down with the following underneath.
Unknown,279.48 GB Not Initialized.
3) I tried to initialize under MBR but it says incorrect function.
4)If it helps, this is the farthest I got with a usb 2.0 cable. It came up with an error (yellow triangle with exclamation point)in the device and printer screen when I used the firewire port. I tried both firewire ports btw. It also says in properties that my drivers are up to date.
5) The Drivers and Maxtor One Touch are recognized as well in the uninstall window.
Sidenote- this drive work flawlessly on both of my xp pro machines in my network but they are 2 stories down and I bought this thing for one purpose only, to backup when needed and then turn off. I don't keep it on all the time ( nor the network stays on 24/7) and though I admit I can use the excercise, I would rather get it to work on this Win 7 machine. I am at a loss on how to get this thing to work. Any help would be welcomed, Thanks in advance.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Related Discussions

Related Forums