Question

Locked

Problems accessing the administrative shared folders

By The_Parasite ·
Hi!
I'm trying to gain access to the administrative shared folder on my laptop, from my stationary.
They both have XP Pro installed, and the internal network between them works fine.
I have been looking at the Administrative shared folders for experimentation, but had the following problems:

When I tried accessing the C$ shared, I was prompted for a password, but was automatically given the username "Guest". As the guest user is deactivated on my laptop, that user was pretty useless.

1. Is there a way I can connect from XP to XP, without getting the guest user? Preferably without changing any settings on my laptop.

I tried booting my stationary from a live Linux USB, and the network manager there showed the C$ folder. When trying to access it, I was prompted for both username and password, and I gave the username and password for the Admin user on the laptop. This didn?t work, I was just prompted for the password again. (I checked for spelling and caps)

2. I had access to the other (normal) shared folders, but not the C$ one, so how come it didn?t work?

In advance, thank you for your help, and your time.
- Steffen

This conversation is currently closed to new comments.

50 total posts (Page 2 of 5)   Prev   01 | 02 | 03 | 04 | 05   Next
Thread display: Collapse - | Expand +

All Answers

Collapse -

Make sure that File & Printer Sharing

by Jacky Howe In reply to Error 5

is enabled. I don't normally have the Guest account enabled. Make sure that you are supplying the Admin credentials for the Laptop.

http://support.microsoft.com/kb/555644

Collapse -

To Jacky Howe:

by The_Parasite In reply to Make sure that File & Pri ...

I checked in the Lan settings, and it is enabled... Also, it would surprise me otherwise, as I have no problems accessing anything else that is shared, from or to either system, it is only the admin shared that I cannot access.

Collapse -

By the way...

by The_Parasite In reply to Error 5

I'm not sure I made this clear, but my network is P2P, not server based.
Also, thank you all for your time, even though I have yet to reach my goal of actually getting access to the admin shared folders, I feel like I have learned something :)
Btw. Any ideas why it didn?t work, when trying to connect from linux? (Or is that probably the same reason as why it doesn?t work from windows?)
- Steffen

Collapse -

P2P

by Mehul Bhai In reply to By the way...

Now assuming this is a home network and is in a workgroup, when you connect and when you get the password prompt, you should input the following in the UserName Field "Workgroup Name/User Name" and password in the Password Field, where "Workgroup Name" can be obtained by seeing the Computer Name Tab in the System Properties in the Control Panel of the Laptop & the "User Name" should be any user having admin control on the laptop. This will surely connect. I have connected many non-domain computers temporarily to our Domain computers this way in our organizayion. This is because the computers' authentication procedure should like to know where to look and authenticate your login credentials you supplied while trying to connect. This is not the problem in a Domain environment where you can give rights to users you want to connect to your shares.
Please let us know the result after trying the same.

Collapse -

thanks, but...

by The_Parasite In reply to P2P

Thank you for your post, though I'm not sure I understand your answer correctly, but if I do, I think you might have misunderstood me. My problem is not to connect normally from the one computer to the other, but to access the hidden administrative shared C$ folder on the one computer, from the other.
If I the address \\SD (the name of my laptop) on my desktop, it opens the shared folders on my laptop, without prompting for user or password.
If I write \\SD\C$ I'm prompted for a password, but the username is grayed out and show SD\Guest. I have used the command-line NET USE X: \\SD\C$ for trying the other usernames.
Btw. Just to clarify, my network is just my desktop, my laptop and a switch. (closed network)

Collapse -

Reply

by Mehul Bhai In reply to thanks, but...

My reply was for that only (C$ accessing) but I donot understand how the user name field is having any data and is greyed out. May be you have saved the username and password previously while accessing a share, which should never be done for security reasons. And SD is the Computer Name of your laptop. Check what is the Workgroup Name as in the procedure I mentioned before.

Collapse -

the gray problem...

by The_Parasite In reply to Reply

My apologies, I probably misunderstood you then.
When I try to connect "normally" to the C$ folder, the username is still grayed out and reads "SD\Guest"... if this is a default setting, me having saved something at some point or what, I have no idea, but it is the same whether I'm logged in as my normal user or the Administrator.
(How can this be un-saved / un-grayed?)
If I try the command prompt, and write "net use x: \\sd\C$" and provide the username: "workgroup\Administrator" I just get the error 5. If I write "workgroup/Administrator" as username, I get a "wrong syntax on username, please write a new username" message.
(And yes, I use the default workgroup name) :)

Collapse -

This article might help..............

by ThumbsUp2 In reply to Problems accessing the ad ...

Here is the MS article on How to create and delete hidden or administrative shares on client computers.

http://support.microsoft.com/kb/314984

It describes how to create a hidden/administrative share, so perhaps you can look at the one you've already got and check to see if the "Administrators have full control; other users have no access" checkbox is checked.

If it is, you can only access that share using the username of "Administrator" which is the default username assigned to THE administrator account. You can't access it with a username which only has admin privileges.

Collapse -

I tried this:

by The_Parasite In reply to This article might help.. ...

Thanks for the article!
I looked around a bit, and got this:

"Control Panel => Administrative tools => Computer Management => Local Users and Groups" show the users:
Administrator, Guest, Helpassistant(deactivated), Steffen, and Support(deactivated).

"Control Panel => User Accounts" Only show these users: Steffen and Guest (not active)

I tried making a new account in the "User accounts" panel, named "Administrator", but got the "Name already taken" message... So what I'm looking at is a "hidden" admin user, that doesn't show in the accounts panel... (I vaguely remember something about a prompt about the admin user when installing Windows, but always figured the normal user with admin rights would be it... guess not!)

I tried right-clicking on the C$ folder in the "Control Panel => Administrative tools => Computer Management => Shares" Folder, but only got the options "Update" and "help"... my guess is that this is because I'm not logged in as the "Administrator" user. (There where no options for stopping sharing, or making new shares, for any folders, not even the "normal" folders I have shared)

So, if I understand this right, I can only gain access to the shared C$ folder, if I log on as the Administrator.
As there already is a default Administrator account, I cannot create one to test with, and as it doesn't show in the "normal" user accounts panel, I cannot log on to it.
I tried to connect from my desktop to my laptop with Net Use, and using Administrator as the username, with a couple of different passwords, (some default ones, and what I could think of if I had changed it) but just got an error 1326 "Unknown user or wrong password"...
I could reset the password in the Administrator tools, but I have no idea if this would change anything, so at the moment, I'd rather not...
So, I'm still not able to access the shared C$, but on the up side, I've learned a lot about windows accounts and shared folders management :) (and default settings/users)
Sorry for the wall of tekst :)
- Steffen

Collapse -

re: How to log in.........

by ThumbsUp2 In reply to I tried this:

If you're using the Welcome screen at login, you won't see the default Administrator user account. If this is WinXP Home, you must boot to Safe Mode to see access the Administrator account. If this is WinXP Pro, there's a trick to get to it in normal mode.

To log in at the Welcome screen on WinXP Pro, press CTRL+ALT+DEL two times. At the resulting login screen, type the name "Administrator" (without the quotes). If you can not remember the password, you might not have set one so try leaving it blank and just press Enter. If you did set a password, you will have to remember it to continue.

Back to Linux Forum
50 total posts (Page 2 of 5)   Prev   01 | 02 | 03 | 04 | 05   Next

Related Discussions

Related Forums