Networks

Question

Locked

Remote Desktop connection problems

By jfuller05 ·
I've been using the remote desktop connection for me and a user outside our network to login to our server(a) for certain things. This week, the user calls and says she's not able to remotely connect to the server(a). I tried to remote in (I'm in the network) and I couldn't connect either. However, I was able to remote in to our other server(b).
I can see and access files on the (a), but I cannot connect to it to use remote desktop. Everything is fine with TS licensing, I couldn't find any problems there. Also, even if there were TS problems, shouldn't I still be able to use remote desktop (I believe at least one user can) without TS? I think so, so that makes this problem even stranger to me.
Anyway, the user was able to get her work done another way, but I still want to fix this problem. I believe it would be a hardware issue.
Any suggestions?
The user logins via VPN through our SonicWall, but I don't think that is an issue, since I can't even establish a connection within the network. Port 3389 is open for remote desktop. So it's not a firewall issue.

Server A: Windows Server 2008 standard.
Server B: Windows Server 2008 R2
Client Machines: Windows XP Pro SP3

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

rebooted routers and switch between me and the server. no luck. no text.

by jfuller05 In reply to Router?
Collapse -

And here I had my fingers crossed.

by seanferd In reply to rebooted routers and swit ...

Best of luck with your further efforts.

Collapse -

Service Up?

by oldbaritone In reply to RE:

You said "Remote Desktop Enabled" - but is it Started?

Especially since you can't connect internally, check to see that the service is up and running.

Collapse -

Yeah, I check it on the server and client...

by jfuller05 In reply to Service Up?

and the service is started.

Also, I ran telnet to try and connect to the server that way. Here's the message:

<i>connecting to 192.168.10.5...Could not open connection to the host, on port 23: Connect failed. </i>

edit: ports 3389 and 3489 didn't work either.

Collapse -

I'm with christianshiflet something changed....

by CG IT In reply to RDP

there should be something in the event viewer probably the security events but I'd also check the application events.

so did this start happening after a "patch Tuesday" ?

Collapse -

I'm thinking it's in the event viewer too...

by jfuller05 In reply to I'm with christianshiflet ...

but I've been following the warnings and errors; nothing major.

There was a time-service issue, I fixed that. There were DNS issues, fixed those. TS was issuing out temp. licenses, but I reactivated the licenses, so now everything <i>appears</i> to be fine in TS now.
However, I could be wrong.
I want to fix this, but a wipe-reinstall is tempting at the moment. :)

Collapse -

wait a minute... is the server a terminal server?

by CG IT In reply to I'm thinking it's in the ...

Is your remote desktop session for administrative work to the server? The RDP session is seen as a terminal services connection, but you don't need licensing for it. The server allows 2 concurrent connection without any terminal services client access licenses.

so what's really going on here.

Collapse -

Under server roles, TS is one of the roles...

by jfuller05 In reply to wait a minute... is the s ...

I use it for admin work to the server. Users outside the network use TS to login to the server and use it for software purposes.

That is why I'm confused, I should be able to login regardless, yet I can't! :0

Collapse -

not going to reread all the posts

by CG IT In reply to Under server roles, TS is ...

can you ping the server?

If your on the same subnet, and as a test you turned off the firewall, and you can ping the server, you should be able to RDP in provided your account is listed in the allowed accounts in the Systems settings for RDP [or are members of the Remote Desktop Users security group].

Collapse -

Yeah, I can successfully ping the server.

by jfuller05 In reply to not going to reread all t ...

We're on the same subnet, turned off firewall, and I'm a member of the RDU group; still, I can't remote in.

Do you think I should just restore from a shadow copy?

Or do you think this issue can be solved?

Related Discussions

Related Forums