Question

Locked

Server 2003 network shares slow under XP

By scott ·
We are converting our network over from Novel to Windows 2003 and have come up with a problem when it comes to the network shares.

When you open a network folder from a XP workstation, either using the name (//server/folder) or a mapped drive, there is a 15-20 second delay. This only occurs the first time you open the share, or if it has been more than 15 minutes since the last time you access it.

It is not a server or network load problem, we planned for extensive expansion and have never reached 10% of the systems capacity.

We still have our old Novel server on the network (don't want to move the user files until this access problem is solved), and if you browse the novel drives their contents come up immediately.

It does not look like a server-side problem as the Win2K clients that are still on the network can access the server 2003 shares immediately.

I have tried several of the solutions I have been able to locate so far, including:
Turning off the Computer Browser on the XP Workstations
Clearing out My Network Places
Disabling the SMB OpLocks (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters)
Removing the Scheduled Tasks check on remote access (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace)

I'm kinda at the end of my rope here...

This conversation is currently closed to new comments.

27 total posts (Page 3 of 3)   Prev   01 | 02 | 03
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Did anyone ever resolve this issue

by vleon In reply to Server 2003 network share ...

We are having the same problem. Did anyone resolve the issue

Collapse -

Did anyone?

by dcc In reply to Did anyone ever resolve t ...

I'm interested in this as well. Browsing files on our Win2k server is almost instantaneous even on directories with thousands of files. Browsing any XP Pro machine results in several seconds of waiting, and several more seconds of the "Flashlight" waiving. I was trying to use an XP Pro machine as a file server, but it's too slow right now. Applications that access the directories multiple times are really bogged down. I've tried most of the suggestions here, and still have the problem.

Collapse -

Look for tree path's in your client registry

by ehhhh In reply to Did anyone?

Remove all drivemappings from out the tree entries in your registry.

Look for the "recent" folder on your client and delete all files.

Look for Olk*** in your temp dir and delete al content

now tell me If the problem persist

Collapse -

Novell client - I thing i know the solution

by gberas In reply to Did anyone ever resolve t ...

If you have an Novell Client installed on your XP maschine and you are traing to browse a share that is not a netware share the clien tries to find the server name in the Netware network. Try to set the "Bad Name Cache Enabled" to Enable and the "Bad Name Cache Timeout" to 0. The edit the registry and add a new REG_MULTI_SZ value to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetwareWorkstation\Parameters
name it BadServer. In the value data type in each line the names of your windows servers.

Collapse -

Solved for my network!!

by djmentat In reply to Novell client - I thing ...

I had to sign up for the forum to post a reply for this one.

I built a parallel Server 2003 Standard AD network alongside of an already existing Netware 6.5 Network and then moved everyone over to AD leaving only the GroupWise 7 Email Cluster running on Novell. Everything worked great except for the issue contained in this thread. My file/print server is a PowerVault NF500 NAS with 4G RAM, Gigabit Ethernet and SAS HDs. I use a logon VBS to map all the network drives and printers. The script would take longer than expected to run and the first time you'd access a mapped drive it would take 10-20 seconds to open the drive, then all subsequent access to the same server would be fast. After about a 10 minute window of activity the first time you'd try to access a mapped drive you would have to wait again.


I tried every troubleshooting suggestion in this thread. Deleting all the entries in My Network Places, Moving the order of preferred networks to have Microsoft Windows Network on the top, Changing the time out's on the novell client to 1 second, and setting the "Bad Name Cache Enabled". The problem still existed.

While troubleshooting I happened to clear all the logs on my Backup DC and rebooted. I found an Error Event in the Application Log for Auto Enrollment that stated: "Automatic Certificate Enrollment for local system failed to enroll for one Domain Controller Certificate (0x80070005). Access Denied." I found an article stating that all Domain Controllers should be a member of the CERTSVC_DCOM_ACCESS Group, and proceeded to add the Domain Controllers Group as a member. I cleared the logs and rebooted to find a successful Auto Enrollment Event and every network problem I had with slow script processing, slow DNS resolution, and the wait times for mapped drives vanished. Now the network is just as fast as it should be and life is good.

Collapse -

MTU

by dcc In reply to Server 2003 network share ...

MTU must be set to the same value on all machines. I've been round and round with this... This utility really did the trick for me. Really all that I have changed is MTU value, but I did run the optimizer on all workstations.

http://www.speedguide.net/downloads.php

Collapse -

Same Scenario, Different Fix

by will.causton In reply to Server 2003 network share ...

Hi ,

We had the exact same scenario, migrating away from Netware 6.5 to Cifs Shares on a Netapp Filer with NTFS/AD permissions. Desktops with Novell Client 4.** SP3 for Windows had a huge lag on initial access to a mapped drive (mapped using a "net use" log on script applied from a ADS GPO)" thereafter its fine.

We tried everything in the above list, some of which helped a little some of which helped a lot. We eventually found that all the following changes were required to the desktops.

We changed the provider order under Control Panel | Network Connections | Advanced | Advanced Settings... |Provider Order so that Microsoft Windows Network was listed first.

And changed the following settings in the Advanced Tab in Novell client.
"Names Resolution Timeout" 1
"Wait before giving up on DA" 1
UNC Path Filter -OFF

Reboot...

We would not have got to the fix (so quickly) without the help of this thread. thanks Community !

To the Gentleman/Lady with the Domain Controller Group membership auto enrolment error, special thanks for that post, we had that too and fixing it solved a completly unrelated long standing problem that had mystified us for a while, but it did nothing for this fix. I'd guess that once you fixed it performance on your DC's leapt up or the load became balanced accross multiple servers.

Back to Networks Forum
27 total posts (Page 3 of 3)   Prev   01 | 02 | 03

Related Discussions

Related Forums