Server Domain Not Functioning Properly

By npiotrowski ·
I have a domain on a Windows Server 2003 box and a backup domain controller on a Windows Server 2000. The 2 domain controller's are not replicating properly. When I am logged on the 2000 box I can access the master domain controller through ip but not through dns. I feel as though my 2003 box is corrupt and feel as though I may have to reinstall the os. I try installing support tools but it tells me my configuration data for the product is corrupt. Maybe I can reinstall the service pack 2 on the box or is it possible to reinstall the system files again w/o loosing the current domain. Is it possible to backup the AD / exchange databases and download them to a new os installation or should I just rebuild the domain from scratch. Thanks for any suggestions.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Domain Controllers

by BFilmFan In reply to Server Domain Not Functio ...

In an Active Directory forest, there no backup domain controllers. All controllers are equal, with the exceptions:

That they are either a global catalog server or they are not.

Which of the FSMO roles are they holding.

To begin troubleshooting this issue, you said that you could ping the server by IP and not by DNS. What did you mean?

Did you mean that you cannot resolve the name of the file server by using the fully qualified domain name? If that is the case, you have a DNS issue.

If you can't resolve it by the NetBIOS name, you have a WINS issue.

I would recommend that you run the following command line on both of the domain controllers and compare the results, which will be written to a file named dcdiagerror.txt:

dcdiag /v /e /f:dcdiagLOG.txt /ferr:dcdiagERROR.txt

Until we have some idea of the exact nature of the issue, simply making changes at random is only going to make the issue worse.

Collapse -

issues fixed hopefully

by npiotrowski In reply to Domain Controllers

man what a nightmare that was, ever since I took over the domain the 2 DC's were not talking to each other and replicating,being the noob sysadmin i am I ignored this. Once I ran dcdiag/netdiag on the primary DC and resolved the failed test i did so on my secondary DC. Once most the of the test passed I decided to force replication and to my amazement I had replication available. Yay welcome back healthy domain. my primary DC has an exchange server. Upon reboot of the DC the exchange services failed, I checked the exchsysadmin and was shocked to see my private / public mailbox not mounted. I manually tried to mount the boxes I would get back a c19742 (something along the lines of that) error. I researched this error it told me to clear my log files, run eseutil /p and /d commands on both mailboxes. After this process was completed took about 3 hours, I manually mounted my mailboxes and to my amazement they mounted properly. Now I'm left with my 2 dc's properly replicating, new exchange databases running properly recovered from the corrupted, way less logfiles. I wonder what I'll have to conquer next with the domain but for now I'll continue to monitor the logs and hope for the best. Any recommendations for noob sysadmin? Thx for reply Bfilmfan u started me off on the right track.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums