Stumped by Vista and Exchange Connection Issue

By Dumphrey ·
We have 2 sales reps with Vista laptops. One has Vista Business, the other has Home Premium. The rep with Home Premium has no issues connecting to our pop3 exchange server (Exchange Server 2003, sp2) from either the lan, or their home. The Vista Business (Dell Latitude D830) rep cannot connect to the exchange server in any fashion while on our lan. They cannot ping the server, cannot browse to a remote share, and cannot send mail. I guess I should qualify this...99% of the time pings are "Destination Unreachable" the other 1% is split between successful pings and "General Fault" icmp codes. This laptop was able to connect to and send mail from our server a month ago. And they can connect to OWA and our pop3 server with no trouble from their home. The rep complained that their mail was acting "sporadic". When they send mail, it will sit in the outgoing box for 15 min to 5 hours, no common delay....
I first thought it was a firewall setting, so I disabled the firewall from the security center control panel, rebooted the machine, and tried pinging and opening outlook. No good. It was interesting to note, that even though the firewall was turned off, it popped up a "blocking Bluetooth connection to Logitech mouse..."
I rebooted the laptop, and logged on as a different domain user, still could not ping or connect. Then I tried a domain administrator, to check if it is permissions based somehow...(a reach of an idea I know), but still could not ping or send e-mail. Note: No e-mail was being received either.
I had them log on to the domain from another computer, no issues, so its not related to their account.
As best as I can tell, something in the core layer of Vista is blocking access to the land ip address of our mail server only, they can access all other functions and shares they have permission to, and as domain admin, I could access several other shares they did not have permission to. It comes down to the Vista laptop is refusing access to the email server. I am at a loss as to how to unblock that single ip in Vista. Its not listed in the firewall settings as blocked.
Any ideas? Am I on the right track? HELP!!!

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Destination Unreachable

by LBrent In reply to Stumped by Vista and Exch ...

Destination unreachable typically means that his IP address is not in the same subnet as your network. Check the IP settings. Give him a static IP if he doesn't have one and try that out. DHCP might be messed up.

Also make sure that Vista looks at the network connection as an "At Work" connection.

PS. I hate Vista.

Collapse -

no ping means no connectivity

by CG IT In reply to Stumped by Vista and Exch ...

What does ipconfig/all show? Does that reflect your domain settings for addressing, default gateway and DNS servers?

I doubt there is a core issue with Vista business as we've been running it without issue for almost a year.

Is Network Discovery turned on?

Collapse -

Sorry its taken this long to reply

by Dumphrey In reply to no ping means no connecti ...

But I had to put this on the back burner for a bit.

Anyway, its only this one address it can not consistantly ping. And it now effects all 3 Vista laptops we have.

Network Discovery is off. Ipconfig /all is showing the proper info, nslookup is giving the right ip address for the server...
The only "lead" I have is that after sniffing the traffic, I am getting tcp_checksum errors from source:Vista destination:Exchange. This could be related to the toe on exchange, but its iddentical hardware/drivers to our DC, which is not affected.
I am stumped.

Collapse -

I have exactly the same issue

by gtuttle In reply to Sorry its taken this long ...

You have described my problem perfectly except that I may connect for an hour and then it will disconnect. Can't connect or even ping the mail server. But I can ping and connect to all the other servers. IP is setup correctly
I am running Vista Business SP1. I was running Outlook 2007 but now I'm running Outlook 2003 and having the same problem.

Collapse -

Our issue was

by Dumphrey In reply to I have exactly the same i ...

a "feature" of the new Vista "smart" networking stack.

The Vista computers are hearing and responding to the arp proxy response from our PIX (responding since it had a wan to lan translation configured it was responding with the lan side mac of its maybe the smarts weren't all Vista).

All other computers are smart enough to ignore this....

From the MS Tech that helped us:

CAUSE: The cause was when the VISTA client sends the ARP request for the Exchange Server?s IP. We would receive the MAC from the Exchange Server and we will also receive a second ARP reply from the PIX because the PIX had the IP of the Exchange configured as well.
RESOLUTION: We disable the NoProxyArp entry on the PIX by running the command "SYSOPT NOPROXYARP <Interface_Name>" and this solved the case.

Maybe this will be of use to you.

Collapse -

Oh Thank You!!

by leeann In reply to Our issue was

Hey thanks so much for your post of your issue. I had the same problem here, but resorted to just having XP being it was stable. But I knew Vista was coming sooner than later so I have been tackling the issues to get my network compatible. At first i didn't find much info, but then starting finding all kinds of issues with Vista and MS servers. I knew it was either DNS (but I was very confident of my DNS setup) or the router. Today, I finally said, one more look, let's give it about an hour today and see what happens! Thank for posting your fix, becuase as soon as I uploaded that change to my ASA router, all the Vista Exchange connections popped on! I have seen alot of issues, but not alot of fixing issues, so I do appreciate it. Thanks for lifting this headache away! (or at least til the next MS change) Thanks! Lee Ann

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums