Browser

Question

Locked

System restore problem, among other things

By lord_alphathon_iv ·
Hi all,

I noticed today that I cannot create restore points on my main computer. The automatic creation doesn't seem to be working either, which I noticed when, probably about a week or two ago, I had to boot into safe mode due to a screw up causing windows to blue screen on booting (which afaik is completely unrelated to my current problem, the cause of which was a network bridge between my wireless adapter and a virtualbox host interace), but while there, I noticed I had no restore points, which I put down to the recent install of SP1, but when I tried to create one today, there were still none.

When I try to create a restore point, it sits with a loading bar for ages saying "Creating a restore point...", then after about 10 minutes, stops with the following error message:

The restore point could not be created for the following reason:
The creation of a shadow copy has timed out. Try again this operation (0x81000101)
Please try again.


While not the same problem, I am also having problems with installers which may be relevent. A lot of installers (not all, but most) take an incredibly long time to complete. They usually sit at 0% for ages (anywhere from 5 minutes to half an hour) then begin to actually install, but more slowly than you'd expect usually, especially with the specs of my system. I don't know if it is related, but as the problem with the creation of a shadow copy is a timeout I thought I'd mention it. Also, if anyone knows how to solve it then please share as it rather annoying (nothing more really, but still...).

Also, I have noticed recently that my CPU usage has gone through the roof. Normally after startup it remains stable at between 0% and 5%, when idle. But after a while, the CPU stars getting consumed more and more. According to resource monitor it is mainly being consumed by svchost (at the time of writing, svchost was using 98% of the CPU, when all that was running was this firefox window and background tasks). As you can imagine, this is a little concerning. It doesn't seem to be affecting the performance though. These figures are coming from task manager, resource monitor and the screen on my Logitech G15 Keyboard

I have tried google for all 3 of these problems, but to no avail, and virus and malware scans all come out clean.

Other possibly relevent system details:
OS - Windows Vista Ultimate SP1 32-Bit
CPU - Intel Core 2 Quad 2.4GHz (Q6600)
RAM - 4GB DDR2 (I am aware that 32-bit OSs cannot utilise it all)
MOBO - Asus P5K-Premium

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Now I remember...

by lord_alphathon_iv In reply to I seem to remember

I did try to do it before, but it turns out you can't create restore points in safe mode, only roll back to them.

Collapse -

OK

by Jacky Howe In reply to Now I remember...

try the Administrator trick.

Collapse -

Still no cigar

by lord_alphathon_iv In reply to OK

Tried that and it didn't work either.

Collapse -

Vista is starting to remind me of ME

by Jacky Howe In reply to Still no cigar

it works almost perfectly on some PC's but not on others.

Repair A Vista Installation Using The Upgrade Option Of The Vista DVD


http://vistasupport.mvps.org/repair_a_vista_installation_using_the_upgrade_option_of_the_vista_dvd.htm

The two most obvious repair option for a Windows Vista installation is either re-installing (and losing all your data and programs) or using the repair options available on the Windows Vista DVD.

However, what if the repair options don't work? Do you really want to re-install the operating system and lose everything on your hard drive? Probably not!

Well there is a third option and that is to actually 'upgrade' the copy of Vista you already have using your Vista DVD. By doing this you can re-install Vista over the top of your original copy without losing any programs or data you already have on your PC.

While upgrading should, in theory, not disturb what applications/documents you already have on your hard drive it would be far wiser to actually backup any important files/documents prior to attempting this upgrade.

To repair your Vista installation using the upgrade option proceed as follows:

1/ To begin with you must proceed as if you were upgrading to Windows Vista from another operating system. Therefore, before you start go through the Upgrading To Windows Vista instructions first to see what is involved

2/ Once you have read the upgrade instructions then begin the *upgrade. You should be aware that the upgrade may take several hours

3/ After the upgrade has completed the following instruction will be found useful

4/ Because you have upgraded the system you will, after the upgrade has finished, be prompted to activate your copy of Windows Vista

5/ Select the Activate Online Now option

6/ At the next screen, if you are unable to get an internet connection, Choose the 'Create new internet connection option'

7/ When the Create New Internet Connection window opens, Select the connection that you had created in the 'old' copy of Vista and then Type in your user name, Password, etc

8/ Once connected to the Internet the activation process should proceed

9/ If the activation is unsuccessful you will need to call the automated activation line. The toll free number is available when you Click the Activate by Phone option

10/ Once activation has completed the desktop will continue to set up and then, finally, you will be presented with the Welcome Center screen

11/ Close the Welcome Center screen

12/ If you now look in the bottom Right hand corner of your screen you may see a message "Windows Vista, Build xxxxxx. This copy of Windows is not genuine"

13/ To get this far your activation must have been successful. This indicates that the copy of vista you are using is Genuine. So once you get to this stage simply reboot your PC

14/ Once the PC re-boots the 'This copy of windows is not genuine' message should have disappeared.

15/ If the message doesn't disappear, then try validating your copy of Windows Vista by visiting http://www.microsoft.com/genuine

16/ When the site opens, just Click the Validate Now button

*upgrade
http://vistasupport.mvps.org/upgrading_to_windows_vista.htm

Collapse -

Not just ME

by lord_alphathon_iv In reply to Vista is starting to remi ...

"Vista is starting to remind me of ME - it works almost perfectly on some PC's but not on others."

Well it does work almost perfectly on mine. Seriously, compared to my last computer (which ran XP) this one runs like a dream. The kind of problems I had on XP weren't always minor either, although in it's defence it did have better software compatibility.

Anyway, it seems like my best option is probably to try a repair install (assuming those still exist on vista, don't see why they wouldn't)

Collapse -

No more ideas anyone?

by lord_alphathon_iv In reply to System restore problem, a ...

Does no-one have any more ideas? I really don't want to have to do a repair install just to fix system restore (it uses up one of your activations doesn't it?) Are there any other ways to fix things like this (not including a clean install, "upgrade" etc)?

Collapse -

Not going to be here...

by lord_alphathon_iv In reply to No more ideas anyone?

OK guys, just thought I'd let you know that I'm going away for about a month tomorrow, so won't be able to try any more suggestions you may have for a while, as I'll be on my laptop as opposed to my main computer (a desktop). Don't let that stop you from posting suggestions, just bear in mind that I won't be able to test them, so please post any possible solutions you can think of.

Collapse -

I'm Back...

by lord_alphathon_iv In reply to System restore problem, a ...

Hi guys. I'm back at home again, and as such have access to the affected computer again, so if anyone has any ideas now as to how to fix this then please post them.
Thanks again

Collapse -

See if this helps

by Jacky Howe In reply to System restore problem, a ...

Restore point creation disabled by Group Policy

As a result, you?re unable to create System Restore Points or configure System Restore.

Resolution
This happens if the Turn off Configuration Policy is enabled in your system, either using Group Policy or through registry edit. For standalone Windows Vista systems, use these steps:

Using the Group Policy Editor

If your edition of Windows Vista includes the Group Policy Editor snap-in (gpedit.msc), follow these steps:

1. Click Start, type gpedit.msc and press ENTER

2. Go to the following branch:

Computer Configuration | Administrative Templates | System | System Restore
3. Double-click Turn off Configuration and set it to Not configured.

Note: If the above setting is already set to Not configured, set it to Enabled and click Apply. Then revert back the setting to Not configured, and click Apply, OK.

4. Exit the Group Policy Editor.

Using the Registry Editor

1. Click Start, type regedit.exe and press ENTER

2. Navigate to the following key:

HKEY_LOCAL_MACHINE \ Software \ Policies \ Microsoft \ Windows NT \ SystemRestore
3. In the right-pane, delete the value named DisableConfig

4. Exit the Registry Editor.

Registry Fix

To automate the above setting, download srpol-clear.reg and save to Desktop. Right-click on the file and choose Merge.

More Information
If you set the Turn of configuration option to Enabled, the option to configure System Restore on the Configuration Interface disappears. If the Turn off Configuration setting is disabled, the configuration interface is still visible, but all System Restore configuration defaults are enforced, and the Create button is grayed out. If you set it to Not configured, the configuration interface for System Restore remains, and the user has the ability to configure System Restore.


http://www.winhelponline.com/blog/restore-point-creation-disabled-by-group-policy/

Collapse -

Definitelly on to something, but...

by lord_alphathon_iv In reply to System restore problem, a ...

I have confirmed that Cryptographic services is definitelly involved, and I can now force my computer to install things at a decent speed and make restore points. I do this by waiting until the culprit svchost.exe is taking up 25% of the CPU, then restart cryptographic services. Once I have done that, it complains about the host process being shut down (although it just starts itself back up again, using a normal amount of CPU (<1%) again) and then continues with the instalation or creates the restore point (whichever applies at the time) seemingly without a hitch.

What I need to know now is how to fix it. I'm sure it's something which is easily fixable, but apparently difficult to diagnose. Hopefully this info will help to diagnose it.

P.S. I know that the DLL which relates to cryptographic services isn't corrupted or anything (I tried replacing it with one from a working comp. and it made no difference)

Related Discussions

Related Forums