Browser

Question

Locked

System restore problem, among other things

By lord_alphathon_iv ·
Hi all,

I noticed today that I cannot create restore points on my main computer. The automatic creation doesn't seem to be working either, which I noticed when, probably about a week or two ago, I had to boot into safe mode due to a screw up causing windows to blue screen on booting (which afaik is completely unrelated to my current problem, the cause of which was a network bridge between my wireless adapter and a virtualbox host interace), but while there, I noticed I had no restore points, which I put down to the recent install of SP1, but when I tried to create one today, there were still none.

When I try to create a restore point, it sits with a loading bar for ages saying "Creating a restore point...", then after about 10 minutes, stops with the following error message:

The restore point could not be created for the following reason:
The creation of a shadow copy has timed out. Try again this operation (0x81000101)
Please try again.


While not the same problem, I am also having problems with installers which may be relevent. A lot of installers (not all, but most) take an incredibly long time to complete. They usually sit at 0% for ages (anywhere from 5 minutes to half an hour) then begin to actually install, but more slowly than you'd expect usually, especially with the specs of my system. I don't know if it is related, but as the problem with the creation of a shadow copy is a timeout I thought I'd mention it. Also, if anyone knows how to solve it then please share as it rather annoying (nothing more really, but still...).

Also, I have noticed recently that my CPU usage has gone through the roof. Normally after startup it remains stable at between 0% and 5%, when idle. But after a while, the CPU stars getting consumed more and more. According to resource monitor it is mainly being consumed by svchost (at the time of writing, svchost was using 98% of the CPU, when all that was running was this firefox window and background tasks). As you can imagine, this is a little concerning. It doesn't seem to be affecting the performance though. These figures are coming from task manager, resource monitor and the screen on my Logitech G15 Keyboard

I have tried google for all 3 of these problems, but to no avail, and virus and malware scans all come out clean.

Other possibly relevent system details:
OS - Windows Vista Ultimate SP1 32-Bit
CPU - Intel Core 2 Quad 2.4GHz (Q6600)
RAM - 4GB DDR2 (I am aware that 32-bit OSs cannot utilise it all)
MOBO - Asus P5K-Premium

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Did you reregister the .dll

by Jacky Howe In reply to Definitelly on to somethi ...

Here is some info for you to peruse.

You cannot install some updates or programs


http://support.microsoft.com/kb/822798/en-us


Some services do not start in Windows Vista


http://support.microsoft.com/kb/943996/en-us


Some Windows Vista functions may not work, or Windows Vista may stop responding


http://support.microsoft.com/kb/929833

Collapse -

Ok, this is a shot in the dark...

Your error "0x8004230F" is a backup error.
And this some how is related to the system restore process, so i have come up with this:
Put your computer into Sleep Mode.
When done restart your computer.

Turning System Restore off or on

System Protection, the feature that creates restore points, is on by default. But although System Restore is valuable, in some cases you might consider to turn it off for some of your disks, turn it off altogether, or re-enable it for some or all of your disks. Please note that if you turn off System Protection on a disk, all restore points are deleted from that disk. When you turn System Protection back on, new restore points are created, but the old ones are dead gone.

In order to turn off System Protection you need to go to Control Panel > System, then click on the Advanced System Settings link on the left. You can also access it by typing systempropertiesprotection.exe from the Run option.

In the System Properties tab click to unselect the checkbox beside the disk you wish to disable. You will get a prompt asking you if you wish to continue, and if you apply, System Protection will be disabled for that specific drive.
In order to re-enable System Protection just perform the opposite action.

Manually creating restore points

In order to manually create restore points you need to go to Control Panel > System, then click on the Advanced System Settings link on the left.
You can also access it by typing systempropertiesprotection.exe from the Run option.

In the System Properties tab press on the Create button.

You will be prompted to give the restore point a suitable name. Select one that'll allow you to easily remember why you thought it was important to keep it.
Press Create, and in a short while, after some thinking, the new restore point will have been created.
Note: Restore points are saved until the hard disk space System Restore reserves is filled up. As new restore points are created, old ones are deleted, so do not expect this restore point you've just created to last long on your hard drive.

Please post back if you have any more problems or questions.

Collapse -

Tried that

by lord_alphathon_iv In reply to Ok, this is a shot in the ...

I tired doing that before and it didn't help. My error code is 0x81000101 btw (0x8004230F only happens if I specifically disable cryptographic services and I assume that specific error is basically saying it cant do whatever cryptographic services lets it do). Also, my problem is that I cannot create restore points - manually or otherwise, so the second half seems a little redundant. Thankds anyway though.

Collapse -

Shot in the dark . 2

If you can not start the Cryptographic Service then the likely cause is that the Remote Procedure Call (RPC) is not running. To check this go to the "Services" window by running through the steps detailed above... Now right click the Remote Procedure Call (RPC) service. If the status shows it is not running then it has been disabled!
Since the Cryptographic Service is a dependency of the Remote Procedure Call (RPC) - We MUST get this running. Sadly you will not be able to do this from the the "Services" Window... You will see it is "greyed out"!
Follow these instructions...
You will need to use your Vista CD/DVD to boot the computer into the Recovery Console/Command prompt, then type the command:
Enable RPCSS Service_Auto_Start

Now press the Enter key to submit the command.
Now type: exit and press Enter to restart the computer.

Please post back if you have any more problems or questions.

Collapse -

Doesn't apply

by lord_alphathon_iv In reply to Shot in the dark . 2

Cryptographic services starts fine, there is just something wrong with it when it is used. As I said, it uses 25% of the CPU (on a 2.4GHz Core 2 Quad) and locks up, causing whatever is using it to lock up also.

Collapse -

Your best way to solve this is to do a repair in Vista.

You do not lose any Activation, if you do who cares, i have done the repair in Vista 6 times so far and it is no problem.
So just pop in the Vista DVD and when you see the "install", look down to the bottom left of your screen you will see "repair", click on this and just follow the on screen instructions. At the moment i would not worry too much on the Activation issue. What you want to get up and running is the restore function, so just do the Repair option.

Please post back if you have any more problems or questions.

Collapse -

I thought...

by lord_alphathon_iv In reply to Your best way to solve th ...

I have read in a lot of places that Vista doesn't have a repair install feature like XP did, and you have to use upgrade instead (which doesn't work if you have SP1). I'll have a look though, as a repair install would certainly be an option.

Collapse -

The repair option is there, if you have the disk you will see it.

You do not have to install just run it and if you follow the instructions from my earlier post you will see it, plus it should mend/fix your problem. I have been testing this very thoroughly over a year and it does work. I have taken out bits of the registry to muck up the system and the used this repair option. Much better than XP's version. :)

Please post back if you have any more problems or questions.

Collapse -

Useless?

by lord_alphathon_iv In reply to The repair option is ther ...

I followed your instructions, only to discover I had been there before. I thought you ment a REPAIR INSTALL like XP had, where you could essentially install XP over the top of the existing one, but leave all your files intact. What you ment though was akin to the XP repair console, and none of the options there seem of any use:

Startup Repair - not really relevent

System Restore - would only be useful if I had a restore point from before the probelm started, which I don't. Heck, if I did, I could just restore it from within windows, as it seems to be able restore from points, just not create them (usually, sometimes it manages when installing software etc)

Windows Complete PC restore - Same as above

Windows Memory Diagnostic Tool - not really relevent either

Command Propt - only useful if I had some commands to fix the problem

Collapse -

Download your Vista recovery disk here,

http://neosmart.net/blog/2008/download-windows-vista-x64-recovery-disc/

What it does: The Windows Vista Recovery Disc can be used to access a system recovery menu, giving you options of using System Restore, Complete PC Backup, automated system repair, and a command-line prompt for manual advanced recovery.

What it doesn't do: You cannot use the Windows Vista Recovery Disc to re-install Windows - it only fixes (not replaces!) Windows.

Please post back if you have any more problems or questions.

Related Discussions

Related Forums