General discussion


TCP/IP Error in Windows XP

By evin.hill ·
I am trying to install a networked copier/printer machine that is attached to our network. I keep getting the Error loading the TCP Mib library. What exactly is this error and how can I fix it? I've tried disabling the network card, re-installing drivers, etc. It comes up when I click on add a printer and then I try to create a new HP Standard TCP/IP port. When I click next I get the error described above. This is the only machine this has happened to, any explinations? It's able to see our network drives and connect to the internet. Please help!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Well known issue

by BFilmFan In reply to TCP/IP Error in Windows X ...

This is a fairly well known issue that can be resolved by deleting the Wsnmp32.dll, Ntprint.dll, Tcpmib.dll, Mgmtapi.dll, or Snmpapi.dll file that has been copied to the %SystemRoot% folder.

The Add Standard TCP/IP Printer Port Wizard checks the root system folder for some dynamic-link libraries (DLLs) before it checks the System32 folder which results in the error being generated.

Collapse -


by evin.hill In reply to Well known issue

Thanks, I figured it out and fixed it. It was pretty simple fix.

Collapse -

same issue

by john In reply to Thanks!

i'm having the same issue but don't have any of the above problems. do you have any other ideas

Collapse -

Same issue

by Tigge50447 In reply to Well known issue

I'm having the same issue however I don't have any of those mentioned files in my system folder just system32. Help please....

Back to Software Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums