General discussion

Locked

TCP/IP not installed

By sia ·
Hi all

I have 2 computers Windows XPpro networked through a router to ntl set top box.
2 weeks go I installed software for Hand held PC/GPS
Few days ago for unknown reason my host computer crashed
I had to reinstall XP (I did not lose any file).
Now I can not go to internet or file transfer with second computer.
But Second computer can use the internet but can not see the host
The host has privet address of 169.254.53.168 and 255.255.0.0 and NO default gate way
And second computer 192.168.0.177 and 255.255.255.0 and default gate way 192.168.0.1
Now when I start the computer I get the message
?Mobile Devices Properties?
?TCP/IP network transport is not installed?
I tried repair, message said ?can not repair, see your ISB. Which I did).and they couldn?t help
I tried to make a new connection and that didn?t work.
Also all the connection are ok
Please be patient with me, I am newbie

Thanks in advance

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by sia In reply to

Hi and thank you all of you
Let me tell you what I have done
As Toivo Talikka suggested
1 I have manually changed IP address and default gateway to 192.168.0.100 range, but with no success.
2 I did add Network card, but still I had IP in range of 169.254.53.164(I had disabled the original)
3 I did use a new cable and use different outlet of the router, but after all these changes still the same problem (second computer worked ok all the time)
4 I unplug the router and connected the internet cable directly to host and repeated as No1 and No2 above, still did not work.
5 I re installed XP (upgrade), still no lock.
6 I have deleted some softer which I thought they can contribute to problem (i.e. software for hand held PC and IRD software.

7 in all the changes I have UN plugged the main electricity from set top box (reset the box)
8 and disabled other local area connections
8 I have down loaded the Registry Fix (as Jcreedon suggested) but it did? not work on the host but worked in the second computer (copped it to floppy and transfer it to the host)
9 I have reset TC/IP stag (as Winterfrost suggested)
Still I am getting the same error

?Mobile Devices Properties?
?TCP/IP network transport is not installed?
I am going to try again and I keep you informed.

Thank you again
Sia

Collapse -

by OTL In reply to TCP/IP not installed

UMM Run MSCONFIG, disable the mobile connection. Ticked me off when corporate forced this on, and had no mobile connectivity ! PC acted stupid on a LAN, was looking for WIFI ! Centrino technology at its worst, PC was trying to connect to nothing.

Collapse -

by firstwob In reply to TCP/IP not installed

I had the ?Mobile Devices Properties?
?TCP/IP network transport is not installed? issue also. Tried several of the fixes. Did not work. Ran the winsockxpfix suggested by JC and everything was great.

Collapse -

recovering from a really really dead TCP/IP stack

by brian_ibo In reply to TCP/IP not installed

REALLY REINSTALLING TCP/IP
Complete destruction and restoration of dead TCP/IP stack
Recovery from fatal failure or partial or complete corruption of TCP/IP.
For virus related problems, please consult tcpip.sys to ensure it is not a corrupt version before following these steps.

This solution is an alternative to reinstalling by partial method or by using winnt /unattend which I very much wanted to avoid.

Here is the hardcore method when nothing else is working. I have cobbled together these suggestions through various forums to offer them here as a concise solution. There are no guarantees! Back up anything relevant and set a system restore point to cover your ***. I discovered this method after all other solutions failed.


Related error messages:
"TCP/IP network transport is not installed" error message from active sync
TCP/IP driver missing from devmgmt.msc showing hidden devices
ipconfig produces immediate failure message :
Windows IP Configuration
An Internal error occured: The request is not supported.
Please contact Microsoft Product Support Services for further help.
Additional information: Unable to query host name.
"the specified device instance handle does not correspond to a present device" message regarding DHCP service in services.msc
net start tcpip >>> fails with system error 2, The system cannot find the file specified
ping error: "Unable to contact IP driver, error code 2"
Repair Local Area Connection: Failed to query TCP/IP settings of the connection. Cannot proceed.
"Tcp/ip Protocol Driver Service Failed To Start, system cannot find the file specified"
"The TCP/IP Protocol Driver service failed to start due to the following error: The system cannot find the file specified"


Failed repair methods:
netsh int ip reset resetlog.txt >>> no effect
non-full reinstall of TCP/IP using only the have disk method. >>> no effect
netsh Winsock reset >>> no effect
http://www.snapfiles.com/get/winsockxpfix.html >>> no effect
reinstalling network card >>> no effect

MY SOLUTION:::

Step #1
Full uninstall of TCP/IP ... no ********.
----------------------------------------------------------------------
These steps are copied from http://support.microsoft.com/kb/325356
11. Locate the Nettcpip.inf file in %winroot%\inf, and then open the file in Notepad.
12. Locate the [MS_TCPIP.PrimaryInstall] section.
13. Edit the Characteristics = 0xa0 entry and replace 0xa0 with 0x80.
14. Save the file, and then exit Notepad.
15. In Control Panel, double-click Network Connections, right-click Local Area Connection, and then select Properties.
16. On the General tab, click Install, select Protocol, and then click Add.
17. In the Select Network Protocols window, click Have Disk.
18. In the Copy manufacturer's files from: text box, type c:\windows\inf, and then click OK.
19. Select Internet Protocol (TCP/IP), and then click OK.
Note This step will return you to the Local Area Connection Properties screen, but now the Uninstall button is available.
20. Select Internet Protocol (TCP/IP), click Uninstall, and then click Yes.
RESTART

succesfull uninstallation of TCP/IP will remove numerous keys from the registry including
HKLM/system/CurrentControlSet/services/tcpip
HKLM/system/CurrentControlSet/services/dhcp
HKLM/system/CurrentControlSet/services/dnscache
HKLM/system/CurrentControlSet/services/ipsec
HKLM/system/CurrentControlSet/services/policyagent
HKLM/system/CurrentControlSet/services/atmarpc
HKLM/system/CurrentControlSet/services/nla
These represent various interconnected and interdependant services.

For good measure you should delete the following keys before reinstalling TCP/IP in step #2
HKLM/system/CurrentControlSet/services/winsock
HKLM/system/CurrentControlSet/services/winsock2

Step #2
Reinstall of TCP/IP
----------------------------------------------------------------------
Following the above substep #13, replace the 0x80 back to 0xa0, this will eliminate the related "unsigned driver" error that was encountered during the uninstallation phase.

Return to "local area connection"> properties > general tab > install > Protocol > TCP/IP

You may receive an "Extended Error" failure upon trying to reinstall the TCP/IP, this is related to the installer sub-system conflicting with the security database status.

to check the integrity of the security database
esentutl /g c:\windows\security\Database\secedit.sdb

There may be a message saying database is out of date
first try the recovery option
esentutl /r c:\windows\security\Database\secedit.sdb

this did not work for me, I needed the repair option
esentutl /p c:\windows\security\Database\secedit.sdb

rerun the /g option to ensure that integrity is good and database is up to date.

Now return to the "local area network setup"
choose install > protocol > tcp/ip and try again

reboot.
worked for me.

Related Discussions

Related Forums