The Beep in Windows sound volume slider

By maxgbw26 ·
After adjusting the sound volume with the "slider" beside the clock, there is always an annoying "beep".
How can I remove that noise?

This conversation is currently closed to new comments.

24 total posts (Page 2 of 3)   Prev   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Now that's silly - of course you do ...

by OldER Mycroft In reply to This isn't the problem.

In case you haven't noticed, the VOLUME of the beep is directly related the position of the slider:

If the slider is at the extreme top you get a loud beep
If the slider is at the extreme bottom you get no beep at all
Any position in between you get a louder or quieter beep.

Without the beep there is no way of telling how loud or quiet you have set the sound levels. :)

<Quiet Typo!>

Collapse -


by maxgbw26 In reply to Now that's silly - of cou ...

...I am sorry, you are right. I did not notice that because I always released the slider somewhere in the middle.

Collapse -

Get rid of the sound beep on the sound slider..

1. Use Sound Recorder (Start, All Programs, Accessories, Entertainment, Sound Recorder) to create a very short, silent sound file. You can do this by clicking the Record button and then immediately hitting the Stop button in Sound Recorder, then use File Menu, Save and save the file into your C:\Windows\Media folder as silence.wav.
2. Click Start, Control Panel, Sounds, Speech And Audio Devices, Change the Sound Scheme.
3. In the Program Events list, under the Windows section locate Default Beep and click it once. (If Default Beep is not listed, you'll need to use the dingfix procedure described below.)
4. In the Sounds list, select silence.wav, then click OK. (If you can't locate silence.wav in the list, use the Browse button to locate silence.wav in C:\Windows\Media. :)
Hope this helps you.

Please post back if you have more problems or questions.

Collapse -

Note: Please read this first...

Just more info for the last post.
Sorry for the late lost..

Note: The Volume Slider is not the only thing which uses Windows' default beep sound. By silencing the slider you will also eliminate the sound used by both Windows and some applications programs to indicate an error has occurred.

If you don't want to silence the Volume Slider but instead you're experiencing the problem with the PC speaker beeping at an unchanging volume, here's how to fix that:
1.Download the file dingfix.reg from Kelly's Korner at: and save it onto your Desktop. (You can, in fact, repair the damaged key manually using the Registry Editor, but using dingfix.reg to do the job for you is much easier. If you'd like to do the job yourself, check out the procedure described below.)
2.Double-click the dingfix.reg file and, when prompted, allow it to be added to your Registry.
3.Click Start, Control Panel, Sounds, Speech And Audio Devices, Change The Sound Scheme.
4.In the Program Events list, under the Windows section locate Default Beep and then select any sound from the Sounds list to use as the Default Beep (preferably a short sound) and click OK.

If you'd prefer to edit the Registry manually to repair the Default Beep, here's how (Note: These instructions assume you are an experienced user of the Registry Editor):
1.Open the Registry Editor and navigate to the key: HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default.
2.If the following subkeys don't already exist, create them: HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default\.Current HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default\.Default
3.Edit the default value of HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default\.Default so it contains: %SystemRoot%\media\Windows XP Ding.wav
4.Add the same value to the default value of HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default\
5.Close the Registry Editor.

Please post back if you have more problems or questions.

Collapse -

Doesn't seem to work

by bobl51inthewild In reply to Note: Please read this fi ...

I still get the PC speaker beep when adjusting the sound volume slider. It beeps at a constant volume. Other sounds coming through the speaker and the headphone jack are normal (and volume is adjusted properly). I used to hear the Windows default beep sound (Ding.wav) when adjusting the slider, but now just this stupid beep. Any ideas? TIA

Collapse -

Double-click the volume icon

by seanferd In reply to Doesn't seem to work

You should see individual sliders vor the various sound outputs and inputs available.

If you do not see the computer speaker volume listed, click Options, then Properties or Advanced Controls, find the computer speaker, and check the box next to it so a slider will show up. Drop the volume on this slider. You can now hide it again or leave it in the multi-slider display.

If this option is not present at all, and the registry fix doesn't work, I don't have any further ideas, but someone else may.

Collapse -

PC Spkr Mute

by bobl51inthewild In reply to Double-click the volume i ...

There is a check-box to mute the PC speaker, but this isn't the speaker that is problematic. It is the motherboard speaker that is beeping. It beeps even when I mute the PC speaker using the volume controls.

Collapse -

The motherboard speaker

by seanferd In reply to PC Spkr Mute

is the PC speaker.

Or do you somehow have 2?

If you disable the Beep device in device manager, does it go away?

You need to identify the actual speaker to which you refer, and find the setting for it. Or, you can post the exact make and full model number for your system, so we can check.

We'll figure something out. :)

Collapse -

Motherboard speaker is different ...

by bobl51inthewild In reply to The motherboard speaker

... from the PC speaker. I disabled the former by using "net stop beep" and the PC speaker still works properly. That stops the annoying system beep when I use the volume control slider, but I can't figure out why the slider doesn't use the Windows default beep sound file (default.wav) like all my other computers, which is soft or loud depending on where the slider control is set. In fact this one used to work properly and one day it stopped and began using the system beep from the motherboard speaker instead (constant volume). This machine is a Dell Latitude D620 with a built-in Sigmatel audio card. All drivers are current. OS is Windows XP SP3.

Collapse -

Is it set to use a Windows sound

by seanferd In reply to The motherboard speaker

in the sounds control panel item?

Perhaps check in the advanced settings for speakers and what in the sound cpl.

Otherwise, it sounds like a driver issue - can you roll back to a previous driver version and see if that helps?

It is a bit of a puzzler.

Back to Hardware Forum
24 total posts (Page 2 of 3)   Prev   01 | 02 | 03   Next

Related Discussions

Related Forums