ThinkPad T42 No Power

By evarnado ·
I have a Thinkpad T42 that just "blinked" out while I was using it.

Now I get no indicationof power going to the laptop. AC adapter doesn't signal the pluged in light. full battery does nothing. I'm getting absolutely no power indication when I press the power button.

Any idea? Thanks

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Let there be light!!!

by mdcruz In reply to ThinkPad T42 No Power

I encountered the same problem today and came across the following on the NotebookForums:

"...remove the battery, unplug the AC adapter, press the power button ten times, then hold the power button down for 20 seconds.

re-insert the AC adapter and see if it will power on. if not, try removing AC and inserting the battery."

To my surprise it actually worked!

Collapse -

Reponse To Answer

by afarbod In reply to Let there be light!!!

First I read this I thought you are kidding... But this is amazing, same thing happened to my X61 and your note saved me all the headache... Thank you

Collapse -

Same Fix Worked for IBM A31With Same Symptoms

by frankzadroga In reply to ThinkPad T42 No Power

Thanks very much for the post. I was able to rescue my IBM A31 that no longer booted with the same symptoms.

It went down like this:

Tuesday: A31 was working like a champ. I turned it off, left it plugged in on the living room table.

Wednesday: Did not touch it.

Thursday: Opened it up. Saw the green power light on the one that looks like (z). Pressed the power several times, short and long presses; no reaction. Uttered a few unmentionables ... I unplugged it from AC power and pulled the battery out.

I knew the AC adapter was working because my T23 worked fine on the same adapter. I put the battery back in and plugged it back in to AC power. No lights were on ... not even the before mentioned power light. I pressed the power button many times in different combinations of short and long presses again ... mostly out of frustration; nothing. I tried the same power on sequence with just the battery, and just AC power ... still nothing. The only thing that happened was that the battery light blinked once in amber very quickly for each time I plugged in either power source from having no power sources plugged in.

The Fix: I saw three posts back in '06 (I must be getting old ... still running A31's and T23's in mid '0 that said the following:

1. Pull the battery out, unplug the unit from AC power.
2. Press the power button 10 times.
3. Pres and hold for 30 seconds on the 11th press.
4. Plug back into AC power only.
5. Power on the unit.
6. Bingo! it worked.

I take NO credit for this fix ... I just followed other's post genius.

PLEASE NOTE: I tried the same steps above unsuccessfully about 3 times waiting only about 20 seconds on the 11th press as some posts suggested. Make sure to wait a full 30 sec.

Hope this helps.

now back to my beer ...

Collapse -

Same fix worked on an X41

by careh In reply to Same Fix Worked for IBM A ...

Thanks OP!! .. although I thought to myself

- this can't work -

.... but IT DID!!

In my case my X41 was running on battery power - and powered down with no warning. Changing to another battery and adding A/C power had no effect. Pressing the power on/off button did nothing!!

I followed the above procedure of removing A/C power and battery then '10 power on/off button presses - and hold power on/off button down for 30 seconds' - and Presto! fixed!.

Collapse -

And on a T20

by tomedsmith In reply to Same fix worked on an X41

Can't believe it!
Tried this on a T20 and it worked!

Collapse -

Reponse To Answer

by memememememme In reply to Same Fix Worked for IBM A ...

Thanks!!!! This worked for Thinkpad R32 as well... I'd just spent 3 days getting the thing up and running and lovely - and it went off. (avoid Broadcom BC wireless minilan cards - i think this is what powered off my R32)...
.... an amazingly un-tech solution :) :)

Collapse -


by Nils Krøyer In reply to ThinkPad T42 No Power

I also tryed this on a T42. It worked.
Does anyone know WHY it works?
And can one trust this really fixed the problem also on a longer term?

Nils K

Collapse -

Reponse To Answer

by robo_dev In reply to Powerissue

Educated guesses are:

Either that you are discharging a capacitor that is holding part of the soft-power-on circuit active, so you are effectively resetting the 'soft power switch controller'.

Also perhaps the machine is somehow stuck in a standby or sleep state, and you are doing a hard reset which clears whatever hardware process maintains the sleep/standby state.

It's fairly common that power supply and/or system board capacitors, which hold an electrical charge, either fail completely, in which case the system may not power on unless you try several times (giving the capacitors time to charge). In this case, I believe a poorly designed or defective circuit is perhaps storing a charge or flipping a transistor bit to do jsut the opposite.

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums