Unable to detect Seagate FreeAgent Go External Drive

By sundar.jawahar ·
I'm experiencing problem in accessing data contents in my external hard drive - Seagate FreeAgent Go 120GB.

I'm running on Windows XP SP3.I used to have my External hard-drive (Seagate FreeAgent Go) plugged-in most of the time to backup data. Yesterday my PC "locked-up" twice and I had to reboot the PC.After this I tried to access the external hard drive and it doesn't. The Seagate Device Manager software doesn't do any good.

The drive is assigned by the system when the external drive is connected. But it takes a long time. Autoplay is searching and searching and finally abandons. In the device manager am able to see the drive. The file system is showing as RAW. Should it be NTFS - not sure?

The external hard drive capacity is 120GB and it is showing free space as 117 GB. I do have alteast 50GB worth of data and that is not being reflected.

I changed the drive name from I to M and it doesn't help. There is no exclamation mark in the USB controllers.

The Safely Remove option does recognize the drive a Seagate. But any attempts to open it or run in Autoplay doesn't work.

I tried to access thru MS DOS and it shows that there is I/O device error.

Is there any other technique that I can try to access the external drive contents thru my PC.


This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Have a go with this workaround fix. It might just fix your connection.

The workaround fix relies on the registry tweak below to change the drive letter that has been previously assigned to the mounted USB or FireWire portable mobile flash or hard disk drive. Or if users wish, can opt to delete any reference to the detected drives by the device so that when the storage device is plugged in again, the whole drive letter assignment will be start from fresh, and clean.
1.Login to Windows as an Administrator.
2.Open Registry Editor by typing regedit (or regedt32.exe in older Windows prior to XP) in Run command of Start Menu and then press Enter.
3.Navigate to the following registry key:
4.Optional step which not required in Windows XP or later, right click on MountedDevices, then select Permissions. You can also click Permissions from the Security menu.
5.Optional step which not required in Windows XP or later, check the option to make sure that Administrators have full control to the registry key. Change and revert back this setting when you are finished with the reset of the steps.

6.If you run above 2 steps in OS earlier than Windows XP, quit regedt32.exe and run regedit.exe.
7.Also in the HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices registry branch selected, in the right pane, find and locate a registry value which represents the troubled USB or FireWire drive. The registry key should have the name that resembles the format of \DosDevice\X: where X can be any alphabet letter which corresponding to your physical system drive letter.

Here?s a few guidelines that you can follow to quickly determine which registry key is linked to your conflicted drive letter:
Exclude \DosDevice\A: and \DosDevice\B: which normally reserved for floppy disk drives.
Exclude \DosDevice\C: which normally is the system root drive.
If you have more than one fixed hard disk drives, then any drive letters that are using by them is not possible linked again, UNLESS the additional hard disk drive is added AFTER you first use the USB or FireWire device that now unable to show.
Same case with CD-ROM or DVD-ROM optical drive as above reasoning.
If you have inserted and mounted a lot of thumbdrives, USB flask drive, or external hard disks before, you will likely still see a lot of remaining registry values that you won?t know which is which. In this case, double click on each remaining registry key values to view its binary data. Inside the binary data, there will be trace of the name of the device that this registry key represents.

With this information, search for a registry value that contains name of your USB or FireWire drive brand and model that having problem showing up in Explorer.
8.Once the correct registry value is determined (for example, \DosDevices\F:), right click on the registry value name, and the select Rename.

9.Change the drive letter (example F) to another unused drive letter that hasn?t been used by another other drives, then press Enter.
10.Now insert and plug in the USB or FireWire device into the port again (if it?s already inserted, take it out and re-insert again). The drive letter for the USB and FireWire should now appear and you can use the drive normally and properly again.
11.For OS earlier than Windows XP which you have previously change the permissions for the registry key, quit Regedit.exe and start Regedt32.exe, and change the permissions back to the previous setting for Administrators (which should be Read Only).
It?s also possible to simply delete the devices registry keys instead of renaming it. Deletion is helpful is users really can?t find the the registry value for the drive letter that having problem. But make sure that you do a backup for the registry branch by exporting MountedDevices key, as mistake may cause your system unbootable. The delete all possible USB drives, FireWire drives and external drives which have drive letter temporarily only when inserted in the system, and DO NOT delete any of the fixed hard disk drives or CD/DVD optical drives registry values.
Happy Computing.

Please post back if you have any more problems or questions.
If this information is useful, please mark as helpful. Thanks.

Collapse -

Thanks. This procedure didn't work...

by sundar.jawahar In reply to Have a go with this worka ...

Thanks for all who have posted suggestions. Changing the drive name didn't help. One of my colleagues helped to recover all the data thru Linux. Linux had a command to read RAW format.After which I used the Partition recovery link posted here to verify if all the data that was extracted thru Linux was intact and I formatted the entired external hard-drive. Good learning. Thanks to all.

Collapse -

See if this helps

by Jacky Howe In reply to Unable to detect Seagate ...

Click Start, Run and type in cmd and press Enter.
At the command prompt, type chkdsk ?/r and then press ENTER.
? = The drive letter of the USB device.
<i>Keep us informed as to your progress if you require further assistance.</i>
<i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.

Collapse -

Chkdsk unable to read external drive.

by sundar.jawahar In reply to See if this helps

I guess this didn't work since the format was RAW and Windows had a hard time recognizing the external drive.

Collapse -

Sounds like the MBR or Partition information is corrupted

by 1bn0 In reply to Unable to detect Seagate ...

You need a recovery utility like Active Partition Recovery.

I have used the enterprise edition successfully on both External HDD and USB flash drives. It can recover both the MBR/Partition information and files on the corrupted parttions.

I have not found a comparable Open Source Utility.

Collapse -

You reminded me about this

by Jacky Howe In reply to Sounds like the MBR or Pa ...

it may help th OP out. <br>
Partition Find & Mount <br><br>

Collapse -

Thanks for the post!

by 1bn0 In reply to You reminded me about thi ...

I have looked for "free" software to recommend to people , but did not locate any. THis looks like an acceptable solution.

For home users the speed limitation of the recovery should not be a problem.

Collapse -

The only

by Jacky Howe In reply to Thanks for the post!

thing is that I haven't tested it yet but it does look promising.


Collapse -

Thanks. The software was able to read my contents.

by sundar.jawahar In reply to Sounds like the MBR or Pa ...

I didn't purchase the software since I had the data recovered thru Linux thru my colleague.Save some $$.

Collapse -

That's Great

by Jacky Howe In reply to Thanks. The software was ...

Linux to the rescue.

Back to Hardware Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums