Unplug/Eject Icon Missing

By ThumbsUp2 ·
I have not been able to find the answer to this question anywhere, even in MS Knowledge Base. It seems that it must be a fluke, but I need help solving it.

When a USB storage device such as a thumb-drive (or whatever you want to call it) is plugged into one of our WinXP Pro machines, the system tray icon for unplugging/ejecting the device does not appear. In order to stop the device and safely unplug it, we must navigate through the device manager or My Computer (right click the device and select properties) to finally get to where we can stop it. When we DO click stop in this fashion, the "Unplug/Eject ICON" will briefly appear telling us to "click here to stop the device", then disappear as the device is actually stopped. This icon appears so briefly that it is impossible to move the mouse over to it TO click it.

It doesn't matter what manufacturer the USB "thumb-drive" is from, Sandisk, etc..., the same thing happens.

We've been through every article that even remotely mentions this icon and made sure that all settings that we're able to get to are set properly. Nothing seems to help. This only happens on only ONE of the multitude of computers that we own which are exactly identical (mass purchase).

The icon acts as if it has a switch turned on/off that is set to the opposite of what it should be for the state the device is currently in.


(added) By the way, did I mention that in the control panel, the add/remove hardware feature only lists "add hardware". The remove part is missing, even when logged in as the administrator. There is no way to get to the remove hardware portion of the wizard.

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

suggestion retracted

by huoml In reply to Unplug/Eject Icon Missing
Collapse -

that is a weird one. did you try another profile in administrators group?

by sgt_shultz In reply to Unplug/Eject Icon Missing

did you try another user profile. is this on a network?

Collapse -

No, I have not, but...............

by ThumbsUp2 In reply to that is a weird one. did ...

There are only two users created on this computer. Well, actually one user. There is the main user account (admin group) and the administrator account itself.

However, now that you mention it, there was a 3rd (really 2nd) user account/profile at one time. This person left the company. A new user account/profile was created when the present user was assigned to this computer about 5 months ago. Files were copied over to the new user's account/profile, then the original user was deleted. It's entirely possible that the thumb-drive was plugged in while logged into that old user account, then, after logging in as the administrator and this old user was deleted, the thumb drive was still in the USB slot and removed only after logging into the newest user account. I know I had a "safely remove hardware" icon at that particular time though. I don't unplug those things without using it. The new user has only pointed out the strange behavior within the last month.

I'll try your suggestion of adding a new user and plugging the thumb-drive in while logged in under that account. We'll see if the darned icon comes back or not.

I just think it's strange that it doesn't even work when logged in as the system administrator. Nothing I try will work. I've even tried plugging in a brand new drive of a different brand and letting it install it's drivers. Once the new one is working, that darned icon appears briefly, then disappears again. It's a slippery little sucker. And, yes, I've checked to make sure it's not being hidden. I have the sys tray set to always show that icon. I've even tried telling it to always hide the icon to see if it would magically appear.


Collapse -

Add / Remove Hardware?...

by OldER Mycroft In reply to Unplug/Eject Icon Missing

I didn't think there ever was a Remove Hardware option - I've never had one on my system.

You DO get a remove option for software but not for hardware.

Correct me if I'm wrong please Sgt.

Collapse -

According to MS Knowledge Base, there is.

by ThumbsUp2 In reply to Add / Remove Hardware?...

Even though these links don't address my specific problem, the KB articles say they apply to WinXP Pro. The first was even written in Feb. 2007.

And, I would swear the words /Remove appeared in the control panel of this machine up until some of the recent patches were applied. But, I'm getting old. I can't remember for sure.


Collapse -

My computer does not show a "remove hardware" icon neither

by Aakash Shah In reply to Add / Remove Hardware?...

I checked my computer and I only have a "Add hardware". However, I don't have an "add/remove hardware" or a "remove hardware". Just FYI.

Collapse -

Tray Icons Hit and Miss

by JRLBell In reply to Unplug/Eject Icon Missing

The tray icons in Microsoft are hit and miss at times. A quick question and sorry if it is obvious but you do have the "Hide Inactive Icons" box in the toolbar properties unchecked, right?

I've had problems with the USB stop icon ever since I installed Windows XP Pro. I get the icon when I plug something in but when I stop it, it never shows the message that it is safe to remove. I know it is safe because when I click on the still showing icon in the tray, it disappears.

I have another problem with the system tray as well. My Volume/Mute icon for audio is set to show up when I start windows. It never does. I now have a shortcut to the "Sound and audio devices" application in my launch bar. I don't usually turn my PC off, so it is not a huge nuisance but when Microsoft requires those reboots after updating I have to click on the icon to open the application. Sure enough, the box that shows that it should show an icon in the system tray is checked--but, no icon in system tray. In order to get it into the system tray I have to uncheck the box, hit apply, then check the box and hit apply. Then everything is hunky-doory until the next time I reboot.

I haven't bothered to search for an answer to my problems because they are minor. I would think your problem would cause a little more frustration. I wonder if you uninstalled the USB host controllers or roots (windows should find them again when it reboots [emphasis on SHOULD]) if that would fix the problem. Maybe get an opinion from someone who knows about USB a little more than I do before proceeding with that suggestion.

I suppose, if worst comes to worst, you could creat a shortcut to the USB connection and just click on it rather than going through all the My Computer/Properties/Hardware/Device Manager stuff.
This web page seems to have a few methods to do just that.

GL with your quest.

Collapse -

View hidden devices

by lbindustries1 In reply to Unplug/Eject Icon Missing

I remeber seeing in an article a while back about viewing devices that do not normally show up in the device manager.
This might be somewhere you can look for these drives. If they are there then all you need to do is remove them, when they are inserted again they will reinstall themselves. Best of luck to you.

Collapse -

They're not hidden.

by ThumbsUp2 In reply to View hidden devices

Thanks, but you're on the wrong path.

The USB device is not hidden in the device manager when it is plugged in. It's the icon in the system tray that's missing. That icon is the shortcut to safely stop the device before unplugging it. We can stop it by going through a long process to get to the right place. We want the icon back so it's easier to accomplish the stop task.

Collapse -

Update, for anyone who might find this thread.

by ThumbsUp2 In reply to Unplug/Eject Icon Missing

We eventually just wiped the darned thing and started over. Absolutely nothing we tried, including creating a new account, would restore that darned icon.

We never did find what caused it, but it has worked flawlessly since the wipe/reinstall.

Back to Hardware Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums