Hardware

Question

Locked

USB Flash Drive is write protected - How do I remove it?

By ddelpilar ·
While transferring files from my PC to my USB Flash Drive. I received an error message - The Disk can not be written because it is write protected. Please remove the write protection from the volume in drive \Device|Harddisk1\DR5.

How do I do this?

Thanks.

Darwin

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

USB Flash Drive Problem solved?

by ingolf.steinbach In reply to USB Flash Drive is write ...

Hi,

have you solved your problem? I seem to have the same problem with a USB 2.0 PenDrive Mini, 1GB, which has started to report write protection after about 260MB have been copied successfully to the drive. Formatting works, however.

Kind regards
Ingolf

Collapse -

Do it in DOS

by da5id_NZ In reply to USB Flash Drive is write ...

I have posted this elsewhere, but...

I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

What I found you can do is get into the drive through a DOS prompt.

Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

Now to list the directory, type DIR
This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

xcopy c: a: /s

You can do a search on google to find other DOS commands

Collapse -

Try this

by Jacky Howe In reply to Do it in DOS

Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.
The value 'WriteProtect' should be absent or set to '0'.

Collapse -

THANKS

by punit_vyas2005 In reply to Try this

IT'S WORKS

Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.

The value 'WriteProtect' should be absent or set to '0'.

Collapse -

hello i am having this exact problem!!!

by poooh%%boo booo In reply to THANKS

ill try this out and hope it actually works.....

Collapse -

lucky fix

by hyuganeji1 In reply to Try this

So I right clicked my flash drive went to sharing and security--> sharing tab and I added a new share and under permissions I added my username from the network and gave it full control. I clicked ok then everything worked fine. Then I went back to the drive in my computer right clicked it again, went to the sharing and security, then the sharing tab and removed the new share that I just added and things still worked fine. Not sure why but you could give it a try.

Collapse -

Cant find StorageDevicepolicies file

by powermanx84 In reply to Try this

it was said go do storage device polices file in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

i followed all these files but could not storage device file....what do i do?

Collapse -

if you cant get storagedevicepolicies do this

by greengerm In reply to Cant find StorageDevicepo ...

press start on your screen,go to run,if you have windows 7 like me go to the part where it says search programs and files here,search run,click on it,and type regedit,now in registry editor click on computer once,go to the upper left corner in the window and click file then click export and save it on desktop,this will be a backup,if you mess up your registry then click file then import and import that file,now go to on the rgisrty editor
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\control\usbstor
then click on each folder and go to each file that say devicehack flags,click on it and put the value to 0 and thats it!!

Collapse -

cant find

by t41h4 In reply to if you cant get storagede ...

hey i cnt find any folder named usbstor
what shall i do now..?? =S

Collapse -

Reistry is different

by bkile1 In reply to Try this

I tried to use this fix, but my registry does not have the final folder: "StorageDevicePolicies" Could there be another name for this folder? I am using XP Pro.
Thnaks.

Related Discussions

Related Forums