Hardware

Question

Locked

USB Flash Drive is write protected - How do I remove it?

By ddelpilar ·
While transferring files from my PC to my USB Flash Drive. I received an error message - The Disk can not be written because it is write protected. Please remove the write protection from the volume in drive \Device|Harddisk1\DR5.

How do I do this?

Thanks.

Darwin

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Found a fix after months of looking

by technik In reply to USB Flash Drive is write ...

Found it! I have a feeling one of my co-workers (A Linux God who disdains us Windows Gurus) was playing a joke on me. The following came from David Kramer.KA at http://davidkramer.wordpress.com It fixed it completely. Thank goodness! Open the command line editor of windows XP (in my case, and in that case hopefully your, if I am to help you). You find that under ?Start?, the choose ?Run?. There you enter ?regedit?. This starts a little program that allows you to operate within the holiest of sites of windows, the registry. Here all kind of actions and behaviors of the system are set. Go to the path: HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control \StorageDevicePolicies This is simply a folder within a folder and so on? The final folder, the one you are looking for is called StorageDevicePolicies, and as the name suggests contains the settings for how the storage devices (USB flash) should behave. Here you right click on: ?WriteProtect? and select ?modify?. Here you set the value that appears to ?0″. Press enter and that?s it. (In other words: Default value: DWORD=0) Possible values are: 0 ? Disabled 1 ? Enabled Set the value to 0 and your back in business.

Collapse -

A Couple of observations.

by kimatthews In reply to Found a fix after months ...

Did the StorageDevices thing and it still didn't work, so I did a safe remove of device and then plugged it in again and it worked. I could then format the drive in Explorer.
1. This USB stick went through a couple/four airport scanners.
2. Also had the problem after moving from one machine to another without safely remove.

Collapse -

having a problem with your instructions

by Pooshen In reply to Found a fix after months ...

i've tried to open the path that you've given but when i was on this part "HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control" i can't find the "storageDevicePolicies" i'm using a windows xp service pack 3 could that be an issue?

Collapse -

Thanks

by sharmaharsh In reply to Found a fix after months ...

Worked great!!!

Collapse -

Reponse To Answer

by JohnMich In reply to Found a fix after months ...

This was working like a dream until I got to the Storage Device Policies bit. Too easy says I. But I am using W/Vista Home Basic and guess what there is NO heading Storage Device Policies! Further clicking on the Storage heading does nothing its empty.
So can someone please tell me what to do now.
I have copied all the files that were on the G: drive to a separate area on C: (a sort of belt and braces thing) but I can't even format G: because of the write protection.
What do I do now please?

Collapse -

Reponse To Answer

by nikhil25 In reply to Found a fix after months ...

the best way is to use the regedit only, but if you can afford to format the usb drive, then try "HP usb disk storage format tool" ( http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml ) it is very small utility & quite useful.

- Nikhil

Collapse -

Solved! using flashdrive again - w/o reformatting it!

by overburned In reply to USB Flash Drive is write ...

click on safely remove hardware & eject media, unplug device, plug it back in, then start saving your files to the flash drive!

Collapse -

Zombie alert!

by TobiF In reply to Solved! using flashdrive ...

The problem was raised and the correct solution (a different one than you propose was found) back in 2007!

Collapse -

i have the same problem

by imwhoim In reply to USB Flash Drive is write ...

i have my 256 GB kingston , it wont write any more , it only allow me to copy the files that already in there but when i tried to write more files it tells me that this drive is write protected , i tried to do the regedit but nothing works out , what can i do , is there any help , please !

Related Discussions

Related Forums