Question

Locked

USB HDD not appearing on Windows XP/Linux

By Pradeep M-12379003 ·
I know this question has been asked many times in many places but I still couldn't figure out what to do with this issue.

I bought an USB 2.5" HDD enclosure to use with a HDD of my previous laptop. For some reason it doesn't recognised correctly by my desktop which is a dual boot system with XP and Ubuntu.

HDD has two partitions. One NTFS and one FAT32. Sometimes XP identifies it as a USB Mass Storage Device and shows it in My Computer as a RAW device. Same with Linux, it tries to mount the device but fails after a minute or two.

I have seen many people advice to change the drive letter of the device. To do that, this should appear in Disk Management. I've seen only once in last few months that this appears in there!

I have tried it on my laptop and on a different desktop, it works fine. So I assume this has something to do with my desktop. It is a Shuttle XPC SK41G with VIA KM266/8235 chipset.

Any ideas please? It would be great if I can sort this out without reformatting this HDD.

Many thanks in advance.

This conversation is currently closed to new comments.

14 total posts (Page 2 of 2)   Prev   01 | 02
Thread display: Collapse - | Expand +

All Answers

Collapse -

Your welcome <NT>

by OH Smeg In reply to Writing failure
Collapse -

Finally it worked...

by Pradeep M-12379003 In reply to USB HDD not appearing on ...

Hello all,

Today I thought of giving another go with my external USB drive. This is what I did.

1. First I copied everything in that HDD to my laptop
2. Installed SwissKnife V3 on my desktop and connected the external HDD to it.
3. SwissKnife showed 2 partitions in that HDD. One is a hidden IBM recovery partition and the other one is the FAT32 partition.
4. Deleted both partitions.
5. Created and formatted a new FAT32 partition.
6. Disconnected and reconnected the USB HDD to desktop.

Finally it worked!!!! Now my desktop identifies it without any problems.

Now I am wondering if that hidden IBM recovery partition prevented identifying it on my desktop.

Thanks again guys.

Collapse -

Very unlikely it held the Recovery Partition if it was a decent size

by OH Smeg In reply to Finally it worked...

If it was just something like 8 MEG it was the Partition Information Table that mapped the drive so that the computer could read it.

The Recovery Partition allows you to rebuild the Drive by pressing 2 keys.

What the problem is more likely to be is that IBM has a Security Chip built onto the M'Board which prevents the ability to read Data on a HDD when connected to a different platform.

You can wipe/Delete the Partitions and reformat without a problem but using the Data on the drive is a totally different Story. IBM Incorporate this to protect the Owner of the hardware and secure their Data.

Col

Collapse -

Thanks again...

by Pradeep M-12379003 In reply to Very unlikely it held the ...

Thanks for the tip mate. It seems working fine now.

Back to Hardware Forum
14 total posts (Page 2 of 2)   Prev   01 | 02

Related Discussions

Related Forums