Question

  • Creator
    Topic
  • #2220990

    Vlan trunking, L3 switch + L2 switch problem

    Locked

    by acer1986 ·

    Hi, I have now successfully got my PowerConnect 6224 configured, to host and route between 4 Vlans, I have internet access and can ping what I need to, it’s all working great. The next thing on my list is configuring my L2 netgear router to work with port based Vlans, I want to connect the L2 switch to port 1/g23 on my PowerConnect 6224, as far as I understand this port needs to be a trunk port that allowes all Vlans, here is my config for the PowerConnect 6224:

    !Current Configuration:
    !System Description “Dell 24 Port Gigabit Ethernet, 2.0.1.8, VxWorks5.5.1”
    !System Software Version 2.0.1.8
    !
    configure
    vlan database
    vlan 10,20,30
    vlan association subnet 192.168.1.0 255.255.255.0 1
    vlan association subnet 192.168.2.0 255.255.255.0 10
    vlan association subnet 192.168.20.0 255.255.255.0 20
    vlan association subnet 192.168.30.0 255.255.255.0 30
    exit
    stack
    member 1 1
    exit
    switch 1 priority 1
    ip address 192.168.1.1 255.255.255.0
    ip domain-name xxx.xx.xx
    ip name-server 192.168.2.10
    ip name-server 192.168.2.30
    ip routing
    ip route 0.0.0.0 0.0.0.0 192.168.2.201
    bootpdhcprelay enable
    bootpdhcprelay serverip 192.168.2.10
    bootpdhcprelay cidridoptmode
    ip helper-address 192.168.2.1 192.168.2.10 37
    ip helper-address 192.168.2.1 192.168.2.10 49
    ip helper-address 192.168.2.1 192.168.2.10 137
    ip helper-address 192.168.2.1 192.168.2.10 138
    ip helper-address 192.168.20.1 192.168.2.10 37
    ip helper-address 192.168.20.1 192.168.2.10 49
    ip helper-address 192.168.20.1 192.168.2.10 137
    ip helper-address 192.168.20.1 192.168.2.10 138
    ip helper-address 192.168.30.1 192.168.2.10 37
    ip helper-address 192.168.30.1 192.168.2.10 49
    ip helper-address 192.168.30.1 192.168.2.10 137
    ip helper-address 192.168.30.1 192.168.2.10 138
    interface vlan 10
    name “Servers”
    routing
    ip address 192.168.2.1 255.255.255.0
    ip rip send version rip1
    ip irdp
    exit
    interface vlan 20
    name “Sales”
    routing
    ip address 192.168.20.1 255.255.255.0
    ip rip send version rip1
    ip irdp
    exit
    interface vlan 30
    name “Accounts”
    routing
    ip address 192.168.30.1 255.255.255.0
    ip netdirbcast
    ip rip send version rip1
    ip irdp
    exit
    username “michi” password 4f70cfb1451a1b0ce0b872421bee6c1c level 15 encrypted
    !
    interface ethernet 1/g1
    switchport mode general
    switchport general pvid 10
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 10,20,30
    exit
    !
    interface ethernet 1/g3
    switchport mode general
    switchport general pvid 10
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 10,20,30
    exit
    !
    interface ethernet 1/g4
    switchport mode general
    switchport general pvid 20
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 20
    exit
    !
    interface ethernet 1/g5
    switchport mode general
    switchport general pvid 10
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 10,20,30
    exit
    !
    interface ethernet 1/g7
    switchport mode general
    switchport general pvid 10
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 10
    exit
    !
    interface ethernet 1/g8
    switchport mode general
    switchport general pvid 30
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 30
    exit
    !
    interface ethernet 1/g23
    switchport mode trunk
    switchport trunk allowed vlan add 1,10,20,30
    exit
    !
    interface ethernet 1/g24
    switchport mode general
    switchport general pvid 10
    no switchport general acceptable-frame-type tagged-only
    switchport general allowed vlan add 10,20,30
    exit
    exit

    On my netgear L2 switch i want to connect port 24 to 1/g23 of my Dell switch, but I can’t seem to be able to get it to work somehow, here is my config of the Netgear switch:

    !Current Configuration:

    !

    !System Description “GSM7224 L2 Managed Gigabit Switch”

    !System Description 6.2.0.14

    !

    set prompt “GSM7224”

    network protocol none

    network parameters 192.168.1.2 255.255.255.0 192.168.1.1

    vlan database

    vlan 10

    vlan name 10 Servers

    vlan 20

    vlan name 20 Sales

    vlan 30

    vlan name 30 Accounts

    exit

    configure

    clock timezone ‘GMT’ 0 0

    sntp client mode unicast

    ! sntp server status is active

    sntp server PooleOne.xxx.xx.xx

    logging buffered

    lineconfig

    exit

    storm-control flowcontrol

    spanning-tree configuration name 00-0F-B5-FC-BA-62

    snmp-server community public@10

    snmp-server community public@20

    snmp-server community public@30

    ip domain-name xxx.xx.xx

    ip name-server 192.168.2.10

    192.168.2.30

    192.168.2.201

    interface 0/1

    vlan pvid 10

    vlan participation include 10

    exit

    interface 0/2

    vlan pvid 20

    vlan participation include 20

    exit

    interface 0/3

    vlan pvid 30

    vlan participation include 30

    exit

    interface 0/4

    exit

    interface 0/5

    exit

    interface 0/6

    exit

    interface 0/7

    exit

    interface 0/8

    exit

    interface 0/9

    exit

    interface 0/10

    exit

    interface 0/11

    exit

    interface 0/12

    exit

    interface 0/13

    exit

    interface 0/14

    exit

    interface 0/15

    exit

    interface 0/16

    exit

    interface 0/17

    exit

    interface 0/18

    exit

    interface 0/19

    exit

    interface 0/20

    exit

    interface 0/21

    exit

    interface 0/22

    exit

    interface 0/23

    exit

    interface 0/24

    description ‘Trunk Port’

    vlan tagging 1

    vlan participation include 10

    vlan tagging 10

    vlan participation include 20

    vlan tagging 20

    vlan participation include 30

    vlan tagging 30

    exit

    exit

    First; is it possible to accomplish what I’m trying to do with my equipment?

    Second; where have i gone wrong in my configs?

    Thank you very much for your help.

All Answers

Viewing 1 reply thread