Question

Locked

What Driver Downloader to use???

By cdwright1 ·
Hi.
I have An Acer Aspire 3680-2022 notebook I bought used with Windows 7 ultimate upgrade.
It's supposed to have the 3in1 card reader but it's not reading any memory cards.
I opened up device mgr. The icon for mass storage controller needed attention. So I tried to update driver... No driver to update- driver is missing.
I've tried a few driver updaters but they all want to be paid to activate after the initial scan. I don't want to pay for software if I can't use it or it won't work!
What driver installer do you recommend? I'm not officially a tech though I am pretty savvy.
If there is free driver software that I can use without having to pay for registering; It would be even better since I just paid $50.00 for a 16gb flash memory card and I have to buy a replacement battery! But other than all that the laptop's great! So please, no comments about getting my money back!!

Thank You,
CDWright

This conversation is currently closed to new comments.

23 total posts (Page 3 of 3)   Prev   01 | 02 | 03
Thread display: Collapse - | Expand +

All Answers

Collapse -

the card reader is a Texas Instruments Device (TI)

by Who Am I Really In reply to WHAT TI DEVICE??

not a Realtek Device

a Card Reader is a piece of hardware
and just like any hardware device it needs a software driver component

the software driver component must match the device or it will not do anything but waste yer time

Collapse -

WHOOPS

by cdwright1 In reply to the card reader is a Texa ...

Okay,
I wasn't understanding that.. I thought it was TI was the driver for the card. Thanks!

Collapse -

iSCSI initiater

by cdwright1 In reply to WHOOPS

Was not turned on. I turned it on..
The only thing of interest that I could see is under DISCOVERY tab: (D:) at port 3260 now seems to register, but I still can't access a memory card- SDHC 8gb.
I typed cmd in run and typed (D:) Came back DEVICE IS NOT READY, if that's any help..
Ran command services.msc.
Smart card is auto and started. any other services I need to start? I think I already got the few other services pertaining to memory cards, but I could have missed something...
And when I right click on my DMA I get option to add LEGACY hardware which opens up the Add Hardware Wizard. Should I look for anything there to install?
ALSO- In comparing this Aspire with the one I have that reads the memory card, in DEVICE MGR I'm missing JMCR SD/MMC SCSI disc device under disk drives, and PCMCIA and flash memory devices, It also doesn't have ISAPNP Read Data Port under SYSTEM DEVICES. But I'm not sure if that's relevant.
Is there maybe a way I can copy the files (Via USB flash) and somehow install them to this one? Could that work? I'm trying to locate those folders now, but admitting it's like looking for a needle in a haystack!**
If found, I won't take any action unless approved here first!
Device Manager says all my devices are up to date. I DO go by that rather than anything any driver update software will tell me. But I did run a test scan with DriverWhiz which claims all my INTEL drivers are out of date..
**I gave up looking for those folders for now

Back to Hardware Forum
23 total posts (Page 3 of 3)   Prev   01 | 02 | 03

Related Discussions

Related Forums