Question

Locked

Windows Server 2003 R2 with Remote Desktop Admin - Can't connect, no error

By mark ·
Using Remote Desktop Connection in Vista, I used to be able to successfully connect to a couple of servers running Windows Server 2003 Enterprise running Remote Desktop Admin (not full Terminal Server licensing in place).

Both of these machines were upgraded to Windows Server 2003 R2. Now, when a Vista (or XP for that matter) client tries to connect to either of those servers with RDC, they find the server (name resolution seems to work), and I'm prompted for credentials. The RDC applet greys out as if it's about to connect, then about 1 second later, nothing happens and I'm back to the RDC prompt (asking me for the server name again). No error. This occurs on both of the R2 servers (both running Enterprise, one is a domain controller, the other is not).

RDC functions fine when connecting to non-R2 2003 servers.

I don't show anything in the security log for these R2 servers that show that credendials were wrong. If I purposely enter the wrong credentials, the same effect, no prompt that the credentials were wrong.

DNS seems to be fine as I can ping and remote connect to these machines using other remote control software (Radmin). I've tried un-installing that thinking it was a problem with R2 and the video hook drivers, but no luck.

Firewall settings on the R2 servers also show that Remote Desktop is enabled as an exception. I've also tried completely turning off the firewall, no luck.

Terminal Services Manager is running fine and showing that RDP-TCP listener is running.

Thanks all.

This conversation is currently closed to new comments.

23 total posts (Page 3 of 3)   Prev   01 | 02 | 03
Thread display: Collapse - | Expand +

All Answers

Collapse -

I think I have the same video card, ATI?

by mark In reply to Finally figured it out... ...

I believe these servers both have the same ATI Radeon X600 in them, although they're using the ATI XP/2003 driver from the website, not the default Windows driver. But perhaps it's related (video hook or version of the catalyst driver).

Out of interest, we're your side effects the same as mine? See my original post about how RDP was behaving from the client PC.

THanks!

Collapse -

RDP is now working with removal of ATI Catalyst component of their driver

by mark In reply to I think I have the same v ...

Wescrook, thank you, you're post led me to further investigate the ATI drivers and tweak them a little more. Although I had the latest ATI drivers with Catalyst, I decided to remove the complete suite and re-install without the Catalyst suite, just the vanilla ATI driver. Behold, RDP is now functioning.

Thanks Wescrook! And thank you TheVirtualOne, Scott and Retro for all your help as well.

Collapse -

no prob!

by wescrook In reply to RDP is now working with r ...

In response to your reply 2 posts ago, yes, my symptoms were exactly the same - attempt to connect, gray out for about 2 seconds, then return to the connection window with no error whatsoever.

Glad I could be of help!

Back to Windows Forum
23 total posts (Page 3 of 3)   Prev   01 | 02 | 03

Related Discussions

Related Forums