WinXPPro - Problems Joining a Windows Server 2003 Domain

By mandocia ·
Hello, I have just installed a 2003 Server Enterprise Edition (Evaluation Version) on one of my older 1.8 gig systems. I have installed DNS and Active Directory, with nothing else as of yet. I have not added anything into Active Directory other than a user. When I try to connect to this domain from a computer within the same network running XP Pro SP2, I get the following error after I input my username and password:

The following error occurred attempting to join the domain "XXXXXXXXXXXX"

(The XXXXX's are in place of the domain name)

The format of the specified network name is invalid

On the windows xp computer, I have set it's DNS settings to the DNS server on the win 2003 box, and the DNS works. I googled this but nothing so far has helped. I also tried to create a new user account, thinking the administrator account was messed up, no luck there.

Also, this occurs for another computer on the network running the same OS, so this occurs for 2 separate computers with the same error messages. Each computer name is only about 10 characters, no spaces or strange characters, only numbers.

Any help would be great, as I cannot figure out why this is occurring. I am new at this, so I am not sure where else to look. Thanks.


This conversation is currently closed to new comments.

28 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -


by Toivo Talikka In reply to WinXPPro - Problems Joini ...

Are you sure you have not used for example the underscore character in one of the names, like the name of the server, the domain or the computer?

Collapse -

No Underscore characters

by mandocia In reply to Characters

Nope, I have not used any special characters.

These are the names I am using:

2003 Server - mdpserver001

XP Desktop - mdpserver002

XP Notebook - mainnotebook

I have no spaces, just the names as you see them.


Collapse -

joining via system properties/computer name

by CG IT In reply to WinXPPro - Problems Joini ...

the error code your getting is saying that either the netbios name you use or the domain name your using isn't correct [format]

so using the domain name would be <domain name>.com [if you used .local, you must use .local]

Collapse -

Domain Name Properties

by mandocia In reply to joining via system proper ...

I am using a real domain name, and I am putting that into my join domain request on the windows box.

The domain name is as follows:

Now, it is a real world domain name, would that cause the problem? If I put in the netbios name of daminious, it does not find the domain controller, but if I do put in, it finds it and asks for a username and password to join the domain, but fails with the name error.


Collapse -


by CG IT In reply to Domain Name Properties

have to be a member of the admin security group to join the domain.

Collapse -

Username and Password Used

by mandocia In reply to admin

I have used the Administrator account with the password to try to join the domain, it does not work.

I also cloned the Administrator account and named it different and tried that, did not work as well.


Collapse -

Check something please

by XT John In reply to WinXPPro - Problems Joini ...

On the server, right click My Computer, and click the Computer Name tab. What does it show for Full computer name: and Domain

Collapse -

Computer Name:

by mandocia In reply to Check something please

Here is the Computer Name for the Server:

Domain name:


Collapse -

Check this out

by XT John In reply to Computer Name:

I was totally puzzled... but a little searching turned up some possible answers. Were the client machines attached to a different domain? Also, are you using static IPs or DHCP. Check out this link....

One other thing to try... open up the Active Directory Users and Computers on the server and check what is listed under Computers and Domain Controllers. Especially check that there aren't duplicate names lurking about.

Collapse -


by mandocia In reply to Check this out

My notebook computer was at one time connected to another domain for testing, however that was sometime ago. My other desktop with windows xp has never been on a domain, and both have the same error message.

My server has a static IP that corresponds to my ISP's DNS settings. My desktops are on automatic for DHCP, and get these settings from my router. My 2003 server does not have DHCP installed.

When I open up Active Directory, under computers I have nothing listed. For domain controller, I have my 2003 server listed.


Back to Networks Forum
28 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums