General discussion

Locked

Workstation service on Win XP runs slow

By godzillex ·
This is infuriating!

I recently finished reformatting my system, and re-installing a copy of Windows XP (SP1).
After going to a four day ordeal of web-updating it to SP2, and re-installing and reconfiguring all my applications just the way I wanted them, my laptop suddenly started to respond VERY, VERY sluggishly.

Here is what happens:

During the boot-up phase, it's now taking over 2 mintues for my system to come up. Yesterday it was taking less than 25 seconds!
So I decided to fire up the "service.msc" during the bootup phase to see where the hang up was, and guess what I found?

The system is hanging on the bloody "Workstation" service, and it's showing that by displaying the word "Starting" for almost a whole minute.

Needless to say this is very frustrating as it also seems to be affecting the Windows Explorer operation as well:

When I use the "Windows-E" button to fire up the Explorer, it takes a good 3 seconds for it to come up.
In contrast, double-clicking the "My Computer" icon, brings the Explore up instantly. This is rather baffling.

I'm willing to live with the Explorer slow down, but the Workstation service slowdown is taking its toll on my nerves.

Any help would be greatly appreciatd.

Here are the links to the current status of services on my machine (JPG format):

Started: http://tinyurl.com/ozclu
Manual: http://tinyurl.com/mmchw
Disabled: http://tinyurl.com/pz6tr

Thank you.

This conversation is currently closed to new comments.

19 total posts (Page 2 of 2)   Prev   01 | 02
Thread display: Collapse - | Expand +

All Comments

Collapse -

Add / Remove...

by theman In reply to Workstation service on Wi ...

I found myself having this same problem after using a TCP / IP "fix" utility, scanning for spyware, etc.

I just realized it's because of the PREFETCH folder!!! WOW...and I had posted another solution that wasn't a solution at all. I'm editing this one.

Check out the information on this site...

http://members.rushmore.com/~jsky/id14.html

He did a great job and even shows you how to fix your PREFETCH settings. I knew it was there to help with the speed of XP but never knew it was actually a bad thing to delete files from there!

Thanks,


RW

Collapse -

The wireless connection was my problem...

by unneeded In reply to Workstation service on Wi ...

I have a Dell Inspiron 9200. Same problem, long boot time. Eventually figured out it was the Workstation service. I had recently removed the fancy Intel software for the internal 802.11 hardware, but I had not disabled the device itself. I uninstalled the device, then rebooted. Workstation service started quickly again! Then Windows PnP located the device and reinstalled drivers (but not the big Intel pkg). Next reboot was slow again, so I disabled the device itself. Now reboots work just fine every time. I did not need to do anything with the precache folder.

Collapse -

I HAVE THE ANSWER!!!!!

by lvidito In reply to Workstation service on Wi ...

I had the same problem on several laptops, and I have solved it! Anyone who is using additional wireless software to manage their wireless connection (i.e. Intel, Dell, etc.)needs to uninstall it and use the native Windows Wireless Zero Configuration. If the service is disabled, enable it. After doing this, we can now all have mapped network drives, the Workstation Service enabled, and NO MORE HANGING AT THE WALLPAPER at startup!!

Collapse -

by giogioforums In reply to I HAVE THE ANSWER!!!!!

HI all.
After getting crazy for fours months here the solution to save you some pain.
http://techrepublic.com.com/5208-11184-0.html?forumID=47&threadID=197152&messageID=2311170
Once I've fould out that the workstation service was slowing the all start up / login process with windows XP.
Here I am posting some considerations.
First the problem appear as a very slow login after typing your passord prior the desktop to appear.
The problem also appeared as an infinite need to repair continuously the connection (right clicking on the wireless icon) or often as inability to

connect wirelessly.

The SOLUTION to the problem "login to XP takes forever" is to remove any other software that manages the wireless card and let only the native Windows

Wireless Zero Configuration to handle it but the problem immediately desappear!!!.
Once you unistall any other software excepts the drivers of the wireless card, you must go on control panel/network

connections/advanced/general/properties/wirelss network and click on Use
Windows to configure my wireless network settings which will anable the native Windows Wireless Zero Configuration.

The problem is probably found in many computer that have the intel centrino chip set which uses the Intel(R) PRO/Wireless 3945ABG Network Connection but

maybe is with any other wireless
card that uses the intel software to manage.

Myself I did also utilize a second D-Link wireless card which was also utilizing its own software to manage and could work with the native Wireless Zero

Configuration) but it turned out because of the Intel(R) PRO/Wireless manager.
Myself just to be safe I unistalled also the D-Link softwarebut is not really necessary.

Collapse -

by giogioforums In reply to

TWO MORE IMPORTANT Considerations:
THE PROBLEM DID NOT IMMEDIATELY GO AWAY!
1)
I had to reinstall (from an image I had) the entire operating system and then remove the Intel Wirelss manager from it.If I was not removing the Intel SW

the problem after few hours the problem reappeared (I restored the OS from the image like 30 times so I am certain).
For many people the problem will go away immediately just unistalling the wirelss software but that was not my case.
If you do not want to uninstall the operating system.you may go through a procedure to reset entirely the networking in your OS, I know there is a way to

do it but I never researched it.
(Maybe all you need to do is to remove all network conncections by uninsalling all drivers I chose to restart with a new XP)

2)
I utilize 2 wireless cards and I am having a second minor issue:
IF I DISABLE the wireless switch of my Intel card and connect the 2nd one, the pc still says that there are network available on the 1st. In other words

the card is not entirely off. I use a brand new DELL LATITUDE D820. Maybe this is to avoid the Plug&Play procedure.
As result I see two wireless icons on the bottom right when I only want one and altough the external DLINK says that is correctly connected to the

wireless network, Windows still seem to remain internally connected to the Intel one and as result will still be unable to see a webpage.
In order to "connect" Windows to the correct external network card I must click on its repair button (right click on its icon) and then everything is

ok. Maybe this is another bug of the os which wouldn't come as a real surprise.
I hope this all note will be useful to you and save you a lot of time.
Good luck!
PS
If you find on the web that the prefetcher is the problem.. I think it is not true.

Collapse -

by giogioforums In reply to

I forgot to mention that the problem appears also as <Preparing Network Connection> prior login with a different mmc setup to show the activity prior login. That's because even though the problem seems to appear after typing the login password, actuality the long delay starts prior typing it. The solution is the same as above.

Collapse -

You suck

by Poop In reply to

Learn English please, and then sort out what it is you are attempting to tell us. Once you've figured all of that out, try typing it in a sensical manner. Your post is actually more worthless than mine, devoid of any point or value. The only success your post has had is infuriating me enough to write this note over a year after your finger staggered around a keyboard and banged that turd out.

Collapse -

by scott.ager In reply to Workstation service on Wi ...

This a little late but it is a continuing issue even up to SP3. I have a laptop with both wired LAN and Wireless cards. Most of the time I use a cable modem connection for speed and reliability. Sometimes after switching to WiFi and then back I get the 2 minute boot crap. Without LanManServer started, half my other automatic services don't startup either. Result: Really slow startup. Try this ridiculous sounding fix. Put Wireless Zero service on auto even though you're not going to use wireless. Bingo, fast bootup. It's another quirk brought to you by Microsoft. (like having to disable personal menus to get full drop-down menus in desktop). Now we have a brand new can of worms called Vista. Wheeeeee!, what a ride.....

Collapse -

Still problems in 2012

by cantoris In reply to

Just seen the exact same issue on a fully patched XP machine with an Intel Centrino Wireless-N 1030 chip here in 2012!

One of two things happen:
- PC hangs on "Preparing network connections" for ages and then all is well
- PC doesn't hang but on logging in, many services are not running, Workstation service is stuck "Starting". Eventually, the Workstation service starts and other services then kick in but then WebClient service sticks instead. After a while it starts and then transitions to "Stopping" and stays stuck on "Stopping".

Configuring a wireless profile with the Intel tool solves the problem!

With wireless disabled, the problem returns. Scott's solution regarding the Wireless Zero Config service fixes the problem - thanks!

Back to Windows Forum
19 total posts (Page 2 of 2)   Prev   01 | 02

Related Discussions

Related Forums