General discussion

Locked

XP Pro Won't Share Internet Connection

By DouglasB ·
Running XP Pro SP2. One NIC for ISP input from cable modem using pref & secondary dns servers. Can connect to ISP ok. Second NIC for home network, but other computers can not see the "sharing" computer or get to the internet. I have tried different NIC's, uninstalled and reinstalled software and run/re-run the internet setup wizard, no luck. DHCP service is running. The second NIC has been assigned an IP and subnet. When I remove this IP/Subnet the other computers can "see" each other, but then there is no internet connection. I have repaired the winsock, still not fixed.

This conversation is currently closed to new comments.

16 total posts (Page 2 of 2)   Prev   01 | 02
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by DouglasB In reply to XP Pro Won't Share Intern ...

In response to jstafs@gmail.com I disabled the fixed ip/subnet on the card that connects to my LAN and was able to see all the computers, and they could see the "server." However this lost the ISP connection on the host.

Collapse -

by Addison In reply to XP Pro Won't Share Intern ...

1.Open Internet Explorer

2.On the Tools menu, click Internet Options.

3.On the Connections tab, click Never dial a connection, and then click LAN Settings.

4.In Automatic configuration, clear the Automatically detect settings and Use automatic configuration script check boxes.

5.In Proxy Server, clear the Use a proxy server check box.

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by Addison In reply to XP Pro Won't Share Intern ...

It's best to start form scratch:

To enable Internet Connection Sharing on a network connection

1. Open Network Connections

2. Click the dial-up, local area network, PPPoE, or VPN connection you want to share, and then, under Network Tasks, click Change settings of this connection.

3. On the Advanced tab, select the Allow other network users to connect through this computer's Internet connection check box.

4. If you want this connection to dial automatically when another computer on your home or small office network attempts to access external resources, select the Establish a dial-up connection whenever a computer on my network attempts to access the Internet check box.

5. If you want other network users to enable or disable the shared Internet connection, select the Allow other network users to control or disable the shared Internet connection check box.

6. Under Internet Connection Sharing, in Home networking connection, select any adapter that connects the computer sharing its Internet connection to the other computers on your network.

Collapse -

by DouglasB In reply to

Poster rated this answer.

Collapse -

by DouglasB In reply to XP Pro Won't Share Intern ...

This question was closed by the author

Back to Windows Forum
16 total posts (Page 2 of 2)   Prev   01 | 02

Related Discussions

Related Forums