How to fix SPECIFIC Internet Explorer Script Error

By lamentofking ·
I'm having an ie script error(s) message pop up on startup. I put 'specific' in the title of this question because it's coming from a network agent I have installed called 'Cisco NAC Agent' . The error(s) is stopping Cisco from popping up so that I can login and use the internet.

Here are pics of the error(s) i get. The first happens everytime the error pops up but the second happens randomly but only after the first.

Can somebody please help me out with this? It just started happening after I uninstalled the DANCE!Online program by Acclaim and restarted. I don't know if that is relevant or not because the two are not related...or are they?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by TobiF In reply to How to fix SPECIFIC Inter ...

In order to analyze this in more detail, one would need to read the referred files with javascript.
The first error occurs when a variables or objects length is requested on line number 235, and seems to be related to the logging function.

It's possible that the DANCE and Cisco shared some common resource that was deleted by the DANCE uninstaller.
Try reinstalling Cisco.

If the problem persists, then we can have a closer look.

Collapse -

done to no avail

by lamentofking In reply to Well

I reinstalled it and it still does the same thing. Anything else I can do?

Collapse -

Look for next clues

by TobiF In reply to done to no avail

So, now you need to look for your next set of clues.
Those error messages give detailed position, where these error occur, with line and column reference to a couple of js files on your computer. So you should have a look.

js means javascript. You can read them with notepad.
When you've find what object is referred, if that one doesn't immediately give away what you're looking for, then search for other places in the code where the same object is mentioned.

Good luck! (You're going to need it!)

Collapse -

Not Really Good at Code so....

by lamentofking In reply to Look for next clues

I don't know how to read it or what it means so maybe you do. Here are the files:

Collapse -

Have you tried?

by TobiF In reply to Not Really Good at Code s ...

Looked at the first file, row 235, col 3 contains this:
if (logString.length>0)

In general, things look logical there.

Next, I looked up NAC agent and noted that Cisco even supplies a special browser. Perhaps you should try running the agent on their browser, in case there are nitty-gritty differences between different versions of javascript?

Collapse -

That's the Problem....

by lamentofking In reply to Have you tried?

I can't run the agent period because of that script error. I think if that error gets fixed then the agent will run.

Collapse -

Try setting that Cisco browser as the default browser

by TobiF In reply to That's the Problem....

At least for the installation.
If, later on, the agent is opened from within a browser, you could always call it fom that browser (if the browser accepts a url as argument on the command strin.)

Collapse -

The trick is to reply on the previous level :)

by TobiF In reply to That's the Problem....

<b>In a private message, lamentofkin@... wrote:</b>
<i>Apparently I can't reply anymore since I've reached the maximum level. The software client still won't start up. Even with the default browser changed I'm still getting ie script errors. Should I uninstall IE?</i>

My reply: You need to experiment a bit.
It surprises me that you get errors from IE, if you've changed the default browser. Maybe the installation is hardcoded to IE.

Next step now is to wait for Cisco support to open for the new week, and ask them what they suggest.
And, afterwards post back here with a quick outcome, since you've got us a bit hooked. :)

Edited formatting.

Collapse -

No Go

by lamentofking In reply to That's the Problem....

Cisco can't fix it. So Now What?

Collapse -


by TobiF In reply to That's the Problem....

Amazing. Seems they want you to go somewhere else next time...

On what system are you trying to install this wonderful piece of code? Maybe you should try a couple of different systems?
XP, Vista... IE7, IE8... Check that your dotnet engine is updated (or not, BTW)...

Related Discussions

Related Forums