Browser

General discussion

[Solved] I Cannot play web videos in all my portable browsers..

By hosa ·
My problem is a strange one... Even after Alot of Googling, I have yet to find any post that complain of the same issue..

For the past couple of years, I have ONLY been using portable browsers (Firefox and Opera..), videos were working fine until I started using another PC.. Now, All web video sites dont work, EXCEPT for Youtube! ( definitely need an explanation for that too)

What I did in attempt to fix the problem:

fully updated the browsers
tried different codec packs
made sure Graphics driver is the latest version
tried both enabling and disabling Hardware acceleration
made sure extensions are not the problem
went as far as installing the outdated Adobe Flash..
More information plus venting:

Most sites, such as Dailymotion gave me a bogus (browser outdated) or very vague error that did not help for googling at all, other sites simply did not show any error just black screen..

I was like alright.. I need to think out of the box.. So I installed a normal setup executable browser and it freaking worked.. But I was even more furious now because of the fact that there was no information on the internet, browser guides or help boards that mention that portable browsers work differently than installed ones and that perhaps I might face problems.. No one told me to treat portable browsers any different..

Still havent been able to actually fix my situation though...

Extra note: It is also worth to mention that the portable browsers aren't exactly running smoothly they are a bit too laggy I think maybe they cant utilize and communicate with my hardware for some reason.

System information:

-Windows 8.1 (x64) Core (N) <-- (means no Windows Media Player, the cause maybe?)
-very old laptop

Note: (Please excuse me guys for posting the same issue on other forums, because its just not getting any replies and being buried..
Thread display: Collapse - | Expand +

All Comments

Collapse -

Certainly the no WMP is a factor.

by rproffitt Moderator In reply to [Solved] I Cannot play we ...

I ran into this at the office where an app failed on 2 client computers. We tracked it down to the Windows N version. We had to update our product specs to mention these versions were not supported. Given we only encountered 2 cases in 5 years, it's not cost effective to go through a development cycle for these 2 machines.

Another issue is your choice of portable browsers. This is yet another reason I see it can fail.

-> Sorry but no, I think this is what it is. Just something that may or may not work. Also, not broken but working as per the user's choice of how to use Windows.

Collapse -

Thank You

by hosa In reply to Certainly the no WMP is a ...

You cannot imagine how relieved I am to finally understand the cause of my frustration...

At least I have closure, now that I know..
It is not exactly common well known information for some reason..

Collapse -

You fixed it.

by rproffitt Moderator In reply to [Solved] I Cannot play we ...

1. In your post you wrote "I installed a normal setup executable browser and it freaking worked." This verifies (again) that portable apps give up performance and maybe more to be portable.

2. About speed. Dated issue that I decline to do more research on is noted at
https://portableapps.com/node/14100

3. YouTube is google so they (mostly) encode to be played in browsers without having to add CODECS or other players.

I don't want to be dismissive here but .. all this, true. Again, from my view as a long time developer is it's not broken because portable browsers have different goals than the full installed versions.

Collapse -

So, I don't have a choice?

by hosa In reply to You fixed it.

Does this mean I HAVE to use a regular installable browser?
I never imagined I would run into that kind of problem..
Wait, can't I Install WMP?

Collapse -

Or wait till such evolve, get fixed.

by rproffitt Moderator In reply to So, I don't have a choice ...

But the issue of Windows N did bring back memories where we had to make a decision. After estimating how much it would cost to get the company apps to function on that version just for 2 users, well, you know what happened.

-> Back to the portable apps.
1. There is a speed hit that has been around for some time. I dug up one to get you some information and a possible workaround or setting.
2. If there is a bug, then you have to report it or they won't know. Again, I don't want to sound dismissive but it's time to take the bug/issue/limitation back to the bug report sites.

https://portableapps.com/node/28593 for example.

Collapse -

But

by hosa In reply to Or wait till such evolve, ...

I am not using the version from PortableApps ..
I am using the official portable version..

Collapse -

Then use their bug report system.

by rproffitt Moderator In reply to But

I try my best to give all correct links but at times have to guess at the smaller details.

Related Discussions

Related Forums