General discussion


Red Question Mark over my printer icon

By candace1x ·
I have installed all of the drivers for my locally attached printer (hp laserjet m1522 mfp series). when ever I try printing I notice the red question mark over my printer icon and it will not print at all. My operating system is windows xp professional.

I have tried all of the troubleshooting like changing the port, reinstalling the drivers, etc.

Any suggestions...

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

Click on Start

by HAL 9000 Moderator In reply to Red Question Mark over my ...

Then when the Start Menu Appears left click on Printers & Fax's and then when that Window Opens Right Click on the HP M1552 Printer and select Proprieties from the Drop Down List. When the next window opens Left Click on the Ports Tab.

See what the printer is set to here and alter as necessary.


Collapse -

Your printer is not properly installed

by NickNielsen In reply to Red Question Mark over my ...

Try the following:

Right-click on the printer icon and select Properties. Click on the Advanced tab and verify the correct printer driver is installed. If not, click the New Driver button and install the correct drivers. (You may need to download the appropriate driver file from <a href="">here</a>. Try the PCL6 driver package).

If this does not work, you will need to uninstall and reinstall the printer.

Disconnect the printer and delete the printer and any copies from the Printers and Faxes folder. Uninstall the drivers and any software.

Connect your printer and turn it on. Windows should detect the new device and try to install the drivers.

If Windows doesn't automatically detect the printer, open the Printers folder (Start | Settings | Printers) and click "Add a Printer". Click Next, then select "Local Printer attached to this computer". Check the "Automatically detect my plug and play printer" button, then click Next. Windows should now find your printer, assign a port, and install the drivers. (You may have to specify the search location for the drivers.)

If this doesn't work, change cables and try again. If the printer still won't install, it may need service or a software update, but you will definitely need local assistance.

Collapse -

After doing what the others said, and if it still doesn't work

by Deadly Ernest In reply to Red Question Mark over my ...

check what TYPE of connection you've got the printer plugged in as - serial, parallel, or USB - then reboot, open the BIOS setting and check the settings there for how it expects the printer to be connected, also check your USB settings.

Next check is the port the printer driver thinks the printer is connected to, against what it actually is connected to. A parallel connection will be LPT1 while a USB connection will probably be Com 3 or Com 4 and a serial as Com 2.

Check cables are plugged in tight, especially important with USB cables.

If USB, check the printer device and the BIOS settings for USB match - can have problems if printer is USB 2 while BIOS and motherboard are USB 1.

Related Discussions

Related Forums