USB to parallel adapter issue

By prof890 ·
I have the following printing issue that I would like to resolve ASAP.

I have recently bought a new pc with Windows 7 Ultimate 64-bit Edition. This pc does not have any parallel or serial ports installed i.e. I can only use USB ports for printer, mouse etc. My old pc is running Windows 98 OS. I also have an old dot matrix Citizen 200GX printer.

Because Windows 7 doesn?t come with a printer driver for the Citizen 200GX printer I tried using other Citizen drivers on my old Windows 98 pc and found the Citizen GSX-190 printer driver to be compatible with the Citizen 200GX printer and worked perfectly using both the black and colour ribbon without changing any of the dip switch settings.

Because of this, I found and installed the Citizen 190-GSX printer driver on my new Windows 7 pc. I tried doing a test print on my new pc using a USB to parallel (centronics) printer adapter by going into Properties in the GSX-190 printer driver setup but this didn?t work. I haven?t been able to print anything from any other program also.

Is anyone able to suggest a solution to this? There are 2 main programs I am trying to print from ? a Microsoft program Visual Foxpro 7 and secondly from a program called ZTree for Windows (based on Xtree Gold ? is a file manager program).

I would greatly appreciate help in resolving this ASAP. If not the only other solution I am considering is to buy a cheap Windows XP pc that uses a parallel port and not a USB for printing and has a printer driver for the Citizen 200GX. However, I am hoping that there is a cheaper solution to this problem.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Related Discussions

Related Forums