Why is this happening on only one site

By chrisjs55 ·
This is happening on one site only from my PC, I can log into the site from other PC's and on Safari on my phone. Any ideas?

1. It tells me ID is incorrect (it's not)
2.Tells me to select I'm not a robt to continue
3. has the Captcha Box (which the site does not have if you login anywhere else) that displays the error message, ERROR for site owner: Invalid domain for Key.

I have tried all the usuals claring cookies, browsing history and tring on another two browsers but still the same result. Not the firewall McAfee as same firewall installed under same account on PC next to me.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: PC

by Kees_B Moderator In reply to Why is this happening on ...

If it works on all other PC's, it's very likely that it will work on this PC after a clean reinstall of the OS (Windows or Linux, you didn't tell).

Collapse -

Short of a reload of the OS.

by rproffitt Moderator In reply to Why is this happening on ...

I usually try another ACCOUNT on the cranky PC to see if it's account related.

Collapse -

Not cranky

by chrisjs55 In reply to Short of a reload of the ...

It's not a cranky PC, it is one year old and high speck

Collapse -

And yet, here we are?

by rproffitt Moderator In reply to Not cranky

Did you try another account on this PC?

Collapse -

Icognito? VPN? secure HTTP?

by paanmc In reply to Why is this happening on ...

Random ideas...
Does it make it better (or worse) if you try using an Inconito / Anoymous window with your Browser?
Are you coming in from a VPN that changes the region you appear to come from? (not knowing the site you are logging in to, perhaps it's limited as to where it allows you in from to make sure it's you).
If you manually typed the URL, could you have used HTTP instead of HTTPS?

Collapse -

Why is this happening

by chrisjs55 In reply to Icognito? VPN? secure HTT ...

Thank you very much for your input, much appreciated. The HTTP doen't make any difference and have tried a vpn extension, designated as different countries with no result

Related Discussions

Related Forums